Problem with sketchup lines

  • Hello, I'm having problems with sketchup lines appearing in the render even though they shouldn't. I'm not shure it's a bug. I'm attaching a screen shot that should be self explanatory. I normally model this way because I use the 3d file for architectural documentation. So it would be nice if I could render without those lines. At the moment I have to unite all the geometry with boolean op.


    Best regards,


    Caetano

  • Hello Gadget,


    Actually they're on the same plane. I've done some tests like yours, with only a few boxes and it goes well. The problem seems to happen in bigger models.

    I just forgot to mention that I'm using SU 2017, latest preview version, Win 10 Pro and GTX 1080.

  • Yes, actually I've tried puting textures and white mode, and always the same result. I changed the color to that dark gray to show the problem better. Actually the house is white. I'll upload the model with no textures here. Maybe you can give it a try? Just apply some colors or textures (dark ones show the problem better). I've installed the latest nvidia drivers and the problem still persists.

  • Hello Gadget,


    thanks for taking the time to test. If it's not ask much, could you do another test with this file I'm attaching in this post? I've painted the faces with a dark color. After you open the enscape viewport, try to move the model a little bit.


    Cheers,


    Caetano

  • Hey caecarvalho,


    thanks for bringing this up, that's an interesting issue you got there. I tried it with your project and didn't see any lines in Enscape 2.1.2. Could you check the [About] window and tell me what version of Enscape you're using?

  • Hello Kaj,


    I'm using version 2.1.2.628-ge5bc706. SU 2017, win 10 pro and GTX 1080 with latest driver. I've tested some old projects and got the same result. Another strange issue is that when I draw some boxes and put them on top of each other in the same file, the lines don't show, but in the house they still show (see screen capture 03). I'm sending a few more screen shots of this project and the link for you to download another project that I've done some time ago where the lines are even more apparent.

    Please download the file here: https://www.dropbox.com/sh/8ev…oQV_nFAK62dHdSZCde5a?dl=0

  • Hey Caecarvalho,


    sorry, I was wrong. I tried reproducing the issue with Enscape 2.1.2.7 Yesterday on my home computer and apparently just didn't see the lines.

    I now tested a little more carefully - they appear with your project in both, 2.1.2.7 and the version you are currently using.


    I tested in the same project by simply pulling out a cube with multiple intersections - no lines visible.


    I have to side with Gadget here, it seems to me as if your lines aren't exactly on the same plane - could you check that?

  • It's some kind of Z-Fighting. Take a look at this example:



    These are perfectly aligned red rectangles. If you reduce the space between them to zero, the border of the green rectangle still shines through. This is caused by Z-fighting, the red and green rectangles simply share the same edge.


    Your model is built in the same way. There are horizontal parts between the different groups, and they are unpainted, so they use the white default material. You need to remove the horizontal parts or paint them with the same material.

  • OK - I can reproduce the error (in your model - does not occur in any of mine, but I know why...)

    The problem (I think) is because some faces at 90º to the visible ones have a different fill (or no fill/default fill). Or that the edge lines have no fill. Personally I only ever apply a fill to a group, never just a single surface; an extra step while modeling that saves clicking around my model later to colour-in.


    I fixed it by selecting everything within the group, filling it with 'default', then exiting the group and filling the group with the dark colour.


    <edit> Having the touching faces the same colour fixes the Z fighting too - but I think removing them as suggested above is the better solution.

  • Hello Guys,


    Thank you for all the replys.


    Yes, that's defnetely the z fighting.

    For me, painting the group from outside and not the faces inside, is not a good option since you loose control over the uvs, and removing the perpendicular faces would be a cumbersome process.

    I've found that if you want to paint the faces directly and not have this issue, you have to paint the faces in both sides with the same material, including the perpendicular faces.

    I noticed that enscape recognizes both faces in a sketchup plane, meaning you can have one material in the frontface and a diferent material in the backface, and it will render them both. I use v-ray and Thea render as well, and they don't recognize both faces of a plane as 2 different faces, meaning if you apply one material in the frontface, it will automatically apply to the backface at render time. Don't know if that's why I don't have this issue with them.

    Is this possible with enscape or is there any possibility for not having this z fighting issue?( Without having to change my painting/texturing workflow?)


    PS: I've noticed that in simpler models, like a few boxes on top of each other, there's no z fighting. I can paint only the front faces and no perpendicular faces and the lines won't show up... You can see in the screen shot I've attached to this post.

  • Great to find that I was not alone with this issue. Great explanation. I suggest to you guy to make a tutorial with the best practice for modelling using Enscape. This will make people like me more happy to learn before get frustrated with something like this. I spend almost all the day looking what was causing the problem with the line. Because only I got the issue with Enscape.