Worksession Issues

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • I'm running into issues when worksessioning large files. Some materials come out fine, but some are mapped incorrectly, and some are rendered completely white. It's inconsistent with which materials get this treatment - making it harder to pin down exactly what is going on. The workaround has been to worksession everything in to one empty file - but even this needs to be done every time from scratch. The issue comes up again when opening that worksession file to export from. I've tried to be careful in naming materials - giving materials in each worksessioned file it's own unique name (eg. ZONE 2-DARK WOOD...) just in case there was some error or conflict in worksession materials with the same name, but still no luck.

    Has anyone else encountered this? Any suggestions? Making a new worksession file before final export isn't a deal breaker or anything, but it is kind of a pain.

    many thanks!

  • I don't work in Revit, but it sounds like possibly file pathing issue? if its a worksessioning file, would there be other teams in and out of the file? My first guess is that there is a texture they used local to another machine (on their desktop or local downloads folder) that you may not have access to via the network. rather than run down a rabbit hole, you could do a quick check to rule it out at least.

    Create a simple worksession file with a custom material that is only on your computer and then have another person on the network check to see if that texture renders correctly on their machine. If you see the same results as you've outlined above, i believe you'll have the culprit, if not its time to keep troubleshooting.

  • Hey Ted - thanks for the response. I don't think that's it though. I've been careful to make sure that everything is mapped correctly on the network, and even saved everything to my desktop and remapped the (I thought) problem materials there. I'm thinking it's more of a size issue and so I guess I'm wondering if there are size limitations that we should be aware of - either distance in model, or size of models and worksession files. The offending collection of files was 9 worksession files varying from 120KB geometry files to 400KB landscape files to 750KB city context files. The complete Enscape .exe that saves out from this is around 850KB. The only thing I've had crash enscape so far is a full-city context model, but this isn't nearly as big or complete as that. It could be my machine and Rhino, and not Enscape that is the problem. The worksession files take a while to load in the first place, but once they're in they are generally okay to work with. Anyway - I'll keep at it and if there is a consistent way to duplicate the problem, or a solution I'll happily post it.

  • Ohhh, okay, when you said worksession file I for some reason assumed you were in Revit instead of Rhino. Yeah, since Rhino is their beta I wonder if this has come up before. Hey Micha have you seen anything like this in your work with Enscape for Rhino? I think you have the most experience here so far so I thought you might know a solve or a workaround.

  • Sorry, no idea.

    Is a worksession file a file that contain linked blocks? (I'm not sure about what "worksession" is.) In the past only I used embed blocks during an Enscape project and this was fine. But some days before I started to use linked blocks and wasn't happy. I ask at the Rhino forum how to handle materials of linked blocks, but no answer yet.

    Maybe some Rhino users could show her interest for a solution here. (If it is to OT, forget it, I don't want to enter the thread here.)

  • Worksession is the rhino command to link multiple .3dm files. We use it for (as an example) multiple buildings in the same development, or as a way to keep file size manageable with complex models - interior may be one model, facade may be one model, landscape may be one model etc. It's odd though, b/c I only get these kinds of errors when I worksession in the large (physical distance) context models, even though they may not be the biggest (size) models - and it is happening in all three projects I'm currently working on.

    building model alone - okay in Enscape

    building model + landscape - okay in Enscape

    building model + landscape + context model - unpredictable material color and mapping in Enscape

    context model alone - okay in Enscape

    The solution (so far) is to:

    -open a new file

    -set the units

    -import the saved views

    -worksession in each file (one at a time) and refreshing Enscape when each one loads

    -export the .exe

    For the most part that works - but it is pretty time consuming. It would be nice if we were able to use a saved worksession file (.rws) and get the expected results.

    • Official Post

    I'm having the same issues!
    Running Enscape 2.7.1+20886
    Rhino 6.0

    Has there been a fix? Or is there a suggested workflow?

    I'm sorry to hear about that - this should've been resolved already of course. It cannot hurt to give Enscape 2.7.2 a try just to make sure, otherwise can you also send in a feedback report please?…sing-the-feedback-button/

    Just include a link to this thread for reference, that would be very helpful.

    Thanks a lot in advance.