Material Mapping

  • Hi,


    First off I think enscape is heading in the right direction to be a top notch plugin when it is finished!:thumbsup:


    However, I seem to be having some issues with material mapping. Sometimes enscape picks up the rhino mapping as expected and but then after both enscape and the rhino file are closed and reopened sometimes the mapping is ignored, this can happen both globally and on an object by object basis? Any Ideas how to avoid this?


    Also one thing that I would find really useful, is a way to force Enscape to update its geometry to the latest changes in rhino, especially in fixed view, sometimes it take a moment to update when something is hidden/shown ect...


    Thanks

    T

  • Further testing, one method for sorting the mapping issue is:


    - Change material to another temporary material

    - Then change it back to the desired material


    Then the material seems to stay correct for the remainder of that rhino session?

  • Alternatively, If the issue is with the texture mapping defaulting to the default 1x1 repeat mapping in material menu, a similar trick seems to fix it for the remainder of the session:


    - In the material, under the color, remember the repeat value, change the repeat to 1(or any number) press okay, then Enscape updates

    - Then do the same again but change the number back to the actual value

  • tomN Can you share a project with that erroneous behavior? I think I have encountered this same error once (texture mapping defaulted to 1x1 repeat), but was not able to reproduce since and unfortunately I haven't saved the project. I think this is an error in Rhino itself (or I'm misunderstanding a flag in the API).


    and what do you mean by "mapping is ignored"? You mean the UV texture coords or the material selection for the objects? (The latter should be fixed since 2.1.3.1901). What version of Enscape do you use?


    You can update the whole Enscape window manually by clicking the start icon while Enscape is opened (but if you have to do that, it is a bug and you should report it)

  • Hi Simon


    Unfortunately I can not send the model due to confidential agreements, But I can reproduce it on a simplified model:


    In the example Attached the mapping was set up in the first session, screenshots taken and then all instances of both rhino and enscape closed (See Mapping01 and Mapping02)


    Then the file reopened, and the rhino mapping remains as expected but the enscape mapping has defaulted to 1x1 mapping. (See Mapping03 and Mapping04)


    The material used is the stripe material that ships with rhino for repeatably your end.


    By "mapping is ignored" I am referring to the UV of the Mapping, material selection for the objects is as expected. Version 2.2.0.93


    Regarding the updating of the enscape window, on large models when large amounts of geometry is switched off or on, enscape takes a moment or two to update, (which can be expected) but sometime I think it does not start the update process in the enscape window until the window is refocus/ enscape view is changed, Which can be frustrating when working on still views. It could be that enscape is updating in the background, but without a visual clue it is difficult to tell. I know sometimes a green arrow/ circle appears in the bottom left but that doesn't always appear in the scenarios I am experiencing.


    Keep up the great work!

    Tom

  • tomN   Nvizeon


    I tried to reproduce the wrong UV repeating like you described. I created the file with Rhino 5 and I saw the bug. This is like I said before caused by wrong values we retrieve via the Rhino API. Nothing we can do here.

    I also opened the Rhino 5 file in Rhino 6 and everything looked fine. I can also remember a wrong repeat pattern in Rhino 6 when it was still WIP. Looks like McNeel fixed this. Can you confirm that it's working in Rhino 6?


    As I understood from a previous request McNeel has no intention for another Rhino 5 update. So, if the problem is gone in Rhino 6 I'd like to close this from our side. Nevertheless I contacted them in their forum: https://discourse.mcneel.com/t…n-applyuvwtransform/59726

  • Thanks for looking into this unfortunately I am working in Rhino 5, so figures cross mcNeel can do something their end, in the mean time I have converted my fix into an automated python command which I can run at the start of any rhino session that I want to use enscape, so others with the same problem can try it:




    I have only tested on a few models but so far it works!

    Thanks

    T