WMR support: Troubleshooting

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • Been looking forward to native Windows Mixed Reality support for a while and was happy to see it was implemented in the latest release. However, we're having trouble getting Enscape to recognize our headset. I've made sure that our VR station has the most updated drivers for all of WMR and the headset (we're using a Samsung Odyssey) but Enscape does not find the headset when we Enable VR. I've looked over the support site trying to find if there are settings we need to set in Enscape but haven't found anything. If it helps, this is using the latest Enscape patch on SketchUp. We haven't started fully using Revit yet so I do not have Revit on this station to test if it works there. The headset works fine in both the Windows VR space and SteamVR and I'm still able to emulate being a Vive through SteamVR and use Enscape but as I've noted before, it's not optimal.


    Anyone else able to use WMR successfully? What was your experience?

    • Official Post

    and I'm still able to emulate being a Vive through SteamVR and use Enscape but as I've noted before, it's not optimal.


    Anyone else able to use WMR successfully? What was your experience?

    What do you mean by emulate a Vive? To run a MixedReality HMD with SteamVR you require "Windows Mixed Reality for SteamVR" and once installed it should detect the MR HMD with the controllers correctly (and not as a Vive). All necessary steps to set this up are described in detail here:

    https://enscape3d.com/knowledg…-virtual-reality-headset/

  • What do you mean by emulate a Vive? To run a MixedReality HMD with SteamVR you require "Windows Mixed Reality for SteamVR" and once installed it should detect the MR HMD with the controllers correctly (and not as a Vive). All necessary steps to set this up are described in detail here:

    https://enscape3d.com/knowledg…-virtual-reality-headset/


    I documented my experience here: Alternative VR HMD's (Head mounted Displays) When we connected our Odyssey through SteamVR (and WMR for SteamVR), SteamVR thinks it's a Vive. As I noted in the other thread, using Enscape (through SketchUp) in SteamVR resulted in a jerky, nausea-inducing experience with many graphic errors like walls jumping around and flickering in and out of existence. Other applications we tested within Steam and the Windows Mixed Reality interface were smooth at 60fps so the performance we were seeing was directly tied to Enscape itself.


    With the announcement that WMR is supported in the latest version of Enscape, I naturally assumed that it meant that WMR headsets were now recognized directly by Enscape and we no longer had to use the SteamVR workaround to get it functional.

    • Official Post

    With the announcement that WMR is supported in the latest version of Enscape, I naturally assumed that it meant that WMR headsets were now recognized directly by Enscape and we no longer had to use the SteamVR workaround to get it functional.



    Unfortunately this is not technically feasible for us at the moment due to the nature of the WMR SDK's implementation (among other things it's DirectX only).

    As I noted in the other thread, using Enscape (through SketchUp) in SteamVR resulted in a jerky, nausea-inducing experience with many graphic errors like walls jumping around and flickering in and out of existence. Other applications we tested within Steam and the Windows Mixed Reality interface were smooth at 60fps so the performance we were seeing was directly tied to Enscape itself.

    Which quality settings did you test Enscape with in VR and on what hardware? As stated in the knowledge base article due to the higher resolution of the WMR HMDs it might be required to lower quality settings to draft in order to get a smooth experience. Performance comparisons are a difficult topic as it depends on so much different factors like overall scene complexity, number of light sources, view perspective etc. So unfortunately it's impossible to guarantee a smooth performance in every case especially in comparison to small VR showcase applications that are essentially build all around the objective to optimize VR performance, which we can't do in case of your (architecture) projects.


    Hope that sheds some light on the issue :)

  • Unfortunately this is not technically feasible for us at the moment due to the nature of the WMR SDK's implementation (among other things it's DirectX only).

    Which quality settings did you test Enscape with in VR and on what hardware? As stated in the knowledge base article due to the higher resolution of the WMR HMDs it might be required to lower quality settings to draft in order to get a smooth experience. Performance comparisons are a difficult topic as it depends on so much different factors like overall scene complexity, number of light sources, view perspective etc. So unfortunately it's impossible to guarantee a smooth performance in every case especially in comparison to small VR showcase applications that are essentially build all around the objective to optimize VR performance, which we can't do in case of your (architecture) projects.


    Hope that sheds some light on the issue :)

    Thanks, Clemens! I lowered the settings to Draft and it's usable now. Smooth enough not to induce motion sickness. Using the move feature on the left stick (like you're walking) can be a bit disorienting. I chalk that up to my own experience because two other users who tried walking didn't report the same feeling.


    We do still get the shimmering textures but it isn't as widespread as before and might be something misaligned in our drawings.


    The rendered handsets are very jumpy. Not like they are tracking incorrectly, the animations and movement on-screen are erratic. They are usable even if the on-screen representation is flickering in and out of view. Not sure where the issue is here since the tracking and usability is fine.