Lag while using Windows Mixed Reality

  • I was using Enscape (via SketchUp) for VR using HTC Vive. Although I did observe some controller (mesh) lag, it was not too bad. I recently purchased Samsung HMD Odyssey, and while the head motion in Enscape is acceptable, the controllers lag a lot. So I would like some tips on how to reduce this lag. Just of note: this lag does not occur using any other VR applications. So I'd like to rule out controller connection/ latency issues.


    Software: SketchUp Pro 8, Enscape 2.2.1 etc. (newest version, although it's expired trail at the moment - I am looking to purchase it as soon as I get this under control)


    My Specs:

    Windows 10 Pro

    Intel Core i7 7800X

    64 GB DDR4 Ram

    Geforce GTX 1080 Ti


    I can upload my SketchUp file if need be. I would really just like to know if there are any tips or tricks I'm missing that would improve the performance. Also, I am not sure if this is the right category. If not, feel free to move it somewhere applicable.


    Thank you!

  • Hi Hume & welcome to our forums!


    We haven't heard of this kind of behaviour before. Neither Vive nor MR controllers should have a visible lag in Enscape if the overall performance is smooth.

    I assume you've already setup everything including the Mixed Reality for SteamVR app as described here?

    https://enscape3d.com/knowledg…-virtual-reality-headset/


    Did you try to lower the quality settings? Was there any improvement in the lag you experienced? We can of course have a look at the Sketchup file, but I'm afraid this is more of a system setup issue than scene related.

  • Hi Clemens,


    Thank you for the welcome and the reply!


    Here is what I found so far: I did go to that link, and yes everything is set up as far as I can tell. I even made sure my GPU drivers are up to date now also.


    I got the lag reduced by lowering the overall quality settings in Enscape to "draft" It looks kind of acceptable, but obviously not nearly as nice as it did on high. So in other words this has to do with my computer not being able to handle it? What would make this better then? Another GPU? Because I did not think the system requirements could be this extreme to be able to run on high (not ultra even). My scene at this moment is just a double story house, no furniture yet.



    But this does indicate a performance issue. Could this have anything to do with my scene in SketchUp? Like how I set it up? Maybe there is something I miss? Like I should group everything together, or something? I know this is more of a SketchUp question to ask though.


    I'm using two 4k monitors also, not sure if that has a performance impact on VR though?


    Thank for helping so far!

  • Hi ! Do you mind if I piggyback on this ? I use Enscape with Oculus and Revit with a GTX 980 Ti. I am looking at getting a more portable rig with a 17" Sager Latop w/ GTX 1080 & Core i7 8700 (http://www.sagernotebook.com/17-Laptops/) and switching the Oculus to a Samsung Odyssey HMD. I'm going for the Sager because of the number of USB connections which will also allow connecting the Oculus with 3 trackers for roomscale.

    Hume's specs sound pretty similar so would you mind sharing what was causing the lagging problem ? Is it Sketchup or something to do with the HMD ?

    Thanks

  • jfmonod the latest higher resolution HMD like the Windows Mixed Reality HMDs and the Vive Pro require much more GPU performance.

    =>The GPU has to render 80% more pixels, which is heavy.

    You should be able to use it quite fine in Medium quality.


    We will come up with further performance optimization for VR in the next versions.