Specular and Roughness not PBR?

  • There seems to be a difference between how we understood PBR and how Enscape handles it. I'm going to take the Unreal Engine as an example to compare Enscape to:


    Scenario 1

    • In Unreal, when you set Roughness, metallic and specular all to 0 = you get no reflections (expected)
    • In Enscape, when you set roughness, metallic and specular all to 0 = you still get reflections (not expected) see screenshots


    Scenario 2


    • In unreal, when you set roughness and metallic to 0 and specular to 0.1 = you get faint but sharp reflections (expected)
    • In Enscape faint but sharp reflections seems impossible to achieve?
  • The specular value (for both Unreal and Enscape) controls F0. This is the amount of reflected light at 0° angle, looking straight at the surface. F90 however approaches (almost) 1 for all materials, this is not changeable in both Unreal and Enscape.


    There's a special case when specular is very tiny (< 0.02) where all specular reflections are then being shut down to simulate that as a special case with even F90 approaching zero. Actually, the material should have no specular if specular is zero. We will check, thanks for reporting.

  • Thanks for your reply Thomas!


    So it sounds like Scenario 1 is going to get resolved.


    However, what we are really more interested in creating scenario 2 in Enscape. How can we simulate what we see in Unreal in Enscape? Will fixing Scenario 1 also fix scenario 2?


    Perhaps a different way of explaining: It sounds like unreal and enscape both assume almost 1 for specular on F90, but we're getting very clear reflections on F45 with very low values of specular (3%), while we don't see the same in Unreal (see comparison here below, same albedo). It seems like Enscape and Unreal interpolate the values between F0 and F90 differently (if interpolating is even the right word).


    I don't know if any of this makes sense. We're obviously not PBR experts, we're just having trouble realizing some material effects that seem to be fairly simple in Unreal. Perhaps we're missing something here.



  • The way how Fresnel is interpolated is a well defined physical model that is very similar (if not identical) in Unreal and Enscape. If you pick the identical exposure, identical albedo and environmental brightness, you should get almost identical results on that sphere.


    I just checked the specular=0 behavior, there's indeed a bug. Thanks for reporting, will be fixed soon!

  • Awesome work! I did a (very quick) test of both the PBR support and the fix for the specular range.


    Exactly what we wanted!


    The new Revit material shaders are much more intuitive to work with than the old ones. One slider for reflection, one for roughness. Everyone can understand that :)


    We have filed a request with Autodesk to have the ability to easily switch between shaders in the Revit material window (right now the only way to switch between Opaque or Metal for example, it so change the material with one from the library and start over with your settings). I'd be great if you guys could also file a similar request with Autodesk (see example in attachment).

  • The specular value (for both Unreal and Enscape) controls F0. This is the amount of reflected light at 0° angle, looking straight at the surface. F90 however approaches (almost) 1 for all materials, this is not changeable in both Unreal and Enscape.

    Hi Thomas,


    I understand the physical background. But under real life project conditions my clients told me - it looks to reflective. It could be nice to find a solution. Here some examples from Rhino:


    Physical correct - 100% and 0% reflectivity. From an artist view the lowest reflectivity isn't enough, the range to small.

      



    By adding some transparency Enscape jumps to an other mode, the diffuse lighting isn't full calculated anymore. But interesting is the nice wide range of reflectivity control. Couldn't this wide range not be enabled for non transparent materials too? OK, it's not physical correct, but for the artists freedom essential.

        


    I checked Vray for Rhino and there I can set any low reflectivity. Please try to open the range for Enscape user too.


  • Pieter, we released a hotfix today which included the fix for the specular range. It should work much better now!

    Hey Thomas,


    We were having issues with this again yesterday (we're on the latest release). Any chance this behavior was changed in the last few months.


    We have a material in Revit 2019, using the new material shader that came with Revit 2019 (opaque).

    Reflection set to 0

    Roughness set to 0


    The material is still reflecting.

  • The technically correct answer is that the reflection parameter controls the F0 Fresnel value (See various internet sources for explanation). If you set this value to zero and you look straight at the surface you won't get any specularity. At grazing angles, there is always a Fresnel component, also depending on the roughness that approaches F90, usually close to 1. In the case that Micha illustrated with his car, the specular reflection looks extreme because the skybox is really bright and the underlying albedo too dark.


    I understand you desire for more artistic freedom, but for the sake of plausible results and less risk of wrong behavior we have to limit the material properties to something that is at least "inspired" by reality.

  • Thanks for looking into it.


    We want to create a material like the blak wood in this picture :


    https://static1.squarespace.co…IMG_5922.jpg?format=2500w


    We tried all kind of methods but nothing is really working to create the deep 'gaps' between the panels. We tried putting 100% rough but then we get a grey look instead of black. Only when we put roughness to 0 we get a deep dark look, but then it starts reflecting even if we put specular to 0.


    I thought you said there was a special case when specular is very tiny (< 0.02) where all specular reflections are then being shut down to simulate that as a special case with even F90 approaching zero. So the material should have no specular if specular is zero.

  • We can create tje wood just fine, it's the gaps between them that we are struggling with.


    We can't model this in Revit, too much work and too much performance issues. So we're using a map that combines the slats and the gaps between them.


    We want the gaps to be deep dark, just like in the image but whatever settings we use we don't seem to get there.


    We need to use high values of roughness to get rid of the reflection but then our material looses its deep dark color and becomes Grey.

  • I can send you the files when I get back at the office in January.


    However, I must admit I'm confused here. In post #4 in this thread Thomas acknowledged there was a bug with specular 0 and it would be fixed.


    Now I'm reporting the same behavior from Revit (the original post was about the specular 0 setting in Sketchup) and we're debating again whether this is a bug or not?

  • However, I must admit I'm confused here. In post #4 in this thread Thomas acknowledged there was a bug with specular 0 and it would be fixed.

    That's a post from April this year. This has been fixed long ago ;)

    I can send you the files when I get back at the office in January.

    Thx, appreciate your help!