Custom Assets Library | 3D Warehouse Models | Wrong scale

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • I just tried to export a 3D Warehouse model as a .obj to import it back to the new Custom Assets Library.


    Everything works fine to me except the scaling.


    Here is the steps I did:


    1. Import the 3D Warehouse Model into my drawing (the scale is already good)


    2. Export as a .obj (without the lady)


    3. Added the .obj file to the Custom Assets Library. Everything looks fine a this point. I saved and generated it.


    4. When I use the asset that I just created and then add it next to the original model, the scale comes so wrong.


    Any idea of what I'm doing wrong? Obviously, I hope that we don't have to scale all the assets manually even if the original model is well scaled.


    I hope you could help me!


    Good day! :)

  • Hi Raphel,


    Looks to me that all you need to do is change the scaling of the object in the Custom Asset editor, currently set to 39.91meters!


    If you look to the top right above the preview of the chair, there are some options, the top one is scaling. It seems that currently you always need to do this with files brought into the asset generator.


    Hope this helps you

  • It seems that currently you always need to do this with files brought into the asset generator.

    I believe this is the case because the Custom Asset editor ignores the units and interprets everything as meters. So if the objects was exported using any other unit, it will not be in the correct scale in the Custom Asset editor.


    Most probably Raphael's model was in inches, so 39.91 inches became 39.91 meters.


    39.91 inches is approximately 1 meter, so he can change the X measurement to 1, and Y and Z will be also automatically scale accordingly.


    Or, a better way in this case, in step 2, at the Export screen to click on the "options" button on the bottom and select "Meters" from the drop down menu.

  • I believe this is the case because the Custom Asset editor ignores the units and interprets everything as meters. So if the objects was exported using any other unit, it will not be in the correct scale in the Custom Asset editor.

    Unfortunately .Obj is a unitless format, so there is nothing more the Enscape asset editor can do. You either need to set the .obj to meters (when exporting it) or you need to scale it afterwards in the asset editor.