Materials - invalid Texture

Reminder: If you encounter any issues with Enscape (including installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Feedback button as detailed here. Thank you for your understanding.
  • This happens quite a bit with files that have been imported from Transmutr and I am sure from other imports. I just purchased a set of SketchUp models from Globe Plants and all of the models are like this when I open them. Any reason why Enscape can't just resolve this on its own by looking in the same folder of the SKP file and re-path all of these things? Huge giant pain to fix this.

  • I am not loading them into the asset editor. I am loading these as a linked file. This also occurs if I just open the model and try to render on its own.

    I am using the latest public release 2.90.

  • This is because of the lack of relative path support in Enscape.


    In Transmutr, do you have "Absolute paths" enabled in the options? If so, does it happen with files you have moved after export from Transmutr?


    We have a new extension coming that aims at fixing this issue. It is a file browser (that replaces the Skatter library browser), that lets you import files and automatically performs path rewriting on-the-fly for maps and proxies.

    It will be released alongside Skatter 2.0. As you are part of the Skatter beta, you'll be able to test it in the upcoming beta version.

  • I have absolute paths turned off. I have come across this issue with some files imported via Transmutr though, but it hasn't been that much of an issue lately.


    This case I am reporting right now is not something from Transmutr. I purchased a set of plants from Globe Plants in SKP format, so I am not sure what system they used to get the files into SketchUp. It's just too bad that Enscape doesn't look in the location of a proxy to find its assets. This is going to be a huge pain to remap all the assets one by one for an entire collection.

  • There is a ReadMe.txt file provided when you purchase Globe Plants assets. It says:


    Quote

    For SketchUp and Enscape Render users, please follow the steps below to get materials and textures load properly:


    - Create a new folder at the root of C drive called “Globeplants_Enscape”. It should be C:\Globeplants_Enscape


    - Copy all files from folder SKETCHUP into the newly created folder. You can copy all the proxy files into other folders as you like as they won’t be affected by user path. The proxy files are SketchUp files without extended name “ _fullGeometry”


    I agree that this txt file is not very obvious!

  • This happens quite a bit with files that have been imported from Transmutr and I am sure from other imports. I just purchased a set of SketchUp models from Globe Plants and all of the models are like this when I open them. Any reason why Enscape can't just resolve this on its own by looking in the same folder of the SKP file and re-path all of these things? Huge giant pain to fix this.

    Yes VStudio it is a huge giant pain!

    Please Enscape team let this be fixed with your next version release. It costs your users soooo much time!