Enscape 3 - extended render time

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • Hi all,


    I have a model that is now getting quite 'old' ie. project began in 2019 and has been through multiple versions of Enscape. Now upgraded to the latest (3.0.1)

    It's moderate complexity with some big pieces of geometry as disjoint meshes in rhino - 1gb file.

    There are also some NURBS elements that were exported from Revit. Also a fair few assets that were placed from earlier version of Enscape 2, etc, so it's been building up over time.

    I've got a decent laptop and spinning around the Enscape model is smooth with everything turned on / full settings, even in VR.


    I'm noticing that 3 actions take significant time to complete:

    - Turning layers on and off in Rhino and updating the Enscape view - 2 - 5 mins

    - Changing named view from the Enscape view management toolbar - 2 - 5 mins

    - Rendering a view (even if it's only HD) - 5 - 10+ mins. The 'export image' progress bar stays at 0% for like 10 mins and then takes 10 seconds to actually render.


    I don't remember these things taking this long in Enscape 2 with the same model.


    Things I tried:

    - SelBadObjects in Rhino to clean out bad geometry - a few things popped up and I deleted them and purged the file. (seemed to make a bit of an improvement.)

    - Turning off everything you can't see (no change?)

    - Meshing some big objects (ie. city model) (no change in Enscape but speeds up rhino)

    - Hiding all Enscape assets (slight improvement maybe related to less complexity though?)

    - Making sure Enscape material textures are mapped to a local file location (we use a cloud server usually) (no change?)

    - Some textures were large at around 5000 x 3000px jpg - tried turning those materials off (no change?)


    Can anyone suggest anything else to try here? This led to a pretty long day yesterday and I'm trying to fix before the next round of updates.


    thanks

    Nick

  • I've noticed some of the same issues with a medium sized residential model I am working on. In enscape 2.9 as long as the model was opened with say a brick enscape texture in it, any object I changed to that material would change when the enscape window was open. Now it wont change unless the file is reopened in enscape. Rendering itself is taking longer with no noticeable change to the output of the rendering. Hopefully a future preview version will fix some of these issues.

    • Official Post

    You can do that directly via Enscape's Feedback button as described here, it automatically sends your log files (if you don't opt out):

    https://enscape3d.com/communit…sing-the-feedback-button/

    • Official Post

    ok Feedback sent, I can't remember if we opted in or out to feedback. let me know if you don't get it!

    thanks

    Nick

    We don't have your e-mail address so I advise you to simply wait 1-3 days, and if you do not get a reply, please get back to us. Then, you can also send me your e-mail address via a DM and I'll check our system for any reports via that e-mail, or lack thereof.

  • hi all, just wanted to close this thread out with the fix.


    There were a few objects in the file that had custom render meshes set up. (they were curved geometry that would otherwise appear faceted in enscape.) Something had happened where these seemed to be taking a really long time for enscape to process. I don't know if the custom meshes were just extremely detailed or if they got otherwise broken over time - the file had been upgraded from rhino 6 to 7, converted from meters to mm, enscape 2 to 3 etc.


    The fix was just to select all and un-tick custom render meshes in the rhino properties palette to clear the custom meshes. Seems to be performing well again.

    Thanks Enscape team for your help.


    Nick

    • Official Post

    That is good to know - and I'm grateful to hear you found a solution. :)