Light Fixtures Incorrectly Casting Shadows On Themselves

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • Is there a way to stop this from happening? This happens for every light I've worked with, including ones from manufacturers with properly made IES files (I've tested them and they work fine in Revit's default rendering engine...). For most lights, this isn't a big deal, but for some (including the below) it's a huge problem.


    Basically, Enscape always casts shadows on my own light fixtures regardless of what IES data says to do or how the fixture is built, except if the material is set to glass/transparent, or if the light source is placed within a part of a mesh. For most fixtures... this isn't a huge deal, but some of them (sconces especially) it looks awful. The only workaround I've been able to figure out is to set the fixture material to something semi-transparent to get Enscape to ignore it on self-shadowing, but this obviously doesn't work in cases like the below.


    How do I get the light fixture to look correct in the below image? Or is there a way to force enscape to NOT cast shadows on certain materials? Adjusting diameter of the light seems to do nothing in Enscape. For comparison, I've also included what the Revit render outputs, which is much closer to accurate.

  • I'm not sure why you believe that Enscape is rendering the light incorrectly. If the light source is in the center of the bulb and you have an opaque bottom to the fixture the light will cast a shadow. You could turn down the intensity of the light source which will diminish the appearance of the shadow. In the image on the right it also appears that the globe material has self illumination.

  • The problem is more that in Enscape light only seems to ever eminante from the origin point at the center of an IES or lighting element (causing shadowing) which isn't accurate in the sconce above where the light is actually projecting from the sphere as a whole. In the case like the above, there wouldn't be any dramatic shadows as the entire sphere is throwing light (not just the "center" of that sphere). But I've never been able to get Enscape to project light like this - even when setting up the light to emit from a sphere/circle/line, it always only projects from the center point, which causes the light element to cast incorrect shadows.


    If I force a light to only emit using the self-illumination material, then it smooths it out. But lighting only using self-illuminated materiales doesn't produce accurate light volumes/shadowing like IES profiles do, plus relying on them throws off the render output making it splotchy.


    I managed to workaround the above light fixture by forcing the stem + base of the sphere to cross into where the origin point of the light emitter is, thus making the light emitter "inside" of the stem/base of the fixture as well as the sphere, which was enough to tell Enscape to not cast shadows from those geometry elements. Still, would prefer a better solution, as this wouldn't work for every light geometry. Or maybe I'm doing something wrong and missing a key setting!

  • I have a problem with version of Enscape 2.9 and 3.x where the sphere light goes through objects and does not cast proper shadows and I have to use instead the Spot Light object to direct/restrict light... very annoying... Also, when trying to get softer light/shadows on the ceiling I have to lower the brightness so much that I cannot get the desired result in Enscape and have to use other renderer... (D5)...


    On this screenshot, the Hektar (Ikea) lamp shade should catch the light and prevent it from bleeding/passing through as if it were translucent material... I even tested placing another sphere on the desk surrounded by a double-walled cylinder and the light of that lower-placed sphere even showed on the floor on the other side of the wall... like why???


    Why is there direct light on the wall behind the Hektar shade? I can only avoid that using the spot light... Why is light passing through walls and double walls?


    This screenshot is now v 3.0.1 non-preview... I also tried it with V 2.9 of Enscape... same thing...