Assets can not be placed (No 3D view selected)

  • I'm getting the following prompt "asset cannot be placed, no 3d view selected" when attempting to place any asset. I've read that activating the offline assets might help but it didn't. Also updated enscape to the latest.

    Obviously tried in 3d views etc.


    Thank you

  • Hans4123 , welcome to our Forum and thanks for your report - If you select a different 3D View does it work just fine? Or are you really completely unable to place any Assets what so ever no matter the view? Since I cannot reproduce this right now on my machine, is there perhaps even a chance for you to share this project with me? I can provide a dedicated safe upload link should that be possible.

  • Hi Demian Gutberlet - This happens across multiple projects so I don't think its project specific. I also just tried on a brand new 'construction template' project, same result.

    I have tried the placing command in plan view, 3d axon views, 3d perspectives, with Enscape running or not. Really quite odd, always same result.

  • Hans4123 , I'm sorry to hear about that - this is indeed not the wanted behaviour, so can you please also send us a feedback report? We should then at least be able to look at your log files and machine information to figure out the cause behind this. For reference, feel free to include a link to this thread in the submission form before hitting the Send button.

  • Hello! I have the same problem. Did you find a solution?

    Welcome to our Forum.


    Asking right away even though it may be trivial of course, but you did select a dedicated 3D view before trying to place Assets, correct? If so, please also send in a Feedback report as described just above in my previous reply. Thanks a lot!

  • I created Enscape new 3d view and after i started to put in plan objects from library. Do you mean i must turn off 3d connection with enscape or just create exactly a new 3d view from enscape? replay please with a screenshot. Thank you a lot!

  • Hi aleksandra0605


    My colleague meant being in a 3D view in Revit, but as you mentioned you created a 3D view in Enscape I assume this was the case.


    Could you please send us a feedback report via the Enscape Feedback Button in that case.


    And please also add a link to this thread in the description for context.

  • I have this same problem in both Revit versions I use 2019 and 2021. Advice I got from Feedback submission was to uninstall and reinstall both Revit and Enscape which I have done but still encounter the same issue. I have also tried previous and "preview" releases of Enscape...all have the same problem. It seems once you get this error it is a plague that wont go away. I am considering do an entire machine reformat to address this one error ;-(

    Only workaround I have found is to assign Enscape assets to other Revit families.

  • Please try deleting the default 3-D view in Revit and then re-creating it. You may also need to open the default 3-D view before placing the asset. Finally make sure that your work plane is set to the appropriate level.

  • Thanks for the suggestions Phil. I had not thought to try those, but unfortunately neither produced any different result.

    I should note I have this problem universally - old projects that worked fine with Enscape previously to completely new blank projects. Both Revit 2019 and 2021. Any views - plan, 3d, camera.

    Only progress so far is my latest office joke:


    What do you call a broken installation of Enscape?


    The Revit Render Window.

  • I started a new thread not knowing this one was here. oops. I'm getting the same error message. It is very rare to never that I place assets in a 3D view. I'm typically placing them in plan views. Currently, I am able to place 'Custom Assets' but no 'Enscape Assets'.

  • BTW I'm using Revit 2020. Not specifically. It seems to choke up going from the custom asset editor back to the asset library. First time I got the error message I just shut everything down and restarted. Of course no change. The Enscape update did get installed last week. I have been using it all week no problem but I haven't been placing assets until today. Mostly modeling.

  • Hey everyone - that's for the updates. I've gotten this message before I was able to do some thing and keep going but I can't remember why. I must be getting old. :-)


    1. What happens if you copy an existing Enscape asset?

    2. What happens if you select an Enscape asset and select Create Similar?

    3. Have you tried resetting the work plane of the view?


    Thanks for your patience.

  • I'm getting this error as well. It's frustrating, because i really am in a new 3D view. Unable to place a new asset to a work plane or to a face. Unable to link a Revit family to the asset.

    I was able to copy/paste from another project. And yes, selecting that asset that was pasted in allows us to create similar. I am combing through old projects to recycle assets in this new one. I think the asset manager is broken.

  • Hey Phil,

    In response to your suggestions:

    1. I can copy existing Enscape assets from within the project or from an entirely different project via the clipboard. Objects copied via the clipboard will place normally in plan or 3d views.

    2. Create similar works fine...creates a new instance of the asset in both plan or 3d view. Instances can be changed to other Enscape assets that are already loaded in project.

    3. Can change work planes and assets will place accordingly. If I go to the ... menu of an asset and switch from place on work plane to place on surface I still get the same error.

    Unlike ihakki above I can at least still link Enscape assets to Revit families as a workaround. The problem seems to be the physical drag from the Asset Library into the Revit Window. I wish there was another way to load them.


    I can't remember why. I must be getting old. :-)

    This reminds me of a joke...

    What are three signs of old age?

    1. Becoming forgetful

  • I was able to retrieve assets from other projects. Select, Edit Family, Load Into Project. Terrible workflow. I had my IT guy install the previous version of Enscape that was working fine before, but now I get the same error message even in that version of Enscape. Frustrated and at a loss.