Enscape Keeps Freezing at 95%

  • I have the most recent version of enscape and I am using a brand new alienware 17r5 laptop(32gb ram, core i9, gtx1080). I keep having a problem where enscape is working just fine for a little while when i first boot up my computer and then if I have to close the enscape window once and reopen it, it keeps freezing at 95% and also freezing sketchup. The problem seems to only happen when I have my laptop connected to dual monitors (I have it setup through mini diplay port and hdmi cables...I had Dell's lightning dock and it was giving me similar problems). I try re-opening sketchup to run enscape again, but it still wont work after that 1st initial run of enscape. When I disconnect dual monitors, enscape works fine with just the laptop screen. Has anyone else had similar problems?


    I just need to figure out if I am doing something wrong with enscape or if there are issues running dual monitors with enscape through a laptop...any help is greatly appreciated!


    Adam

  • Hi awarner ,


    thank you for posting your experience! This looks like a known incompatibility with a certain third-party software: The software is called Nahimic and seems to also be a part of certain preinstalled sound driver packages. The names of the software (that are known to us) are Asus Sonic Studio II, Alienware Sound Center, A-Volute and MSI Nahimic. This incompatibility might causes Enscape to freeze at 95% in Sketchup. Currently the only known reliable workaround is to uninstall this software, then Enscape should not freeze anymore. We have had other reports that changing the monitor configuration also seems to work in some cases.


    The same issue is present when Enscape is used with Revit. In this case however, the progress bar freezes at 5%.



    Hope this helps!

    Stephan

  • I had this issue, and it continued even after I uninstalled the Sonic Studio and I even tried uninstalling every audio related software and driver. My computer also gave me an error popup asking to "restart computer to finish audio driver install" every time I started the computer.


    Both problems got fixed when I permanently disabled a service called NahimicService from Windows Services.

  • Hi,


    I got the same issue but because of my new dual screen.

    I figured out that when I"m running Enscape with my LG monitor plugged on my laptop, Enscape is freezing at 95%. When I"m unplungging the monitor it works fine.

    Did not find out the solution for that yet.


    Thanks for your help.

  • Hi,


    I got the same issue but because of my new dual screen.

    I figured out that when I"m running Enscape with my LG monitor plugged on my laptop, Enscape is freezing at 95%. When I"m unplungging the monitor it works fine.

    Did not find out the solution for that yet.


    Thanks for your help.

    That's an interesting observation. Could you please submit feedback with logs as follows:

    1. Run Enscape with unplugged second display

    2. Run Enscape with plugged-in second display, having it freezed at 95%

    3. Send feedback including logs and mention your forum user name in the comment.


    It is important to not run Enscape after (2) so we could be sure the latest log file is from the case when Enscape freezes and the pre-latest is from the normal run.

  • Hey Alexander,


    Thanks for your feedback.

    I tried to follow your process but unfortunately I can't send you logs when Enscape is freezing at 95% cause sketchup window is also frozen. I can't do nothing but force to quit SKP.


    Update, Enscape works well even with the second screen plugged-in as long as the Enscape window is set on my laptop screen, if the window is opening on my second monitor then it freezes at 95% .


    Thanks for your help !

  • Thanks for the info! To me it sounds like a hardware/driver issue. Enscape does not know anything about display configuration - we only know that we've got particular GPU and start using it for rendeing. The only reason to crash I can imagine is that the display has e.g. 4k resolution so GPU is out of memory when Enscape starts fullscreen. But to prove this guess we need logs :)

    I tried to follow your process but unfortunately I can't send you logs when Enscape is freezing at 95% cause sketchup window is also frozen.

    You don't need to have Enscape window runnign to send logs - return to SketchUP (or open it again if it was closed together with Enscape) and click Feedback button on the panel. But you will have to repeat the runs in the same order as mentioned in my first reply so we could be sure that the latest log file belongs to the frozen Enscape and pre-latest to the normal-working case.

  • Received your feedback, which will be forwarded to our developers for further troubleshooting. Thanks a lot!

  • I have the most recent version of enscape and I am using a brand new alienware 17r5 laptop(32gb ram, core i9, gtx1080). I keep having a problem where enscape is working just fine for a little while when i first boot up my computer and then if I have to close the enscape window once and reopen it, it keeps freezing at 95% and also freezing sketchup. The problem seems to only happen when I have my laptop connected to dual monitors (I have it setup through mini diplay port and hdmi cables...I had Dell's lightning dock and it was giving me similar problems). I try re-opening sketchup to run enscape again, but it still wont work after that 1st initial run of enscape. When I disconnect dual monitors, enscape works fine with just the laptop screen. Has anyone else had similar problems?


    I just need to figure out if I am doing something wrong with enscape or if there are issues running dual monitors with enscape through a laptop...any help is greatly appreciated!


    Adam

    Hi Adam, seems like I had a similar issue with my new MSI laptop. Turned out it was some sort of conflicts with an additional audio driver called Nahimic, used for gameplay. The solution I found was to disable the nahimic service at boot by default in the windows options.


    Hope this helps! Let me know!