Bug: flicker glass

  • Dear Enscape team, I have a recurring problem which I hoped would have been fixed in 3.1, but it is still there.


    The flickering during movement of glass/light/reflections.


    I have turned off the lights/the emitting/both. I have turned on and off all denoiser/rtx/etc. options and am rendering on ultra with an 3080rtx.

    I have deleted a second layer of glass inside, but this doesn't help.


    I wonder what causes this and more importantly, how can I get this effect gone? Because my customer is annoyed by it.

    flickerlight.mp4


    Ps. great update with the sun rtx shadows, will this also be added to video rendering please? That would be awesome!

  • Workaround possibility - Render scene X times and composite them together with overlay mode "Lighter Color". If the flickering is random, it should lessen the effect.


    ...I am not suggesting this does not need to be fixed by Enscape. Just a workaround to consider if you are in a pinch.

  • Thanks for your report. I think part of the issue here is that this is frosted glass with a rather high roughness (is that correct?). Can you try and see if the effect is reduced when lowering the roughness/removing the frosted glass option?

    Unfortunately there's probably not much else you can do at that point. We're aware of the issue in general and hope that we can improve results in the future though.