How to fix "shaky" VR mode with Oculus Quest 2

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • Hello everyone!


    Is there a way to fix the shakiness, introduced in version 3.x, when in VR mode, using an Oculus Quest 2?


    The image shakes a lot and the colors looks kinda washed out.


    Tested with both cable and airlink, no luck. It works perfectly with previous version but really want to get the benefits from DLSS.


    Thank you.

  • Rick Marx

    Approved the thread.
    • Official Post

    Tatunts , first off, please make very sure that your graphics card drivers are up to date.


    If that doesn't fix the issue, can you let me know if this issue only occurs when DLSS is enabled? Does disabling DLSS help overall? Of course, DLSS should in fact boost VR performance, but for troubleshooting purposes, I'm asking.


    Also, if you generally lower the Rendering Quality in the Visual Settings, does that resolve this behaviour too perhaps? Is there a chance you've perhaps dialled up that setting after installing 3.x? And please make sure you really have our latest version of Enscape installed, as we put out a hotfix just a few days ago.

  • Hello Demian Gutberlet ! Thanks for the reply.


    Yes, drivers are all up to date.


    The image in the headset is very, very shaky and nauseating, impossible to use. Lowering render quality or disabling DLSS altogether does not help, the issue persists. This was never a problem with Enscape 2.x.


    I'm running a 2080ti with 32gb DDR4 3600 and a 3900X.


    Thank you!

    • Official Post

    Tatunts , I'm sorry to hear about that - in that case, please also definitely send us a Feedback report as described here, and include a link to this thread in the Feedback submission form, please. To further make sure, you do not experience any performance problems with other VR applications? Can you kindly make sure that this kind of shaking and instability is really only present in Enscape? Thanks a lot again in advance!

  • Ok, I'll do that. All other games and apps in VR using my Quest 2 runs great, only Enscape has this shaking/jittery view (there are other posts here stating the same issue), its like the render is lagging behind and showing frames out of order. If I set to force 45hz, without ASW, it seems to help with the jitter, even tough my GPU is using 70% of its resources when in 90hz, ultra quality with DLSS, so it does not relate to a lack of power/resources from my PC. Have you tested it with a Quest 2 and link cable? It works for you? Thank you.

    • Official Post

    Tatunts , I did not experience problems, but I also have an RTX 3070 installed that happens to be slightly overclocked as well. In the end, you should've hopefully also gotten a reply through your Feedback report by now, the log files should give us further hints as to why you experience such bad performance.

    • Official Post

    as i mentioned in a other threat ... i got the same Problem ... but if i turn the Nvidia RTX Render off all is Smooth on our Oculus Quest using a 3060 newest Driver !

    Welcome to our Forum! I'm glad to hear you can at least use Enscape still with RTX off, but that should still not occur so we would love to receive a feedback report as described here from your machine as well if you haven't sent one in.

  • I'm having the same issue...

    • Official Post

    You can gladly send us a Feedback report each so we can go over your system and let you know if everything is up to date and there aren't any visible problems in the logs.


    Otherwise, RTX, in general, is rather performance-intensive, especially when VR is enabled since the image has to be rendered in 1. high resolution 2. high framerate and also 3. once for each eye, so twice in total - Especially the third point costs a lot of performance, so the framerate would naturally go down and the 45hz mode is activated. That is why we recommend disabling RTX for now when using VR. If you look online you will also find that there aren't really any larger native VR games/applications which make use of raytracing in the first place.


    Furthermore, if SteamVR is activated alongside then there will always be a performance loss I'm afraid, which was and is always the case with Oculus products since they do not directly use SteamVR, in this case for example the Oculus Quest uses the Oculus application/runtimes themselves on top of SteamVR so to speak, this can sometimes cost up to 20-30 FPS from experience - just for your information. (Generally, just as a side note only related to Oculus devices and VR in general: For SteamVR applications/games you can also use "OpenComposite" to skip SteamVR entirely and only use the Oculus app which helps with performance.)


    If you also experience problems when RTX is off, let me know and definitely send in a report then too.

  • Hi Demian Gutberlet


    I can confirm;


    RTX OFF

    - WOBBLING solved on VR device/ still on PC screen a very wobbling image

    - BRIGHTNESS of the image is kept normal


    RTX ON

    - WOBBLING with ONLY NVIDIA DLSS ON still gives a wobbling image (VR), but LESS than with the two other options activated (Denoiser + Raytrace Sun)

    - BRIGHTNESS is way blown up/ doesn't represent the pc brightness



    Hope this input helps.

    Cheers!

  • Found it ..

    Tried to downgrade to version 3.1, found the RTX and other checkboxes :)


    Got the same results others : shaky VR was gone when RTX is unchecked in ver 3.1, no luck in ver 3.2


    I'm using RTX 3070 latest driver

    • Official Post

    beebo , welcome to our Forum! :)


    I'm afraid, this specific "shaking" inside VR is a known issue currently present in 3.2 - Our developers are busy resolving this as quickly as possible of course.