Screenshot vs Batch - same visual pre-set - different result

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • In the two renderings below I created the one on the left using the screenshot button. This is the desired result.

    There is a visual pre-set which is set as current as per the Visual Setting box screen grab.

    When I render that same view using Batch render which has that same visual pre-set linked to the view (as you can see below in the View Management screen grab) I get a different result.

    It is cropped, or zoomed in slightly.

    The same output settings are being used, so why are they not the same?

    This has always confounded me and means that I cannot use batch rendering, which would be a great time saver.


  • Go to Best Answer
  • Can anyone suggest something?

    Does it have something to do with the Field of View or Safe Frame or Synchronze Views?

    I need to create about 80 renders and can't face having to do them again one at a time!!

  • Since no one could offer any advice I decided to mess about with the Field of View settings since it seemed to me to be the likely cause of my issue.

    All of my SketchUp scenes have a FoV of 70 deg. I use this on pretty much every SU scene I create.


    The only way I could get Batch Rendering to achieve the same result as a screenshot was firstly, disabling view sync and then setting the FoV to 93.675(Horizontal) in Enscape's Visual Settings which then updated the pre-set assigned to the views.

    That number was arrived at by trial and error and makes no sense to me whatsoever.

    This can't be the way it's meant to work?!


    BTW. Assigning visual pre-sets one view at a time is just painful. Try doing this with 80+ views. Can I please request that the developers look to find a way to enable assigning pre-sets to multiple views at once? I'm begging you!

  • The only way I could get Batch Rendering to achieve the same result as a screenshot was firstly, disabling view sync and then setting the FoV to 93.675(Horizontal) in Enscape's Visual Settings which then updated the pre-set assigned to the views.

    That number was arrived at by trial and error and makes no sense to me whatsoever.

    It seems to be a mixup between vertical and horizontal FoV.

    Using your image aspect ratio in this calculator gives exactly this value: https://themetalmuncher.github.io/fov-calc/

  • Thats' interesting, cheers.

    Certainly explains why I arrived at that figure.

    Still don't understand why I should have to manually input into the FoV setting to achieve the same results between batch and screenshot.

    I'm amazed that no one else seems to be bothered by this.

    • Official Post

    foggo , that should not be the case and I was not able to reproduce this problem of yours, yet at least.


    What I did is simply:

    - Created new settings preset, set the FoV to 140 (left the rest of the settings unchanged)

    - Linked those settings to "View 1"


    Then, I used both the Screenshot and Batch Render functionality, the FoV was exactly the same in both renderings. I left View synch disabled and had no problems otherwise either - it shouldn't make a difference but please ensure you're using our latest release.


    And if that doesn't do the trick, I'd highly appreciate it if you could perhaps send us the project including the settings themselves? This would be the quickest way to hopefully further troubleshoot this on our machines as well. Let me know if that is possible and I'll send you a link through which you can confidentially upload the files.


    Regarding your request to assign presets to multiple views more quickly, I have gladly forwarded it as a feature request to our product management team.

    • Official Post

    Could it be related to 2pt perspective?

    In a 2pt perspective camera, I believe the FOV switches to vertical instead of horizontal:

    https://ruby.sketchup.com/Sket…height%3F-instance_method

    Great point, thanks a lot - foggo , just to re-enforce this: Please check that you're in the "Perspective" projection mode when you take screenshots:


    For batch rendering, this won't matter of course if you linked the settings to your views anyway, and as long as those settings have the projection mode set to perspective as well (via the Visual Settings).


    Just to add though: Unfortunately, I was not able to reproduce such a drastic shift in FoV like you experience, but it can't hurt to check.

  • I'll start by addressing the perspective/2 pt perspective/SketchUp camera suggestions. I don't use 2 pt,, only perspective camera in SketchUp and Enscape is set to perspective as well. I'm puzzled about the 140FoV setting you mention as well Demian. Anyway, this is not the issue.


    Let me explain my process of how I create my views.

    Historically I have always created scenes in SketchUp as that's what I've been doing for the last 16 years! And I have found that for my purposes, setting SketchUp's FoV setting to 70deg is a good starting point. I will start Enscape now and leave it syncronized with SU.



    For the views in my original post I used a custom resolution of 1600x1050 assigned to the current view pre-set. I will then create my scenes using SketchUp (not Enscape).

    Before you know it, I've got 80 or so scenes all created as described. Then there's inevitably some tweaking done to the model, some people added etc. I will then do a few screenshot renders once I'm happy with the model. NOTE I have left the syncronize views on as I see no reason to unsync at this point.

    Great, now I've got a pile of views with which I want to do a "final" render. Batch render is the obvious next step.

    :rolleyes:Hang on, I have to assign the view pre-set to all of the views (I've already shared my thoughts on that)

    2 hours later I'm ready to batch render. I do so. Syncronize views is still on. Shouldn't matter right?

    But they don't match the preliminary screenshot views I created earlier. They're cropped as I mentioned in my OP.

    So I try unsyncronizing and I notice that Enscape's FoV setting changes from 70deg (Vertical) to 80 deg ( horizontal).

    Not even going to try to make sense of that. Try the batch render on a couple of views, still not matching.

    I click this little button, the FoV changes to 90deg (horizontal) still the batch views don't match.



    So I give up and end up rendering each view one at a time with the screenshot render option.

    Of course now I have to tweak the model and need to re-render the entire set of views. Now I'm determined to get this batch rendering to work, so I manually fiddle with that number and arrive at 93.675 to get an exact match. It's a head scratcher and was a bit time consuming but I got there in the end. I'm stuck with it, it works and is the only solution to get the 80+ views matching the screenshots which I already produced as a prelim set.


    So what should I be doing differently to avoid this? Create all of my views from Enscape? Avoid using SketchUp's FoV setting and rely on the Enscape one? Leave synchronize views off? This is counter-intuitive as Enscape is the plug-in and should be the slave to SketchUp. I know one thing, I will definitely avoid using the screenshot render option in future and just use batch, even for single renders.

    • Best Answer
    • Official Post

    Thank you very much foggo . I truly appreciate the further details and I can of course also understand your frustration - through your info I can at least give you a logical explanation behind this which should help with clearing the confusion:


    If you have Synchronize views enabled then Enscape will always take the vertical FoV which has been set up in SketchUp itself. Because of this, having an FoV of 90 for example in SketchUp (Vertical) will not be the same as having the Enscape FoV (Horizontal) set to 90 (through the Visual Settings). So, when you then batch render, the views take the FoV settings into account which you've defined, but again, it's going to be horizontal, not vertical. But, if you enable Synchronize views again or in case you've never disabled it, then taking a screenshot will take the SketchUp Vertical FoV into account so they naturally look different to the renderings produced via the batch function.


    I'm also aware that this is not ideal if you want to batch render while Synchronize views have been used from the beginning of the project, at least for now we would recommend using Enscape itself indeed to create your scenes/views, and keep synchronize views disabled at least until all the views have been set up to your desire, unaffected by SketchUp's vertical FoV also ensuring that only the settings would also then be taken into account when Batch rendering is used - I'll also forward this subject to our product management team for further review to see if we can improve this behaviour in the future, but we may also very well be technically limited through SketchUp itself in some form which may also be the reason we have not added this yet - just so you also know: SketchUp itself controls Enscape when you have View Synch enabled, not the other way around - which means that once you do Batch render, Enscape is not able to tell SketchUp "move from this scene to the next" - but as mentioned, this subject has been forwarded again to see if there is anything we can do to improve this.


    Finally, I hope that this won't influence your workflow too much in a negative way - feel free to share any further thoughts with me if you like as well!

  • Thanks for your reply Demian.

    On the next project I will just use Enscape to create the views and assign the visual pre-set at the same time. It looks like I'll have to stop using the SketchUp FoV setting to avoid the conflicting FoV issue. No big deal, it was just how I've always worked. Plus I will only use batch rendering from now on for the sake of consistency.

    I will have to navigate around more in Enscape now but that is fine as I recently got a Spacemouse.