Enscape custom size does not match with Sketchup 2D graphics export

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • Hi Guys,

    I am using Enscape for quite a bit now and I cannot figure out how to make the enscape export render to match the sketchup export size.

    In Enscape export setting, we have done the following:

    1. We had set the custom export size to be the same as sketchup 2D export size (4000x2056)

    2. Unchecked “use viewport aspect ratio”

    3. Turned on “Synchronize Views”


    But at the end both the enscape and sketchup exports did not match in Photoshop.

    I do a lot of touch up work in Photoshop after exporting.
    Everytime I need to manually stretch the exported image to match to the sketchup 2D exported image in Photoshop.


    This really affect the use of enscape and we had used the older versions and we never had encounter a problem like this.



    Does anyone have a solution? If there is any guidelines that would be extremely helpful.



    Thanks so much!!

  • In previous Enscape version (2019), it would work if the enscape custom export size matches the sketchup 2D graphic export size and have the synchronize views turned on.

    Where can I find a tutorial for that?

    Thanks so much!

    • Official Post

    vicdour, if you want to overlay an Enscape rendering to the exact output of SketchUp itself you will actually have to check/activate the option “use viewport aspect ratio” - Doing that alone should already resolve this problem at hand, you're doing everything correctly it seems otherwise. Let me know if that doesn't do the trick!

  • If I’m trying to match up between SketchUp I activate the advanced camera tools, choose a SLR camera and then make sure I output with a resolution with a 3:2 ratio / 1.5 aspect ratio in Enscape.

    If the view sync is enabled this will get a perfect match

  • Demian Gutberlet By just activating "use viewport aspect ratio" its still not matching. I have made sure both enscape and SKP are the same size (4000x2090). What else can I do there to resolve it? This was not a problem in earlier enscape version. Please advise. Thank you!!

    • Official Post

    Demian Gutberlet By just activating "use viewport aspect ratio" its still not matching. I have made sure both enscape and SKP are the same size (4000x2090). What else can I do there to resolve it? This was not a problem in earlier enscape version. Please advise. Thank you!!

    Please give our latest preview a try as well while I'll try to reproduce this myself once again. I'll let you know in case this has to be filed as an issue.

  • Demian Gutberlet

    I think this is an issue you should file as this is not the first time people has flagged this in this forum. There's been threads made regarding views cannot match many times.

    I have tried with your suggestion but nothing works.

    Thank you.

  • Did you try my suggestion?

    If the aspect ratio is the same between SketchUp and Enscape then it will be the same.



    Here are the 2 outputs composited into one image (Sketchup does still include what is outside of the safe frame in it's output)


    In this example I've used a resolution of 3000x2000 in enscape


    and I've given SketchUp an export resolution of 3000 wide by whatever it auto filled in (because the height is populated by space I don't need)

    • Official Post

    vicdour , we'll have a closer look into this once more and discuss this matter with our developers if required - meanwhile, I hope you can still make use of the guide provided by Adam above.


    Thank you again for the Feedback and input.

  • I remark a difference in output with a 'Screenshot' (=single render) >> RESULT: E3D = SU viewport.

    BUT when performing an BATCH RENDER >> RESULT: E3D SU viewport ?! Why?!!!


    BATCH SETTINGS with minimal difference between E3D ± SU viewport ;

    - deactivate 'Synchronise Views' and the set Field of View to 100°

    - batch render output will have the same apperance of the SU preview


    OPTIONAL

    - activate 'Synchronise Views'

    - activate 'Safe Frame'

  • View angles are synced so can't be the problem ?

    Once Again it can.. Actually the question was in the way that I have doubts if He meant Fov or direction in which camera is looking.. cos the latter is always synced.. and actually the former as well, BUT.. To me it looks really like the scene was taken in 2PP perspective and then a bit zoomed out.. ENS will not react to zooming and panning in 2PP in sKetchup. That's way it will appear like misaligned,, and he had to stretch it in PS..

    That is way if You are planning on taking 2PP scene take it in ENS.. It will be added as normal perspective in sKetchup but using this scene with Visual Settings Presets, which have the correct FoV (the same that You were Creating the View with) and of course 2PP without Synch Views.. will allow You to get the same 2PP view.. Still You will not get aligned sKetchup and ENS. What You can do is select the created scene in sKetchup change to 2PP and ADD not update.. The added 2PP scene is actually the same with ENS but different shift values.. (You have to pan it - and I think only pan.. zoom should be correct?).. And here comes problem cos in theory it is possible to align them.. but in practice it is difficult to pan in sKetchup scene two pixels down and 1 to the right.. But if You have managed that then You can use the first scene which You created from ENS window to get correct view in ENS and second scene which You added in sKetchup to get correct view in sKetchup..

  • Glad I could help. I wrote in past past about 2PP.. For 2PP shift and zoom are not supported by sKetchup API so external vendors can do nothing about it.. SKetchup people as well didn't give me any hope that it will be added.. so this workflow is best that I have found.. and probably that it will be for some time..