Enscape Assets not changing visibility

  • Hello, we are using Enscape Version 3.1.2. and Vectorworks (German Version) 2020.

    We have Enscape assets on different 'Working Layers' (Konstruktionsebenen) and we need to be able to turn these Layers on and off. But the Assets are always visible regardless of the visibility of the Layers. VW 2021 seems to be responding correctly but we are using VW2020 in the company and are not planning on using 2021 except maybe sometime next year. Can you please provide help on this subject? Thank you!

    Alan

  • Hello Alan.

    Unfortunately, the change events for layer visibility have only been added with VW2021.

    The export API that we use was new to VW2020 and so it does not have all of the features.


    A simple workaround is to restart Enscape. This will re-read everything from the project and have the correct visibility.

    The big downside here is of course the export time for every restart.


    How are your layers set up for visibility? It might be possible to write a small python script that forces an update on all of the assets but this doesn't work for all cases.
    Could you provide a sample project with a few assets and layers set up as yours that imitates your real project?

  • I've looked at the project and the script that I had in mind doesn't work. It only works when the layer with the assets is not completely hidden.


    I've looked a little into adding a workaround on our side and it won't be easy. As I mentioned above we simply do not get any updates when the visibility of the layer changes. I won't promise anything but I'll see what I can do.


    Then for the moment, the only workaround is to reopen Enscape.