Just installed 3.2 and substantially freezes my PC

Reminder: If you encounter any issues with Enscape (including installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed here. Thank you for your understanding.
  • 3.1 was working fine this morning.

    Than I got the tip that 3.2 is just out and immediately installed.

    When launched the loading bar stops at 5% and the only thing I can do is to move the mouse pointer, not even CTRL+AT+DELETE to try to delete the process.

    I had to push the physical power button.

    Tried 3 times, same result.

    Anybody in the same situation?

    Could it be that I'm using Win7?

    I have also 2x GTX 970, but actually the monitor is driven with a GT 740.

    I will try to downgrade back to 3.1.

    Any advise on how to solve this?


    Thank you in advance,

    Gio

    • Official Post

    Welcome to our Forum!


    I'm afraid, we do not support Windows 7 anymore. Under some circumstances, Enscape could still run under Windows 7 but we will not offer any further official support for this version - We would therefore highly recommend upgrading to Windows 10, or even Windows 11 now. And I do hope that will be a possibility for you of course! In the end, this upgrade will of course make your machine more future-proof overall when it comes to further releases after 3.2 and so on as well.