Enscape 3.2 3D mouse issues!

  • It also doesn't stay upright. You can now roll over and end up upside down which makes it incredibly hard to control. The walk mode also disengages as soon as you move try to move with the space mouse. This all worked perfectly in all the previous versions.

  • Hi,


    we've updated the SpaceMouse integration for 3.2 to support all the features of the current 3DConnexion drivers. Please make sure you have the latest drivers installed:


    You can now control the camera movement behavior directly in the driver settings. It sounds like you'd want to switch between 'Object Mode' and 'Camera Mode' to get the desired behavior: Object mode behaves as if you were manipulating your scene with the space mouse on a fixed view. Camera mode behaves as if you were directly controlling the camera movement with the space mouse.


    Make also sure that the 'Lock Horizon' checkbox is checked to always keep the camera upright.



    Hope that helps!

  • Thanks Clemens,


    I've installed the latest driver and see the functions you are referring to. After some experimentation, I've gotten it to work for all the issues bar one; It's still impossible to stay in walk mode; it disengages as soon as you rotate or try to move.

  • Thanks for the tips. A nasty shock when first starting with the Spacemouse controls all over the place. Very fortunate that I tried it out before a client presentation first thing in the morning :)


    Default lighting is so much better now and that also helps for client presentations.


    Very nice, thank you8)

  • That's a real shame. Being able to glide through the interior of a house, up and down stairs, with the 3D mouse was night and day over using the mouse and keyboard. It gave presentations a real professional touch. This is a big back step. Can I ask what the reason was to change? This worked perfectly before. There was no need to change any settings apart from toggling the invert box to match up to your preference.

  • That's a real shame. Being able to glide through the interior of a house, up and down stairs, with the 3D mouse was night and day over using the mouse and keyboard. It gave presentations a real professional touch. This is a big back step. Can I ask what the reason was to change? This worked perfectly before. There was no need to change any settings apart from toggling the invert box to match up to your preference.

    +1

  • Another client presentation this morning so I uninstalled Enscape 3.2 and reinstalled 3.1 but the 3dConnexions spacemouse driver seems to have been corrupted by using it with 3.2 as it would not work properly with 3.1 until I uninstalled the driver and reinstalled it.


    Thankfully, got it working just in time for the presentation.


    It isn't clear whether it's the Spacemouse driver or Enscape 3.2 that is the problem but something between them doesn't seem to be working quite right.

  • 3DConnexion have been notorious for abandoning hardware and changing driver functionality without warning over the years.

    I’ve got a space pilot and a space mouse somewhere, both perfectly functional but abandoned by 3DC and now nothing but paperweights.

    If I was a betting man I’d happily put money on it being 3DC’s driver functionality (or lack of) rather than Enscape being at fault here.

  • Not having walk mode is a problem. But I am having a larger issue. My Spacemouse will not switch out of object mode. When I change the navigation mode to camera mode there is no change. I end up just doing barrel rolls through my model. Is anyone else having this issue? It was working fine last week. My Spacemouse Drivers and Enscape are up to date.


    I just purchased a new Enscape license this morning only to find out I can no longer navigate. So, I am pretty disappointed.

  • I tried an uninstall and reinstall on both the SpaceMouse and Enscape. I played with all of the settings. things like disabling rotation worked. But changing the Navigation mode or locking the horizon had no affect. I ended up installing an older Enscape to fix the problem. It is a shame because I really wanted to try out the new Batch Panorama Renders. But, not worth it if I cannot navigate with my SpaceMouse.


    I am curious. Does anyone use Object Mode in Enscape? It seems like Camera Mode should be default. It would be a lot more usable out of the box.


    I have a suggestion. Add an option in the Enscape settings to disable the dedicated Enscape driver. That way it would give you the old behavior until all of the bugs are ironed out.