Enscape 3.2 3dconnexion Spacemouse Issues

Reminder: If you encounter any issues with Enscape (including installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed here. Thank you for your understanding.
    • Official Post

    Everyone, just to provide you with an update from our developers and future steps.


    In the end, we've decided to implement SpaceMouse support on the basis of the new SDK, even though Walk mode was no longer available. Originally there was the hope that integration problems in the CADs (especially Rhino) would no longer arise, unfortunately, the opposite is the case in the end.


    We will thus now gather all your input and forward it to our product management team - If there may be enough demand, we can consider reverting our support for the older drivers, thus restoring the walk mode functionality. How future proof this may be I cannot say though.

  • Everyone, just to provide you with an update from our developers and future steps.


    In the end, we've decided to implement SpaceMouse support on the basis of the new SDK, even though Walk mode was no longer available. Originally there was the hope that integration problems in the CADs (especially Rhino) would no longer arise, unfortunately, the opposite is the case in the end.


    We will thus now gather all your input and forward it to our product management team - If there may be enough demand, we can consider reverting our support for the older drivers, thus restoring the walk mode functionality. How future proof this may be I cannot say though.

    If you can not get it to work as good or better than before, then it would be best to revert.


    Another thing I liked with the old implementation is that he speed of the Space Mouse could be changed by holding Ctrl and/or Shift keys. This no longer works either.

  • I'm going to add info that I used to help me and hopefully it may help others. I just re-added my very old space mouse that I haven't used in years. I installed the current spacemouse software for win10. Initially the drivers only worked on the demo apps and nothing else. I was able to get the spacemouse -sketchup 2020- specific driver (from the forums of spacemouse) and that worked even though I'm using skp 2019. It also works on my enscape but it's not locking to the horizon or as useful - so I unchecked the box at - enscape window - rendererWindowSettings - input - enable spaceMouse checkbox - and it reverts to the sketchup handling regardless of whether sketchup or enscape is the primary window. You can then further adjust how it moves in the 3dconnexion settings under the advanced settings menu - and you need to have sketchup as the main window - or it will show the properties of whatever is currently the primary active window. I use camera mode, lock horizon and separately the dominant checkbox UNchecked.


    I believe I attached the sketchup driver that Im referring but not completely sure. It was recently in my downloads folder ;)

    • Official Post

    Please revert to the older drivers. It's unusable as it is. Had to revert back to an older verion of Enscape while this mess is sorted out.

    I've certainly forwarded your Feedback, thanks a lot.

  • Please revert to the older drivers. It's unusable as it is. Had to revert back to an older verion of Enscape while this mess is sorted out.

    Agreed.



    I've certainly forwarded your Feedback, thanks a lot.

    Please add another +1 here. The latest response from my feedback report does not give me the impression this will be implemented:


    "Version 3.2 has support for the new Spacemouse drivers, which provide limited functionally in this version.
    If you need better support for the Spacemouse, rolling back to version 3.1.2 is required."


    What is the point of updating the software to provide "limited functionality" when it worked perfectly well previously? Very frustrating. I'm now stuck on 3.2.1 for the foreseeable future.

  • Yes, it's very dispiriting.


    Other than stick to a version of Enscape 3.1 I do not think there is a solution.

    Ended up updating to 3.2+ and relying on the Synchronize Views button in the Enscape toolbar within SketchUp. Not my favorite method but it works. Always felt a bit less fluid than just navigating within the render window natively.

  • Ah, you are in Sketchup, my issue is in Revit 2022.


    I tried Enscape in the latest version of Sketchup and it seemed to have the same problems as Revit which I guess is not unexpected given that it seems to be something to do with the 3DConnexions developer toolkit?


    I'm resigned to waiting with 3.1 - fortunately I use Lumion for rendering - and that doesn't even support a Spacemouse LOL

  • Ah, you are in Sketchup, my issue is in Revit 2022.


    I tried Enscape in the latest version of Sketchup and it seemed to have the same problems as Revit which I guess is not unexpected given that it seems to be something to do with the 3DConnexions developer toolkit?


    I'm resigned to waiting with 3.1 - fortunately I use Lumion for rendering - and that doesn't even support a Spacemouse LOL

    Twinmotion recently added it ;) .

    • Official Post

    Everyone, I cannot exactly promise when, but 3D Connexion stated they'll work on their API to resolve these ongoing issues in combination with Enscape - They also stated that it won't take much longer, but as of now there is no exact release date just yet. Still, stay tuned and await more good news soon. :)

  • Thanks for the Update, Demian. The effort is appreciated.

    Everyone, I cannot exactly promise when, but 3D Connexion stated they'll work on their API to resolve these ongoing issues in combination with Enscape - They also stated that it won't take much longer, but as of now there is no exact release date just yet. Still, stay tuned and await more good news soon. :)

  • So here we are 6th April 2022. I've installed Enscape 3.3 and the latest 3D Connexion drivers 10.8.6.


    There is no mention in the release notes about fixing the problems detailed above but I thought I would give it a try.


    In short, it isn't as bad. It works, a little jittery and unfortunately there is no way I could see of keeping the view level - other than making sure your view is level and then disabling that rotation feature from the 3dConnexions Menu.


    It's rare for products to become worse with newer versions but I'm going back to 3.1 as this combination is still too unstable to use for client presentations.

  • Thanks for trying it Willsud, I was thinking about updating to see if anything had resolved itself. But it sounds like that is not the case.


    Enscape, if you are listening, please fix this. It just needs to go back to the way it was. Or add an option to disable the dedicated driver. This issue was introduced in un update 6 months ago and I am still not able to update because this makes Enscape unusable for me.

  • I've spent a while playing about with the Menu options in the latest 3d Connexions driver and Enscape 3.3


    The best workaround I have come up with - for me - so far is:


    Navigation Mode = Target Camera mode


    Speed (I have all these Reversed) = disable Left/Right Roll


    Unfortunately, disabling the Left/Right Roll for the joystick is no guarantee that the horizon will stay level ('Lock horizon' in the menu options doesn't seem to work?)

    When it starts to drift away from vertical I use the 'F' or 'R' button on the Spacemouse to get the building back level again - it forces a Front or Right View.


    All this is OK for outside but inside a building the camera is very jittery. I've tried the other Navigation Modes but one doesn't seem better than another.


    At least this has forced me to learn what the buttons on the Spacemouse can do.


    It's still rubbish compared to how it used to be so the best solution might be what I've just done - throw the Spacemouse in the bin ! :)