Enscape 3.2 3dconnexion Spacemouse Issues

  • Using Revit 2021 with Enscape Version 3.3.0. I click the Lock Horizon button in 3DConnexion settings, but it doesn't appear to do anything? Is this what others are experiencing?

    For me the Lock Horizon function started working after the last update. I am on Revit 2022 and 2023 Enscape Version 3.3.1. Are you not able to update to 3.3.1?

  • Thanks RandalRDesign,


    3DConnexions' Windows 10 driver- 64 bit version 10.8.7.3448 and Enscape version 3.3.1 + 75071 (the latest release versions as far as I know) do now seem to work OK with Revit 2023 hotfix 1.

    With Enscape linked to Revit 2023 the trick does seem to be to enable 'Lock Horizon' in the 3DConnexions' Enscape menu. My preference is to also reverse the direction of all the joystick directions in the same menu.

    If your Revit model appears in Enscape not horizontal I find tapping the 'F' key or other hotkey on the Spacemouse will place it level.

    Walk Mode in Enscape still does not work - it can be enabled in the menu bar but it immediately flips back to Fly Mode.

    FWIW in Revit 2023 the Spacemouse is too sensitive by default but this can be cured by selecting an object to pivot round in Revit first and then the Spacemouse uses the same pivot. There are no pivot point choices in the Revit menu for the Spacemouse (it recognises the current application).

    A big relief to have the Spacemouse usable again. I do wish software developers would stop using customers as beta-testers though :/ :)

  • For anyone else like me, who can't see the obvious...:rolleyes: :)

    If your Spacemouse in Enscape - or Revit - even after the latest driver updates, makes movement very 'twitchy' and is over-sensitive, just pull back the 'Speed' slider on the first page of the 3D Connexions settings menu.

    It seems to me that movement in some axes is more sensitive than others :/

  • Something has changed and now my spacemouse is even less usable than before. I give up. Think it's time to change programs as enscape are not listening to their users. Twinmotion now supports the spacemouse and it works great.

  • Apart from WalkMode not working the latest Enscape version 3.4 and the latest Spacemouse driver 10.8.8 work reasonably well now with a little bit of tweaking to reduce sensitivity.


    I've not noticed any changes for a month now - what are you seeing that is different?

  • My camera mode has jumped to function as if in object mode when it is set to camera mode and nothing I can do will get it to change. I'm sure it's fixable but I'm fed up having to spend time getting this thing to continue working at a lesser level than what it was previously straight out of the box before they changed the system. I don't see how anyone who was using a spacemouse before the change would say that it's now better than it was. Navigation was effortless and now at times I feel like I need the dixterity of a surgeon just to professionally move through a model during a presentation.

  • My impression, which may be false, is that the programmers have had to rewrite the drivers completely and it has proved difficult for some reason to regain the same functionality that previously existed.


    Even if not true I find thinking this makes it easier to accept the rubbish performance we've had to put up with for most of a year.


    I had - quite literally - thrown my Spacemouse in the bin, but retrieved it for one last go with the latest 3DConnexion drivers and Enscape version. Somehow this worked with the horizon locked, in Camera Mode.

    Weirdly I used to have to reverse all the speed settings but now I don't.


    In Enscape movement of the Spacemouse was still over-sensitive but turning down the Speed slider quietened down the twitchy movement and suddenly it became usable. I daren't alter anything but for now I can use it - this is Revit 2023 into Enscape 3.4 with the 10.8.8 Spacemouse driver.


    Best of luck with it.

  • Thanks Will, I'm on Revit 2023 wih Enscape 3.4.1 and 10.8.8 spacemouse driver. Settting to camera mode makes no differnece, it still works as if in object mode which makes it almost impossible to turn around within a room. I've tried reinstalling the driver and still no difference. This just starting happening in the last week.


    The loss of walk mode is not the only issue. This new automatic variable speed thing means you end up moving too slowly when you need to move quickly and vice versa. It's too unpredictable in it's behaviour. I'm constantly having to apologise for not being able to smoothly navigate through a model in a presentation.

  • I sympathise - it was very awkward doing presentations last year. I have my small office set up for clients to come in and walk them through the building but Enscape became unusable without the Spacemouse for this and I reverted to Lumion but it's not its strength.


    Strange that what you describe is not what I am seeing with the same software versions.


    I can't say I've noticed an automatic variable speed.


    I do find that setting the Rendering quality slider to medium helps being able to see inside the building and reduces twitchiness of the controller. Ultra makes things very dark and twitchy I notice when just trying it out.


    I've got a pair of RTX 2080Ti cards in my PC if that makes any difference.


    By the way, I cannot use the Spacemouse in Revit 2023 - it used to work but is very unstable now.


    One thing I did try which worked was the 'Calibrate' button while in Revit which did improve stability but not enough to make it usable.


    If you haven't already it might be worth trying Calibrate while in Enscape?


    Best of luck with it.

  • I have also been frustrated by this for almost a year and both Enscape and 3D connections keep blaming each other - can't fix it until they update their drivers....... Right now everything is good except I can't rotate from the camera point so I use the mouse at the same time I can drag rotate doing this.