Enscape 3.2 3dconnexion Spacemouse Issues

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • Thanks, Demian.

  • Hey guys, i have also the same issue with the 3dconnexion mouse as many have mentioned here before me (- I am working with the latest VW update as a 3D draughting tool - currently VW2022; all software are automatically updated for the whole office).

    In order to be able to navigate with my 3Dconnexion mouse I have installed enscape 3.1.2 (only on my machine as an exception in the whole office) which is to my knowledge the last version still supported by VW2022 and where 3D navigation still seems to function. As mentioned above I am using all these tools at work, therefore my hands are a bit tied with which software I can download; however the technicians were kind enough to make an exception for me.

    In any case I am really hanging out for an up-to-date enscape version where the 3D navigation works well again, as it's a bit of a pain to overwrite the otherwise automatically updated enscape each time.

  • It still doesn't work in 3.5 preview 11 (both SKP and Rhino). Is it still planned to include 3dconnexion fix in the final 3.5?

  • That is useful to know - that it still doesn't work properly in 3.5 - many thanks. For client presentations in Revit 2023.1, the bundled TwinMotion is now looking the best option for wandering round the building model using the Spacemouse.


    I am sure the programmers are working hard but you get the feeling that this isn't a priority for the people in charge. It is 14 months I think since we started complaining about this.

    • Official Post

    I want to further provide more clarity and a general post to sum up general info and issues (plus potential workarounds) users have been facing with the SpaceMouse and Enscape. Unfortunately I haven't been very clear with my previous posts so I hope this will be more useful in case any of this information is new:


    1. The ability to switch to Walkmode will still not be available after release 3.5 - To rehearse why: Walkmode requires collision - but since the new SpaceMouse drivers now have full control over the camera movement, there is no way to use Walkmode with the SpaceMouse. This is a limitation we've decided to accept. (See why more down below)


    2. Further, even though this shouldn't be news to most: The camera no longer revolves around the viewer by default compared to previous releases. This can be resolved via the SpaceMouse driver settings themselves where you can switch the navigation to "Camera Mode" and activate the "Lock Horizon" setting - after that the navigation should work as desired with the viewer as its rotation origin. (First-person view)


    Picture for reference:


    3. Some users also complained about a generally worse feel controls wise compared to previous releases of Enscape which may be due to the SpaceMouse sensitivity being set too high - Before Enscape 3.4, we just kept everything Enscape internal, so the camera behaved as defined in our settings - since this is now an external setting as well, it should be even more adjustable though.


    Picture for reference:



    Now to the part about what is changing with release 3.5:

    While the SpaceMouse has been working with Enscape before, we are fully transitioning to 3D Connexion's API, mainly also because they want the SpaceMouse to behave the same/consistently in all applications.


    On top of that we also plan to add Enscape functions to the SpaceMouse hotkeys.


    Last but not least, since I mentioned a dedicated fix (which was misleading) in my previous replies we would like to know what issues you still experience exactly (besides not being able to use walkmode) and especially if you still run into any odd behavior when it comes to the controls of the SpaceMouse. I appreciate any further input.

  • Many thanks for the detailed reply Demian however this isn't what I am seeing at the moment. The Spacemouse seems to have a life of its own and this behaviour is the same in the latest version of 3.4 and I have tried the pre-production version of 3.5. Horizontal Lock just doesn't work - it used to but stopped working some months ago.


    I'm going to uninstall and reinstall everything one last time and then it's cheerio Enscape.

    • Official Post

    Many thanks for the detailed reply Demian however this isn't what I am seeing at the moment. The Spacemouse seems to have a life of its own and this behaviour is the same in the latest version of 3.4 and I have tried the pre-production version of 3.5. Horizontal Lock just doesn't work - it used to but stopped working some months ago.


    I'm going to uninstall and reinstall everything one last time and then it's cheerio Enscape.

    I am very sorry to hear that of course - Is there perhaps also a chance for you to share a screenshot of your SpaceMouse driver settings with us and generally perhaps a short video in which we can see this behavior? Just so we can make sure this isn't just a localized issue when comparing it to our in-house results.


    I'd really appreciate the effort.

  • 3DxWare 10.8.11.35.19


    Yes, I registered to make this comment on the 3d Connexion issue, I've been using the 3d mouse for a decade. It was godsend to navigate sketchup models, graduated to Revit + Enscape and was in bliss.


    Sketchup + Enscape + 3d Connexion + Camera + Lock Horizon (Controls are set to reverse)= Perfect navigation

    Revit + Enscape + 3d Connexion + Camera + Lock Horizon (Controls are set to reverse)= Crazy navigation (cannot spin in place)

    I have both of the above Enscape session running and the navigation is night and day.


    Just for fun I exported both models to an EXE:

    Sketchup EXE + 3d Connexion + Camera + Lock Horizon = Can spin, but cannot reverse the controls (reverse control buttons are all grayed out)

    Revit EXE + 3d Connexion + Camera + Lock Horizon = Can spin, but cannot reverse the controls (reverse control buttons are all grayed out)

    The Sketchup EXE and the Revit EXE behave in the same manner, I can spin in place but the controls cannot be reversed, all of the reverse control buttons are grayed out).

    • Official Post

    Thank you very much for that information - We're in the process of investigating the cause behind these navigation issues in particular and this is good to know for internal comparison as well. I'll get back to you here once I have any news what so ever.

  • I am very sorry to hear that of course - Is there perhaps also a chance for you to share a screenshot of your SpaceMouse driver settings with us and generally perhaps a short video in which we can see this behavior? Just so we can make sure this isn't just a localized issue when comparing it to our in-house results.


    I'd really appreciate the effort.

    Thanks Demian,


    I will see what I can do in the next few days. A problem in taking screenshots is that as soon as I start the Snip utility the 3D Connexions Driver properties in Enscape switches to Snip settings not Enscape :)


    After a complete uninstall and reinstall of everything I seem to have the Spacemouse (driver 10.8.11.3519) and Enscape (3.5 preview 11 +95987) working to at least make it usable for client walk rounds if not very smooth in left/right horizontal rotation. This is with 'camera mode' selected, 'lock horizon' enabled but the key to making it work is under the Speed tab in the driver 'Advanced' settings to deselect left/right roll. (Also reduce the top level Speed slider in the top level of the driver properties).


    Now the camera remains mostly level but if it starts to drift from horizontal a little I press the 'F' function key on the Spacemouse to force an Elevation view.

    • Official Post

    You can also simply press the "Print" (sometimes labeled "PrtSc" too) button on your keyboard which also takes a screenshot of your whole screen, which you can then copy-paste into Paint for example for brief editing. I appreciate your efforts and in any case I'll keep you posted, but I'm at least glad to hear that it's already more usable than before.

  • Last but not least, since I mentioned a dedicated fix (which was misleading) in my previous replies we would like to know what issues you still experience exactly (besides not being able to use walkmode) and especially if you still run into any odd behavior when it comes to the controls of the SpaceMouse. I appreciate any further input.

    So my input would be, it works in Twinmotion and doesn't work in Enscape. It works in Twimotion the way it use to work in Enscape, plug and play.
    In Enscape, I am full 360 degree as if I am in solidworks. Twinmotion, horizon appears to be automatically on, I walk around and it just works.

  • Demian and all the 3d Connexion peoples.


    The saga continues.


    Sketchup + Enscape + 3d Connexion + Camera + Lock Horizon (Controls are set to reverse)= 100% - can spin in place 360°

    Revit + Enscape + 3d Connexion + Camera + Lock Horizon (Controls are set to reverse)= cannot spin in place 360° / it's like I'm drunk, it doesn't matter if Camera or Target Camera is clicked.


    Sketchup EXE + 3d Connexion + Camera + Lock Horizon = 100% - can spin in place 360°, can reverse control buttons (previously grayed out)

    Revit EXE + 3d Connexion + Camera + Lock Horizon = 100% - can spin in place 360°, can reverse control buttons (previously grayed out)

    The Sketchup EXE and the Revit EXE are both 100%!


    So it's almost 100% except for the Revit spinning in place 360°. I can use a regular mouse to spin in place, but it's not as cool.

    Enscape updated to 3.4.4 +94564

    3d Connexion driver: 10.8.11.3519, "Software is up-to-date"


    Thanks for your continued attention.

  • Apologies Demian, I haven't got round to screenshooting my experience however today I uninstalled Enscape and 3D Connexion drivers and installed the latest 3D Connexions drivers - version 10.8.12_r3545 - and latest preview version of Enscape - 3.5.0-preview.14 +99672


    This shows a big improvement with Enscape linked out of Revit 2023.1.1


    I had previously set the 3D connexions driver to 'camera mode' and 'lock horizon' but the horizon did not lock - now in this latest version it does, and is acceptable at long last for client presentations.


    I don't use other features in Enscape, just in client presentations in real time.


    cheers,

    William

  • Demian and Willsud,


    I'm not desperate, I didn't immediately download all of the drivers that Willsud mentioned.


    Enscape: 3.5.0-Preview.14+99672

    3d Connexion: 10.8.12.3545


    Sketchup + Enscape: 100%

    Sketchup / Enscape / Export EXE: 100% (controls can be reversed)


    Revit + Enscape: 100% (can 360° spin in place, I am no longer a drunk old man)

    Revit / Enscape / Export EXE: 100% (controls can be reversed)


    Wow, I didn't think this would be resolved. My thanks to the Enscape team, and the 3D Connexion team. It will make a huge difference in my Enscape navigation during meetings / presentations!