Unable to Update last two versions