Video texture works in Enscape, but in the exported EXE it's black

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • Hello everyone!


    I've run into an issue I can't resolve. I have a video texture (screen) in my model, it works fine when Enscape is running with Sketchup, but when I export the EXE it shows up as black in the EXE file. I had it working before the holidays but now the same file I made a couple of unrelated changes in no longer works.


    I am running Windows 10 Pro

    Sketchup Pro 21.1.332 64bit

    Enscape 3.2


    I have tried restarting the computer, and deleting and re-linking the video texture. It's just weird that it works in Enscape and not the exported file.


    Any ideas?


    TIA

    Paul

    • Official Post

    Pardon the delayed response - Does this issue still persist for you? Can you please also ensure that you're using our now latest release of 3.2 (3.2.0+65063), which you can acquire here?


    If that doesn't do the trick, can you let me know if this happens with any video files you're trying to use, or is it perhaps just a specific one?


    And in any case, please also send us a dedicated Feedback Report as detailed here so that we can check out your log files for any further info as to why this occurs.

  • I updated Enscape and it's still doing the same thing. I have not been able to correct it. I also submitted a Feedback report.


    The fact that it runs the video texture in Enscape fine means it's linked and working. It's only the Standalone EXE that's black, so it seems like it's a issue with the export or the way my computer is opening the EXE. I have had it working with this file, but 9 times out of 10 it shows as black...it's seems lucky/random if it works.

  • I'm guessing here but what format/codec is the video in?, whilst YOUR computer may be able to play mp4, mov, avi etc etc it could be that the Standalone can only play certain types of video/codec's.

    Additionally, does the video file have any non-English characters in its name? again it may be ok/supported on your PC but break when compressed into the exe.

  • Sorry, I'm showing my age...VC=Video Card, aka Graphics Card, or GPU...whatever they're called these days. The latest update from NVIDIA solved the issue which in theory was only on my machine, if the client's drivers were all the most current then they could view it without the black screen showing.