Batch render viewport

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • Hi everyone


    I'm aware that this is an old topic, but I think I read somewhere that it was resolver for the last enscape version.

    Well, it's still happening to me.

    Single image render works just fine, but batch render changes the viewport and gives me "extra image" on the sides. Attached image to compare, top one is single render, all fine, and bottom one is batched. Am I doing something wrong or is this still a issue?

    thanks.

  • As a guess, I'd say that there's a difference in the field of view (FOV) between SketchUp's zoom and Enscape's FOV with Enscape having the slightly wider. Enscape will render with what it has in its Visual Settings.

    They do differ and it's a bit of experimenting to get them close/the same as each other.

  • adolfobisi Do you have a saved image setting linked to the view? As Paul mentions the FOV is taken from the image setting. If you don't link an image setting to the view, Enscape will just take the active setting, which might have a different FOV then when you rendered image out as a single image.

  • adolfobisi Do you have a saved image setting linked to the view? As Paul mentions the FOV is taken from the image setting. If you don't link an image setting to the view, Enscape will just take the active setting, which might have a different FOV then when you rendered image out as a single image.

    Demian Gutberlet fwiw: I personally find this behavior unintuitive. I routinely see users struggle with this.


    I think it would make more sense to move some the FOV settings out of the image settings dialog and into the view panel (where we also have the option to make it a favorite).


    Other things that would be good to add to the view panel is Time of Day (we can already do that in the video editor but not for regular views). And of course a button to update camera position.

  • Thanks for the answer guys, it seems to be exactly that.

    I did some tests here as follows.


    camera settings are saved into the scene in sketchup. "Synchronise views" is selected in the enscape panel. When I change scene in skp, enscape will correctly follow that scene, changing FOV accordingly.

    If i change scenes one by one and make the renderings manually, the come out perfect, but that negates the whole purpose of batch rendering.

    If I do a batch render, enscape will follow everything from the saved scenes, EXCEPT the FOV. It will just use the "visual settings" FOV instead. My personal problem is that I do a lot of interiors and the FOV changes a lot, otherwise i would just set it and batch pictures with same FOV at a time, but this workaround is impractical for me.

  • Hi all, is there a way around this issue?


    I also save scenes in Sketchup with varying 'focal lengths' between them, and would ideally batch render them, but as adolfobisi has explained, Enscape seems to ignore the unique fov of each scene and instead uses the FOV set in the Enscape 3D viewport. This is a bit of a killer if you need different focal lengths and many scenes, and there's a revision that requires most or all of them to be re-rendered.


    Thanks

  • EDIT:


    I just reviewed the forum because I was pretty sure this has been discussed MANY times before, and voila... since 2018 this behavior has been complained about.


    The current behavior for View Sync when creating single renderings needs to be also used for batch renderings. Currently, when view sync is enabled the field of view slider is grayed out and whatever FOV saved in sketchup overrides.


    Can we please get batch rendering work also work this way so that the UI will be more consistent, intuitive, and batch rendering infinitely more useful?