Previous Release / Preview Threads Merged

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • Thanks a lot for your report. Looking at the images I think that's not a denoising problem, but probably the emissive(?) geometry not being visible anymore. This could be related to other changes behind the scenes that involve the data structures used for ray tracing.

    It'd be great if you can share the material setup of these objects (maybe try flipping front/backside?) or even share that section of the project with us, so we can investigate this further. Thanks!

    Hi Clemens,

    the project has not been changed from previous renderings. All the materials are the same.
    In my example there is a sphere light between the two metal panels, no emissive material.

    This is my material setting
    (and the normal orientation for the faces)



    If you want I can send you the SU file of the project. Please just keep it strictly private.


    Mirko

  • Good morning.

    Although the Enscape is enabled to notify when there is a new update, it does not.

    When you ask the ESCAPE to check the existence of a new version, it does not run either.

    What may be happening?

    Thanks

    • Official Post

    Dear Forum Community,


    We've just released the latest Enscape 4.0 Preview 3!


    NEW:

    Intel Arc GPU Support

    Intel’s dedicated Arc GPU line-up is now supported, including their hardware ray-tracing capabilities.


    Rhino 8 Support

    Enscape now supports Rhino 8.3 or later.



    UPDATE:

    Improved Denoising in VR

    The NVIDIA Real-Time Denoiser is now also integrated into our VR rendering pipeline, reducing noise on Quality Levels “High” and “Ultra”.


    Revit Worksharing Improvements

    Reduced the frequency of needing to sync with central. Two people working on different views with different presets should no longer run into conflicts.


    Support Window

    The existing Feedback window has become the Support window.


    Introduced “Ongoing Asset Placement” Dialog

    Users can now see the document in which assets can be placed while placing them from the Asset Library.


    Enscape Windows Run in a Separate Process

    Enscape 4.0 contains a lot of under-the-hood changes to have a common code base for Windows and macOS. One of these changes is that all Enscape Windows now run in a separate process. This improves stability and also reduces the risk of incompatibilities with other CAD plugins.


    Dropped Support for TIFF/TGA File Formats

    The support for TIFF/TGA files formats is dropped due to technical limitations.



    BUGFIXES:

    Rough Metal Appearing Black

    Rough metal behind a glass surface could appear black (with hardware ray-tracing enabled).


    Web Standalone: Fixed Teleport on Minimap

    Clicking on the minimap could result in teleporting to the wrong coordinates or not at all.


    Fixed Crash When Running Out of Memory When Ray-Traced Sun Shadows Is Active

    This crash could occur when additional memory is required for ray-traced sun shadows and the scene was concurrently being changed.


    Fixed Crash When Opening a Project Without a Light Near Any Geometry


    Fixed Artifacts in Panorama Rendering

    Unwanted geometry edges could appear in panorama rendering.



    KNOWN ISSUES:

    Collaborative Annotation Mode Is Missing

    This mode is missing as it is still under development. It will be included in a subsequent preview release.


    Custom Asset Editor Inside of Enscape Not Opening When Not Configured

    Workaround: Open the installed Custom Asset Editor application and configure it.


    To see what has been added with release 3.5 itself please check out this post here.


    If any questions or further feedback arises, please let us know via this thread or by reaching out to our support. In case your experience any crashes, freezes or similar, kindly submit a feedback report with log files if possible.

  • Hi Demian, is very good to hear you about a new version after a long time.

    I just did a little test and it seems that the global illumination is more precise than before (very good) although I will have to set the power of the emissive materials again because now they shoot much more light.


    Little problem: i cannot do batch rendering because of this message.

    (i have already set the path for saving the images)

    Any idea?
    Thanks

    Update (after a few days):
    Uninstalled. Never seen a beta bugged like this. ?(

    • Official Post

    Pieter , in this case could you please try to run the setup with administrator permission? As in, right-click on the setup file and then "Run as administrator" if that's possible on your machine. Does the setup now proceed throughout the steps as it should and properly install preview 3?


    If that doesn't do the trick, please also try to:

    - Install 3.5.6 (or any other 3.x version) again

    - Uninstall 3.5.6 (or any other just installed release) manually

    - Install 4.0.0.Preview 3 as administrator like detailed above


    Please let me know about the outcome and thanks a lot in advance.

    • Official Post

    Anyone else having trouble installing the preview 3? I get stuck on this screen:

    Just so you know I've slightly adjusted my previous reply as well in case running the preview installer as administrator didn't do the trick right away. At least on my machine the installer worked without further issues with this procedure alone, but in case it doesn't on yours.


    In general our developers are aware of this behavior and we're looking into resolving this for the future.


    Of course kindly get back to me if you're running into the same or any other problem despite the steps above.

  • Hey Demian,


    I tried

    - reinstalling 3.5.6

    - uninstalling 3.5.6 manually

    - running the installer as administator


    But it's still stuck on the 'we are uninstalling the older Enscape version 3.x' page.

    • Official Post

    Same here. Won't install.

    Thank you for your patience.


    In order to now resolve this you can briefly install a program called "Revo Uninstaller" also available as a portable version (and free of course): https://www.revouninstaller.co…ts/revo-uninstaller-free/


    Afterward simply locate Enscape within and then use the Uninstall button or press right-click -> Uninstall instead:


    Afterward the native Enscape installer itself should pop up allowing you to uninstall, and thereafter you will be prompted with another window from Revo Uninstaller to analyse if the installation was properly removed. Simply click the Scan button to proceed.


    Hereby it's important to remove the following entry specifically under Uninstall as highlighted with a red rectangle here:

    Make sure to not remove the Uninstall entry above just above.


    After this procedure you should be able to properly install Enscape 4.0 Preview 4.


    We will of course be looking into resolving this prior to the full release of Enscape 4.0, but I hope this current method won't cause too much extra work.


    Let me know in case you still experience this or any other problems thereafter.

    • Official Post

    Pieter , laffnedavoc , pardon the double post but there have been some further adjustments made to my previous reply, just to ensure you're seeing the updated version. As mentioned, please let me know if you still experience any issues thereafter.

    • Official Post

    Demian Gutberlet


    I tried these steps, but the registry key underneath uninstall has another number than the one on your screenshot. Should I proceed?


    (I installed the latest stable build before initiating the installation process through Revo).

    Yes indeed no worries, we've just used a slightly different release of Enscape in that example.


    As long as you don't remove the "Uninstall" folder as a whole you're good to go. :)

  • It installed now, but it was a weird process. The process bar almost immediately went to 100% and then it seemed stuck for a few minutes (while the fans on my laptop kicked into high gears). I thought it had gotten stuck again, but after a few minutes it finished properly.

  • I managed to get it running. I had a nasty _second_ Enscape entry that showed in Revo Installer. It was linked to an old Preview (94756) and indepenend of the actual enscape installation. After removing it with the help of regedit (Right click in Revo "Open Registry Key...") the 4.0 installation issue was gone. Thanks for the right hint :)