Previous Release / Preview Threads Merged

Reminder: If you encounter any issues with Enscape (including installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Feedback button as detailed here. Thank you for your understanding.
  • I managed to get it running. I had a nasty _second_ Enscape entry that showed in Revo Installer. It was linked to an old Preview (94756) and indepenend of the actual enscape installation. After removing it with the help of regedit (Right click in Revo "Open Registry Key...") the 4.0 installation issue was gone. Thanks for the right hint :)

  • In my opinion, Enscape 4.0 should look like this.

    No.1 Alpha video

    录制_2023_06_15_18_02_54_179.mp4


    No.2 dynamic model

    录制_2024_02_19_11_00_49_1832024219111812.mp4


    No.3 Light caustics

    录制_2024_02_19_11_05_48_171.mp4


    No.4 Projection lighting

    录制_2024_02_19_11_10_50_55220242191124286.mp4


    No.5 Better shadows, long-distance

    录制_2024_02_19_11_28_30_500.mp4

  • Enscape always freezes when I turn on layer with 1575 individual spot lightsources (led lights) with sync on in sketchup. When i turn sync off, then turn the layer on, and then turn sync on again, it works smoothly. It happened also with version 3.5.


    Freeze screen:


    • Official Post

    While placing enscape library object I pressed space and it immediately crashed (preview 3, sketchup 2023, rtx3060 latest driver)

    In general, whenever you experience any crashes/freezes with Enscape, be it the latest preview especially, please simply right away get in touch with our support team directly using the feedback button in this case: https://learn.enscape3d.com/bl…back-button-win-sketchup/


    This way we have your machine information and log files available from the get go for further troubleshooting purposes.


    Thank you very much in advance.

    • Official Post

    Hello,

    I still can't install 4.0.0.228-preview3 after following the process.

    When will the official version be launched?

    Also, is there any chance to release a traditional Chinese version?

    I'm sorry to hear abut that. Just to make sure, you've followed the exact steps detailed here, correct?


    If so, could you let me know where exactly you're getting stuck during the process? Perhaps there is any error message or dialogue in general displayed of which you could take a screenshot for us to see?


    That would be very helpful and thanks a lot in advance.

  • Is this really the only new features and improvements for 4.0???


    • Intel Arc GPU support
    • Improved denoising in VR
    • Revit Worksharing improvements
    • Rhino 8 support
    • Support window
    • Introduced Ongoing Asset Placement dialog
    • Enscape windows run in a separate process
    • Dropped support for TIFF/TGA file formats
    • Bugfixes and stability improvements
  • Hi


    We've had an issue since version 3.5 upwards, details of which are recorded under support ticket 150544. The issue described below was never resolved but we were told would be addressed in the next update. I've just tested on the preview and it seems it is still happening, I was just wondering if you have seen this behaviour.


    Using Rhino7 in certain models when launching Enscape the folder C:\users\%username%\AppData\Local\Temp\McNeel\Rhinoceros\V7\Texture$Cache$ slowly builds with black and white tiff files. Once complete the Enscape window shows the model. The issue here is two things. for example in the model I just tested (which admittedly is large) this cache grew to 105GB so Enscape takes a long time to load whilst this happens but also if the user has limited disk space the machine grinds to a halt.


    Should be said I don't know if this is an Enscape or Rhino issue but it doesn't happen if I downgrade to Enscape version 3.4.4 but every version since has the issue. Thought I'd mention here in case others are experiencing similar and whether it is at all being addressed.


    Thanks

    ***
    EDIT: had an update from support since posting, so for the benefit of anyone experiencing the same thing, this is a known issue resolved in Enscape 4 in Rhino 8 only. Can confirm I have tested Enscape 4 (preview) in an evaluation copy of Rhino 8 and the issue does not occur.

    • Official Post

    This version is exacly as unstable as 3.5 in Rhino!!! Navigating the viewport is impossible!!!

    I'm sorry to hear about that of course.


    Right away just to make very sure, you're already using either Rhino 7.36 or Rhino 8.3+? If so, and you're already using the latest service releases of Rhino (e.g. Rhino 8.4), definitely also submit a dedicated feedback report as detailed here so that we can check out why this may still occur on your machine despite the fixes/adjustments Mcneel and we have made.


    Thank you in advance.

    • Official Post

    Thanks a lot for your report.


    If sending in a feedback report does not work for you, could you please manually send us the necessary log files, both from the the Enscape main plugin folder as well as the corresponding CAD host application plugin folder since they hold different information that are crucial to us to assess the current issue. You'll find them here:


    Enscape main plugin log files:

    C:\Users\%USERNAME%\AppData\Roaming\Enscape\Data\Logs


    as well as


    Rhino plugin log files:

    C:\Users\%USERNAME%\AppData\Local\Temp\Enscape\Logs\EnscapeRhinoPlugin


    Simply make sure to put these logs into a .zip file and submit what you've written here alongside said file via our Help Center:

    How do I contact Support? - News & FAQ - Enscape Community Forum


    Afterward we'll investigate everything we've received at hand to get back to you accordingly via the created case.


    Thank you once more in advance.

    • Official Post

    Batch rendering automatically causes an untimely shutdown, tried to install the previous version (3.5) without success. :(

    Just in case you haven't already, please definitely make sure to also submit this issue via our feedback button, which is generally recommended whenever you wish to reach out to our support team for assistance or bug reporting: https://learn.enscape3d.com/bl…sing-the-feedback-button/


    Doing so will transfer all of your machine information, alongside corresponding driver dates and log files which should help with further troubleshooting. Thank you in advance!


    Ens3.5.6 can be opened and rendered, and immediately crashes after starting the rendering window in Ens4.0 p3

    Thank you as well for reaching out to our support team already. As you've likely seen by now, we still require the corresponding generated log files from your machine, the details can be found in the e-mail we've sent you. Your cooperation is appreciated!

    • Official Post

    Dear Forum Community,


    We've just released the latest Enscape 4.0 Preview 4!


    NEW:

    Ray-Traced Artificial Lights (Beta)

    This new feature can be enabled in the Renderer settings if your graphics card supports hardware ray-tracing. Ray-traced artificial lights offer a range of quality improvements over the previous shadow mapping based technique:

    • Higher quality shadows: No aliasing of shadow borders, precise and sharp shadows for small point light sources and physically correct soft shadows for area lights
    • No more unrealistic illumination cut offs due to limited light radius range
    • Scalable to a large number of light sources with consistent performance

    Shadow mapped based lighting:


    Ray-traced lighting:


    Shadow mapped based lighting:


    Ray-traced lighting:


    UPDATE:

    Animated Vegetation Will Now Use Less VRAM if Wind Is Turned Off

    If you have out of memory errors with ray-traced sun shadows in scenes with animated vegetation assets you can try to turn off wind completely, as this will now use less VRAM.


    Removed Fixed Limits of Ray-Traced Geometry for Captures

    Enscape used to enforce a fixed geometry limit for ray-traced reflections and global illumination. Several optimizations of our ray-tracing data structures allow us now to manage much more geometry than before and replace this fixed limit with a flexible upper bound based on the available memory on your graphics card (VRAM). Given enough VRAM the entire scene can now be considered for reflections and global illumination when you do a capture (image, video or panorama) and have hardware ray-tracing enabled. Known issue: In this Preview version captures of complex scenes including many light sources may take notably longer. This performance issue will be fixed in the next preview version.


    Considered geometry for captures before:


    Considered geometry for captures in 4.0:


    New UI Theme & Icons


    Collaborative Annotation Mode Available Again


    Texture Editor UI Updates

    Albedo texture transformation is always explicit, while all other texture slots could use, either explicit texture transformation, or the values assigned to the Albedo texture transformation.


    BUGFIXES:

    Fixed Custom Asset Editor Inside of Enscape Not Opening When Not Configured


    Fixed Batch Rendering Not Working With Default Output Folder


    Fixed Keyboard Shortcuts for Scale and Translate Asset Library Tools


    KNOWN ISSUES:

    Installer Might Hang When Uninstalling Enscape 3.x

    In some rare cases, the installer hangs when uninstalling Enscape 3.x. Follow the steps provided in this forum post to solve the problem.


    Revit Section Box Is Reflected in All Views


    Browse Custom Assets Area Is Inaccessible After Project Create or Edit

    The Browse Custom Assets option within the project Create or Edit view is broken and replaced by a non-functional button. Please close and reopen the editor window to access it.


    Errors Are Logged During Assets Selection


    Switching Views Inside Enscape Might Lead To a Crash With Hardware Ray-Tracing Enabled



    To see what has been added with Enscape 4.0 Preview 3 please check out this post here.


    If any questions or further feedback arises, please let us know via this thread or by reaching out to our support. In case your experience any crashes, freezes or similar, ideally submit a feedback report with log files if possible.