Editing custom assets - "The Custom Asset Editor could not find a project for the request asset"

  • Hi,


    After importing and creating a custom asset into the custom asset library, Enscape wont allow me to edit the custom asset. I am looking to be able to just change the materials as It was defined upon creating it.


    I get the prompt "The Custom Asset Editor could not find a project for the request asset" . Then I am asked to open the project to edit it, and then either save over the existing asset, or create a new one.


    I have tried accessing it both in Enscape window and within Revit.


    Lastly, both the Project and Output are the same location.


    Any idea what could be triggering this?

    Thank you

  • Rick Marx

    Approved the thread.
  • Look in the materials folder for your custom asset. If you replace the material with a different material using the same name it should work. Or you can open the custom asset in the asset editor and modify the material from there.

  • Hi, Phil.


    Which materials folder are you referring to? The Enscape Material Editor? Otherwise I don't see a materials folder that has the custom assets. We have tried everything to be able to edit the custom assets material but it wont allow us to open the actual asset. It prompts me with the error I attached in my previous post. It then opens the Enscape Custom Asset Editor but the asset does not appear. We then have to Open the Project file to edit the materials and override, update the thumbnail, save projects, then generate asset again.


    So I am not sure what could be the reason for not being able to open the asset in the Custom Asset Editor. Is it a configuration setting? Both paths are in the same location.


    Hope this helps. We are stumped.

  • Quick follow up. I want to attached the step by step process with screenshots in hopes it helps.


    Revit 2021 - Version 3.3


    00 - click the edit new asset

    01 - Error window pops up

    02 - Custom Asset Editor opens once I close the error prompt. No Asset appears.

    03 - Check the Project Directory

    04 - Check the Generated Assets location

    05 - Check to see where the project is located - same as configuration

    06 - Open the project. Here is the only way I can edit the materials. I have to open the project. Edit the materials, resave, update thumbnail, and then regenerate the asset

    07 - Try and replace the Material #0 and Material #1 within the Enscape Material Editor but the materials do not show up.


    The issue we have is the asset not opening up when we click to edit the asset. Its strange to me it cant find the project when the project path linked to the project...So unfortunately we cant use our custom library in Enscape just yet. I am hoping these screenshots can help.


    Thank you for your help