SketchUp Create View - turn off Shadows as default

  • I have a little issue where after creating SketchUp scenes from Enscape's tool bar, the shadows turn on everytime I click on the scene which wouldn't be a problem for me with models that aren't so heavy. However, when dealing with larger and much more complex model's, this runs the risk of crashing Sketchup and Enscape. I understand I can just turn off the shadows through the scene editor toolbar but its a bit of a chore to do when dealing with many scenes.


    Would it be possible to turn off this default setting whenever creating new scenes through Enscape?


    Thanks in advance,

    Steve

  • I have the "Scene" tray open in SU: when you click on the [camera] button to create a view it shows up and says "Enscape View", but does not change the currently active SU scene.

    This means I can re-name the scene and un-tic every tic box except "Camera Location".

    ... now the scene won't turn on the shadows. (Unfortunately shadows and time are tied together, so I use the "Description" field to type in what time settings, FOV or any other scene specific settings I have changed.)


    Click to render, click the add scene button: by the time I have changed all that in SU it's done rendering.


    {PS I have also asked for this feature in the past ;) }

  • id prefer it just used the current scene settings. (we typically have most of them off for large scenes)

    In Skup18 if you make a scene with SKUP it remembers settings, use the enscape button and it turns all options back on.


    agree its a crash risk to have it remain on.

  • In another thread we discussed something similar but the SketchUp API that provides developers with the commands to manipulate SketchUp doesn’t have any options when it comes to creating scenes, it’s all or nothing.

    The only way to change this is for Trimble to add additional functionality to the API.

  • I would love for the shadows to not be turned on as well, but are aware of the API limitations. I usually just turn the shadows of in the "shadows" tap, and then right-click the scene and select "update"... its annoying, but not that big of a problem :-)

  • You can just take the camera cosition in Enscape, without changing the scene in SU. Click on Manage View (button), you will see every scene has a Set Camera Position (button), click it and Enscape view will change to that view, and nothing happens in SU, neither the view nor the shadows.