Revit - Enscape Assets not Rotating & Changing Z Direction

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • I have been using Enscape on Revit 2023 since it came out and this is the first problem I have really had. Since yesterday, out of the blue, I am not able to continue editing the Enscape assets in Revit. I had recently just done a few updates for Revit and am not sure if there was something in the Update that is causing this issue.

    I have all of my Enscape assets in a separate workset for ease of filtering on documentation and keeping a clean model. While being in the proper workset and having the worksets editable, I am not able to edit any of the Enscape assets, both existing and new. Every asset that has been placed in the model has previously been edited (rotated / scaled). The other issue I'm seeing is that whenever I try to move an asset or copy them, even with constrain on, the asset changes in the z direction. I have checked the workplane and it is set to my ground level on a horizontal datum so that doesn't seem to be the issue.


    When I pull up the live-render Enscape window and click on the "Asset Library" button, the only edit commands for the asset that is grayed out is the rotate tool. I'm assuming this is a new issue because I have never noticed this button being grayed out before and when hovering over the button it states, "Revit does not support all rotation axes for Enscape assets".

    Anything helps.

    Cheers,