Multiple reflections problem

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • Hello guys.

    There was a time when Enscape would not render multiple reflections, and this was changed at some point, so i.e. a mirror would show a second mirror reflection as well. is there a way to disable this via some config files? I would rather have the old method as the multiple reflections are giving me some strange results. I can get the result I want by rendering the mirrors from behind a glass panel, but it is extra work and I would apreciate if I could just turn this off.



    This is what i get with multiple reflections. I cant use this king of image


    This is what I would like to have, just a single reflection from the mirror. This is possible by rendering from behind a glass pane, but as I said, its an extra step to do.


    Thanks for any help

    • Official Post

    adolfobisi , thanks for your inquiry.


    There is no direct way at the moment to disable these multiple reflections (besides setting the Rendering Quality to "Draft" which is not something you may want as it only then displays the Skybox in reflections) - I am sure you put some thought into the placement of your mirrors, but even though it would show no artifacts in a real-life situation like seen in the example, there'd still be an "infinite mirror" effect occurring there too. Reflections, in general, have been improved further though already with our latest Preview, which you can try and acquire for yourself here too - It may not resolve your issue in this case, but could help, if not in the near future when other reflective surfaces come into play.


    Perhaps there is also a way for you to only keep one of the mirrors, or alternatively, you could lower the "Metallic" setting of the material to make this behavior less obvious at least.


    Let me know if any further questions come up regarding this subject or any other.

  • Hello Demian, thanks for the reply.

    Unfortunately the mirror placement is part of the designer project, I have no authority to change them, and sadly the next release preview didn't make the reflections any better, in this case at least.


    Now for the solution i used, if anyone is having the same problem

    Put a completely clear glass plane in front of every mirror that could have this issue. Dont forget to put a 2mm space between them to avoid those coplanar artifacts.


    Only mirrors, strange effect


    Mirrors + glass. Not quite the result irl, but still better than those strange mirror angles.

    Hope this is helpfull for anyone withthis issue.

    • Official Post

    I understand adolfobisi , and thanks for getting back to me again so quickly - I'll forward your inquiry as a feature request as well to allow the deactivation of multiple reflections in the future especially if there'll be even more demand for this.


    For now, thank you as well for sharing your solution, I am glad it is a viable workaround at least.