Shadows incorrectly displaying on 3.4

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • Hello. I've just encountered this bizarre artifact with the shadows where it seems like it is incorrectly rendered depending on where the camera is view. See the images below:


    1. The shadows are completely off. There's nothing above the building, but somehow its own shadow is being rendered above the roof.


    2. If I rotate the camera to another angle, the shadows suddenly appear fixed. It's only the previous angle where the shadows are messed up.


    3. However, another shadow artifact is noticeable. On the top right, there's a clean cut-off and there's light, despite the fact that there's a roof there that should be blocking light. On the second picture, I went inside the building and looked at the angle where the shadows begin to break.

       


    I have no idea what is causing this. I tried using older versions up to 3.1.0, but the same lighting bug occurs. The shadows are fixed on versions around 3.0.0, but that version has messed up glass rendering for some reason, which is another bug in itself but I'd rather focus on the shadow artifacts right now. I've updated drivers and everything, but the shadows are still broken.


    My PC specs are these if it's any helpful:

    AMD RX 5700 XT

    AMD R5 2600

    16 GB RAM


    I'm also using the SketchUp plugin of Enscape.

  • I have a similar issue, though I am using Rhinoceros 3D plugin of Enscape. This also appears in older files where I have not had an issue with. I updated drivers, but I was on 3.2, then updated to 3.4 and still had the same issues. My license is a student one.

    My PC specs are also AMD, so it could be an AMD related issue perhaps...

    • Official Post

    Thanks a lot for the reports.


    Does this issue also persist when you disable or enable Ray-Tracing (of course only if it's supported by your card):


    Kindly let me know if you have a chance to test this.


    On top of that, please submit us a Feedback Report including log files as well. These may already give us further hints as to why this behavior occurs.

  • Can't test the ray-tracing on my end.


    I did found out after tinkering around with the sun angle that it changes the camera angle where the shadow issue occurs. Also, the artifacts don't appear if the sun is set around sunrise and sunset.


    I can't really downgrade my AMD drivers since I'm not sure which driver update caused it and I don't have time to find out which one of it is at the moment.


    I've sent a Feedback Report for now.

  • Im also having the exact issue with random shadows casting all over the place.
    I also dont have the ray tracing feature as my graphics card is AMD Radeon RX 5700 XT.

    Im using Rhino and unsure whether the issue is caused by the update of rhino or enscape. It was working fine previously.
    I've tried reverting the enscape version but issues still occurs.

    Please help resolve. Thank you

    • Official Post

    Thanks for the report.


    There have been other AMD users reporting these kinds of issues regarding sun shadows - It's already filed as a bug internally so our developers are currently looking into it to resolve this behavior as soon as possible.


    I'll keep you posted through this thread once there is any further news I can share soon.

    • Official Post

    Thank you for the follow-up, much appreciated.

    Please see attached images

    Thanks a lot for the screenshots.


    I've adjusted my previous reply after I was made aware that this is currently an issue many AMD users are facing in terms of sun shadows behaving not the way you'd expect them to. Kindly re-read the response if you haven't.


    We're busy resolving this issue as quickly as possible of course, and as mentioned in my reply before I'll also get back to you once I have further positive news to share.

  • Hi everyone. Just an update for this thread.


    I've had gotten a reply from Enscape Support and they told me that the 'optional' driver ver. 22.8.1.220810 is what caused the incorrect casting of shadows. I've downgraded to ver. 22.5.1 and the shadows are fixed now for my end.


    I guess this is a temporary fix for us AMD users, and I hope that AMD fixes this on with their future drivers.


    Cheers! ^^

  • Thank you. The driver downgrade fixed the problem in Enscape and D5 Render.

  • Hi everyone,


    I run the same issue with random shadows casting all over the place (please see the attached image). I have read the previous comments about disabling and enabling the Ray-Traced Sun Shadows, but the problem didn't fix. I have also uninstall and re-install the latest version of Enscape. Also, I have an AMD driver (the 22.10.3 version).


    Could you please help me resolve this issue?


    Thank you in advance.

    • Official Post

    Thanks for your report.


    You will currently still also have to downgrade to the 22.5.1 version when it comes to your AMD drivers - Please kindly try that and let me know in case you aren't successful. This behavior will also be resolved with 3.5 or a preview beforehand, so this is the current workaround.

  • We've been using Enscape for quite a few years now, and due to some early bugs a few years ago with enabling raytracing, we decided to turn it off for renders. However, we've since decided to try it again, but unfortunately now we are noticing this same graphical issue as above with what is possibly termed 'shadow acne'.


    We're running the very latest Nvicia drivers as well as latest Enscape version.


    Incidentally, it's the same issue if rendering through Twinmotion with raytracing enabled.

    ...as such, I would assume this is a global issue with Nvidia?

    • Official Post

    Especially with raytracing enabled and you still experiencing these issues could you please send me a few screenshots of that?


    In the thread before there were only examples shared of shadows behaving false entirely due to certain AMD drivers, so some examples showcasing this behavior in your scene would be great.

  • Quick example.


    Actually think part of the issue is with the file format and object type (in this case good old Autodesk DWG format, '3D Solid') - when we explode the 3D Solids it changes the faces to 'Region's and when rendering, the issue seems to disappear....so far. Still investigating....

    We utilise externally produced detailed 3d city survey files as part of our early feasibility and planning stages, and receive them in DWG format with buildings, roads etc being '3D solids'.


    If nothing else, hoping this R&D time spent today may help other's out there.


    I'll share further findings.

    Wondering if AMD users have same issue. (not that it affects us)

  • The exact same Issue still exists after updating to 3.5. This is disappointing. Running Enscape on a AMD Radeon.

    ARCHICAD 26 / AMD Ryzen 5, 48GB / AMD Radeon Pro 5700 / Windows 11/ Enscape 3.5.0+107264

    • Official Post

    The exact same Issue still exists after updating to 3.5. This is disappointing. Running Enscape on a AMD Radeon.

    The issue shared here (excluding that of Jeppo03 above) should be resolved already by upgrading to the latest AMD Radeon drivers at this point. This was unfortunately an issue we weren't able to resolve directly ourselves as it was up to AMD in this case, no finger-pointing of course or blaming them, but just as side info this was a behavior caused by the drivers themselves.


    If upgrading to the latest drivers does not do the trick, have you also tried reverting to version 22.5.1 which was the workaround before?


    Last but not least, as you haven't reported this issue at least in the Forums before, do you experience perhaps what Jeppo03 does just above your response instead of the expected shadow issue caused by AMD drivers?


    Thank you in advance, I do appreciate your cooperation!

    • Official Post

    Just to investigate further to make sure this is simply something which may not render properly in Enscape is there perhaps a project file you could share with me to reproduce this? At least this way I can also ensure this occurs with NVIDIA cards too, not just AMD but in Enscape or even other external rendering plugins. Let me know if you ran into any further findings too, thanks!