Enscape crashing and causing SketchUp to crash as soon as Enscape viewer is clicked

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • I recently downloaded Enscape 3.4 for use with SketchUp 2021. Every time I open the Enscape viewer Enscape malfunctions - noting "Enscape encountered an error during rendering. It is using a GPU from NVIDIA. Vulkan Error::vk::Queue::submit: ErrorDeviceLost at queue submit.


    A screen shot of the error message is below.


    When I choose "Close Enscape and send feedback" SketchUp then crashes before I can submit the feedback or log information.


    I'll note I'm using Windows 11 with a fully updated nVidia Graphics card - GEForce GTX1660Ti with Max-Q

    I would appreciate help how to resolve - otherwise I am completely unable to use.

    • Official Post

    ctoothill , thanks for your report and welcome to our Forum.


    Please kindly simply press the first button in this dialogue and we'll receive a dedicated Error Report. This report will then allow us to troubleshoot the cause behind this as quickly as possible.


    Let me know once you've sent it in and thank you again in advance.

  • Hi guys, just noticed this post, I am having the same issues with a Windows Surface Book 3 running a GEForce GTX1660Ti with Max-Q.

    Updated everything, plenty of RAM, still crashes every time...


    Any workarounds?

    • Official Post

    Hi guys, just noticed this post, I am having the same issues with a Windows Surface Book 3 running a GEForce GTX1660Ti with Max-Q.

    Updated everything, plenty of RAM, still crashes every time...


    Any workarounds?

    In this case, a feedback report with your logs would be good to receive as well.


    Please also ensure that you don't have Ray-Tracing enabled as your card is not suited for this functionality (despite the fact that it is technically supported):


    Otherwise, if that doesn't help, is there any chance you are using projects of the larger size? Or generally high-res textures alongside maybe an imported high-res .HDR file used as a skybox? Even high-quality models from third-party vendors can result in your graphics card memory (VRAM) running full and thus producing this crash.


    Thank you in advance for any further replies.

  • Even high-quality models from third-party vendors can result in your graphics card memory (VRAM) running full and thus producing this crash.

    Could you consider updating this message to better indicate what is -actually- causing the crash?


    This seems to be the default error that Enscape throws up when anything goes wrong. In 99% of cases the cause is running out of VRAM due to large models, rendering at ultra hi-res, using RTX reflections, or a combination of those. It is almost never solved by updating GPU drivers or changing which graphics card is used. It sends our users and IT dept down useless troubleshooting paths that do not solve the problem.

    • Official Post

    Could you consider updating this message to better indicate what is -actually- causing the crash?


    This seems to be the default error that Enscape throws up when anything goes wrong. In 99% of cases the cause is running out of VRAM due to large models, rendering at ultra hi-res, using RTX reflections, or a combination of those. It is almost never solved by updating GPU drivers or changing which graphics card is used. It sends our users and IT dept down useless troubleshooting paths that do not solve the problem.

    You are correct when it comes to what caused this crash as I can see per the provided feedback report we received. (Ray-Tracing was indeed enabled) I've made that more clear in my previous reply, pardon me for overlooking that this particular GTX card is indeed capable of Ray-Tracing but not suited at all.


    Regarding your experience when it comes to troubleshooting this for your users, are you strictly talking about what is being communicated here in the Forum, or the support channels? (support@enscape3d.com / Crash Report)

  • I've had the same problem since Aug 25th....someone has been working on my laptop for the last 2 days.....he even removed the latest update but that didn't help.......I assume enscape gives priority to this? Please tell me that someone is closer the solution? I have a major deadline....and can't present my design to my client :(


    Ow....And before you ask....yes...my laptop has all the recommended system requirements...and it has worked fine...until the latest update

  • Regarding your experience when it comes to troubleshooting this for your users, are you strictly talking about what is being communicated here in the Forum, or the support channels? (support@enscape3d.com / Crash Report)

    I'm talking about the language in the error message pop-up.


    Typically the user is working along just fine rendering lower-res drafts, then they try to do final output and crank up the resolution, and the error occurs. Their first line of action is to call our internal IT helpdesk. Our Helpdesk

    - Checks the switching of the internal graphics card. It is always set appropriately.

    - Updates drivers. Our drivers are kept fairly up to date, and this never solves the issue.


    After wasting time with that, the helpdesk gets in touch with our rendering specialists to troubleshoot the issue further. Turning off RTX features, reducing the amount of geometry in the scene (section box in Revit,) reducing quality from Ultra to High, reducing output resolution, or a combination of those fixes the issue 95% of the time.


    Every time I have submitted this error to Enscape, I get a diagnosis of "VRAM maxed out." Every time I see this error discussed on the forum, the diagnosis ends up being "VRAM maxed out." So if that is the leading cause of the crash, why is the message suggesting to switch the graphics card and update drivers?


    I'm suggesting the pop-up could say something like "your GPU VRAM has likely reached its capacity. To reduce VRAM usage, try the following...." (suggestions as noted above)

    Then maybe "switch graphics card" and "update drivers" as secondary possible solutions.


    I would also think that might reduce the number of logs getting submitted to Enscape by giving users more useful advice in troubleshooting their own issue.

    • Official Post

    I've had the same problem since Aug 25th....someone has been working on my laptop for the last 2 days.....he even removed the latest update but that didn't help.......I assume enscape gives priority to this? Please tell me that someone is closer the solution? I have a major deadline....and can't present my design to my client :(


    Ow....And before you ask....yes...my laptop has all the recommended system requirements...and it has worked fine...until the latest update

    Right off the bat that user can also try disabling "Hardware-accelerated Ray-Tracing" as detailed above, or lowering the Rendering Quality, or when it occurs during the export process, the resolution size of renderings. We can give you more exact information after receiving a dedicated feedback report from that user's machine if the steps above do not help, so kindly submit one if you haven't already.


    I really appreciate the response, thanks, that clears it up of course - Matter of fact, we are actually looking into a dedicated additional system so to speak to what you proposed but it's still a bit too early to talk about details. In the end, our goal is to allow users to do more of the troubleshooting themselves though, if possible. I'll use your feedback to further reinforce the demand for this.

  • Hi, I have the same problem. I was working on a project in Sketchup 2023 which does not have too much complex geometry, however, the last bit I did was adding more lighting + adding more models.


    Problem starts:

    1. When I start Enscape and get to 99%, it shows a window saying that "Enscape encountered an error during rendering. It is using your GPU from NVIDIA.

    Vulkan Error: vk::Queue::submit: ErrrorDeviceLost at queue submit.


    What I have tried:

    1. Uninstall Enscape and install the newest version (Currently, I have the most updated Enscape version, which is: Enscape Versopm 3.4.4+94564 (This step haven't solved the issue)

    2. I have updated my GPU as suggested in the message box (This step haven't solved the issue)

    3. I have deleted lighting, and complex geometry (Which is, to be fair, not much), saved the file as a new file and stored the file on the C: folder

    4. My computer doesn't have the ray-tracing ability, so that's not the issue in my case



    My computer specs:

    Model: Lenovo Laptop-J9FA4RKS

    NVIDIA GeForce GTX 1070

    Windows 10 64 bits

    Intel(R) Core(TM) i7-7820HK CPU @ 2.90 GHz (8 CPUs), 2.9 ghz



    Findings

    When I open a file that has less heavy geometry, I can run Enscape.


    Please help as I do need to submit renders to clients soon!


    Thank you for your time on assisting.

    • Official Post

    Thanks a lot for your report.


    Right away, whenever you experience a technical issue like that or even crashes, please ideally instead get in touch with our technical support team directly by submitting a feedback report with logs/crash dumps and machine information: https://learn.enscape3d.com/bl…sing-the-feedback-button/


    Besides that this error at hand usually occurs when your graphics card memory is running full (VRAM), although you mentioned the scene shouldn't be too complex, so in that regard the logs should tell us more.


    You can expect an e-mail back with likely a solution/workaround too in the following 1 or 2 days tops after the report.

  • I'm having the exact same issue. Just started today and on one particular file (as far as I can tell thus far).


    I'm using SketchUp2022 on Windows 11 and new system with NVIKDIA GeForce RTX 4080 with plenty of RAM.


    Nothing had changed from yesterday. File isn't that large, worked fine, everything was good...until today.


    System crashes before report can be sent. So whatever solutions are found, please share immediately.


    Thanks!

    • Official Post

    Please submit us a feedback report manually (including logs) so that we can look into this further right away - Meanwhile you can temporarily try deactivating ray-tracing via the General Settings found via the Enscape menu in your CAD solution, SketchUp in this case, to see if that makes any difference.


    I appreciate it and thank you in advance.

  • Please submit us a feedback report manually (including logs) so that we can look into this further right away - Meanwhile you can temporarily try deactivating ray-tracing via the General Settings found via the Enscape menu in your CAD solution, SketchUp in this case, to see if that makes any difference.


    I appreciate it and thank you in advance.

    Hello experiencing the same today. Please help

    • Official Post

    Hello experiencing the same today. Please help

    As per my message, please also try disabling ray-tracing in case you have a card which supports that feature, alongside a dedicated feedback report with logs which you can send in as detailed here:
    https://learn.enscape3d.com/bl…sing-the-feedback-button/

  • Hi,

    I'm having the same issue even with the trial version, have submitted a feedback report days ago but haven't heard back since. Can you actually look into the error reports and reply to users' requests, please, I'm really needing some help to figure this out.


    Thank you.

    • Official Post

    silverthistel , welcome to our Forum.


    Could you please be so kind as to share the e-mail you've used in the feedback reports submission form? Via a direct message ideally due to confidentially, as I cannot locate any prior report trying the e-mail you're using to log into this forum.


    Afterward I can re-check to see if we've received said report to analyse the specific cause behind your crashing.


    Thank you very much in advance.