3.4 Bug?

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • Does 3.4 perhaps have a bug (SketchUp)? I downloaded and updated my driver and SketchUp crashes when I attempt to render a scene. Had to to back to 3.3 to finish projects.

  • I have a sample file that causes the crash from sketchup to enscape. Even if i save it as a component and load it into a new file it crashes - i do see it briefly as greyscale prior to crashing. It doesnt crash on other models - this was the first model i used the new create view with time of day/sun position from within enscape. I get Vulkan Error: vkc::Queue::submit: ErrorDeviceLost at queue submit.

    I had also updated my monitor setup in between to dual monitors. My system AMD with 64gb and 3080 geforce

    I cant upload the file as its too large

    I'm going to try rolling back

  • Hi notsuh , Paul Russam and sergeinester

    Please send us a feedback report including the log files, as seen here, so we get more information to see what may be causing this.

    You can add a link to this thread in the description for context.

  • some objects and materials needewd to be redone - for instance the enscape refrigerator model simply disappeared in the render

    For me it helps to go inside the component and then back.. sometimes deleting and undoing it afterwards.. With materials it is more problematic usually.. I guess ENS needs sometimes to be poked to be reminded of some work to be done.. usually it was happening between changes of ENS version but can not guarantee.

  • Hey Paul Russam ,

    Some may be too old to be sent automatically using the feedback button indeed, but you can still send them and add my name and a link to this thread, perhaps something will still be there.

    Alternatively, you can send me the log files manually, these can be found here:

    Enscape main plugin log files:


    SketchUp plugin log files:


    You can just place all the files that are contained in these folders into a .zip file and send these to us via support@enscape3d.com as well with my name included.

  • Hi guys getting better at understanding the dependencies I forgot about the proxy model method used by enscape in sketchup. This is why I connected the issue of missing models after I’d wound back the version of Enscape - I’d forgotten to download local copies of models. Luckily I’d used models from the library in my model. We had these issues when writing the Viewbuild visualisation system until we simply provided a full mesh and texture save option not just a relational save of models.

  • I unfortunately have to say that I just opened a file which I created before updating to 3.4.0 and as it was a bit slow on 3.3.1 it haven't crashed once. Now it crashes more often than not on 3.4.0 and in some cases I can not even open the ENS window..

    Does 3.4.0 uses more memory than 3.3.1. ? I as well went up from 2021 sKetchup to 2022 in the same time..

    It is not a total disaster but like I said.. the file was not causing any problem a month ago.?


    I have just sent this file to the colleague who has sK 2022 and ENS 3.3.1 and a weaker than mine PC and it is working fine.

    Feels like going back to 3.3.1..

  • Rick Marx I am not sure if any of my log files on error report was sent cos ENS on closing just blinked the error report and it jumped to sKetchup error report..

    So I send them here again..



    those are only after lunch time today.. Actually most often I can not even open ENS window..

  • I went back to 3.3.0+74199 (4/4/2022)

    I don't know about it using more memory - i've got 64gb of system ram

    The inconvenience was some Enscape proxy models didnt load up - and i i had to download the library locally and delete library items that still didn't show up.

    Did you use the new feature of Enscape that allows you to create views with time of day within enscape? or change anything about your windows system ?

    Everything worked with the enscape update until i used the new features in Enscape create views and altered my system setup by adding a 2nd monitor (of different resolution) - then the crashes occurred - i'm wondering if that feature is hard coding some canvas/screen data into that scene update that updates into SKetchup and causes a perpetual problem - or unrelated. New files and older files still worked in the updated version of Enscape.

  • Hey Tomasz Drgas

    Thank you for the additional information.

    Could you still send me the logs via the feedback button, as this contains some more information, you don't need to start Enscape, simply open your CAD and send them to us, this will include any previous logs as well, please add a link to this thread and my name in the description for context.

    Hi sergeinester

    Thank you as well, Enscape utilizes the GPU'S VRAM, so the system RAM should indeed not change.

    In case you haven't already, please also send in feedback so we can aggregate your data and see if there are any commonalities here, please also add a link to this thread and my name in the description for context.

    Seeing that you have added a second monitor, are you using a docking station perhaps?

    Many docking stations make use of DisplayLink, which can cause issues if the main display is connected through the docking station.

    As an example, when using a laptop, making the laptop display the main display again and not the external monitor (that is connected through the docking station) can prevent some issues.

  • sergeinester Ye maybe it has nothing to do with older files.. I only ment that file which was workin on 3.3.1 is working worse on 3.4.0 while it should better.

    I just started an ENS on the new skp file.. just the guy there.. It was about to die and I already have chosen to send report and close, but then it froze for about 15 mins and opened.. ?? while I was checking email..

    Rick Marx I have just send the feedback


    I just noticed that follow me components follow me.. and not only when I change view in sKetchup but also in ENS window..

    suddenly got curious if it is somehow connected


    I just noticed that if I start ENS on empty file and then open my project file I have higher chances of not killing ENS..

    And as we talking about 3.4.0 issues.. The Enscape Material Editor use to show currently selected materials settings when it is open.. now it is showing nothing until You select a material again after Editor is opened.. No big deal but I think it was less clicking before..

  • OKI.. I'm trying 3.4.1


    I just tried the same file with 3.4.1. I tried before updating with 3.4.0 and ENS died again. didn't even manage to send report.

    With 3.4.1 it opened.. seemed maybe bit slow but worked..

    To cool down : It was just one try and before I got message about new version of ENS I updated my graphic driver so not quite clear were from the improvement came..

  • Hey Paul Russam and Tomasz Drgas

    We noticed you both having very similar errors, and at first appearance, these looked like assets that were unable to load, but trying this over and over again.

    Could you try if deleting the following folder resolves this issue (as the data will be downloaded again):


  • Could you try if deleting the following folder resolves this issue (as the data will be downloaded again):


    Like I said for me after updating to 3.4.1, File loads and I haven't got issues so far today.. If something happens I will try.. And my colleague on other PC working on 3.3.1 as well no issues.. Afternoon I will try to test it more extensively and will do some heavy renders