Enscape keeps Crashing

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • Hello,

    Getting desperate and really need help

    I have a sketchup model that whenever I try to open up in Enscape to render. Will crash and take sketchup with it, I have tried contacting enscape and googling answers and have completed every solution given to me but with no success. I have checked my drivers, uninstalled and reinstalled, downloaded the previous version, edited recommended settings, etc.

    This issue only seems to be happening with the one model so is it something I can do and fix? I have tried copying it over to a new sketchup file but nothing.

    When I am loading Enscape I don't get past the loading screen, I have watched my task manager and when enscape gets to 99% loaded, the CPU & GPU will shoot up to 100% from 1% - 4%

    Attached is the error message that appears

    Thank you in advance for any help

  • I spent my afteroon trying to solve this issue with Kalli as we are the Enscape distribution partner.

    Enscape team - I managed to narrow it down to just a single texture contained within a model

    If it is present we both got this Vulkan Error on both of our machines

    2.09.05 17:51:22.931 +01:00 [RenderWindowHostThread] | INFO | Starting Enscape

    2022.09.05 17:51:26.279 +01:00 [RenderWindowHostThread] | INFO | Enscape started - elapsed: 3347ms

    2022.09.05 17:51:28.088 +01:00 [1] | WARN | API Error: BeginUpdateWorld: Invalid operation (No error)

    2022.09.05 17:51:28.537 +01:00 [1] | WARN | API Error: EndUpdateWorld: Invalid operation (No error)

    2022.09.05 17:51:28.901 +01:00 [16] | ERROR | Rendering error (CONTEXT_LOST): 'Vulkan Error: vk::Queue::submit: ErrorDeviceLost at queue submit.' occured while at: '-29.90974, 3.819451, 18.58546'

    2022.09.05 17:51:28.909 +01:00 [16] | INFO | Enscape exited with return code: 1

    The solution is to delete it from SketchUp, but it might be good to know what caused it or if there is a way to identify a similar issue

    I've attached a piece of offending geometry with the texture in the file - (a log is contained within) if you want to try and replicate the error.

    • Official Post

    Thanks a lot for the report KalliK , Adam.Fairclough, and your posts generally.

    I am able to reproduce this crash and will forward everything to our developers for further troubleshooting. I appreciate the dedicated file for us to test this.

    You'll hear back from me once I have any further news to share which should be soon.

    • Official Post

    KalliK , Adam.Fairclough , after further review, I advise trying out our latest preview as well for the time being as I cannot reproduce this problem at all using 3.5-preview2. If you still experience this problem or any others afterward, kindly let me know.

  • Demian Gutberlet

    Hi Demian,

    I too found a texture that crashed Enscape. Luckily, I was able to find it by eliminating what I had added to my model.

    It's a texture that comes from a model found in SketchUp's warehouse.

    Strangely enough, I extracted the .jpeg file from the texture and used it in a new model and it works.

    In short, I tried to trace the original model in the warehouse but its success.

    I send you the sketchup file with the texture. You may be able to glean some insight into the problem.


  • ^yeah, I suspect it isn't the texture itself, rather a problem with the extra data that SketchUp has with that in an xml file.

    Programs can write information about PBR materials for example into this - Enscape stores whether a material is rough or smooth for example and it means that info is saved inside the material rather than by enscape itself.

    Because this sketchup file can also hold lots of software specific data and some programs will try to read each other's information, I wonder if this might cause some confusion if there is a conflict

    I have a library of materials that I use where I've preset various enscape parameters to them, so no matter where I open them, they look right.

  • Adam.Fairclough

    Thanks for the information. It helps me to understand a bit. I must admit that this is knowledge that I have little mastery of.

    But why by extracting the texture (jpeg) and re-creating it works? The "extra data that SketchUp has with that in an xml file" changes?

    That said, I believe this is a problem that has happened to me a few times. Identifying where the error comes from is not obvious. I don't know yet how to understand error information like "Vulkan Error: vk::Queue: ErrorDeviceLost at queue submit" What it actually tells me. From what I understand is that there is a buggy information transfer? This is not a particular problem with SketchUp or Enscape as such. But this error can occur with other software (?)

    From now on, I will test more often the textures that come from the warehouse. It's pretty much the only way I can think of to avoid endless searching.

    A big thanks! :thumbsup:


    • Official Post

    anju1810 , I reckon your system meets our requirements?

    If so then please simply submit a feedback report with log files to our technical support team, which only requires a few clicks and almost no effort from your side: https://learn.enscape3d.com/bl…sing-the-feedback-button/

    I appreciate it and thanks in advance!

    • Official Post

    Still not resolved.

    Please kindly have a little bit more patience and I'm sure someone from our support team will get back to you. It may sometimes take a bit longer than a day until you receive a response back, especially if my team has to troubleshoot your logs in detail.

    • Official Post

    Bonjour, J'ai le même souci.

    Que puis-je faire?


    Please simply click the first button you see in the prompt - This will transfer a feedback report with log files which will then be analyzed by our support team to further resolve this crashing. Thanks a lot in advance.

    Veuillez simplement cliquer sur le premier bouton que vous voyez dans l'invite - Cela transférera un rapport de commentaires avec des fichiers journaux qui seront ensuite analysés par notre équipe d'assistance pour résoudre davantage ce plantage. Merci beaucoup d'avance.

  • I'm on preview 3.5 but still experiencing the same error running on GPU Radeon RX 550. All my drawings never complete rendering :( I am running Enscape's recommended drivers. Prior, I tried AMD's own drivers, same results.

    Looking forward to a resolution soon.

    • Official Post

    I'm on preview 3.5 but still experiencing the same error running on GPU Radeon RX 550. All my drawings never complete rendering :( I am running Enscape's recommended drivers. Prior, I tried AMD's own drivers, same results.

    Looking forward to a resolution soon.

    Please also definitely make sure to submit us a feedback report with logs - Our technical support team will get back in touch with you after checking the submitted log files and machine info alongside.

  • Thanks for the quick response, Demian Gutberlet.

    When the Enscape error reporting window pops up (the one that asks customer to fill out info), the computer only gives me about five seconds to fill in the necessary information before it halts/freezes. I have yet to figure out how to resolve this. If there's a way to manually extract the error logs for your analysis, I'm happy to try that avenue.