cannot deserialze the current JSON object Enscape Custom Asset

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • Whenever I try to add a object to my Custom Asset folder I get this error message, anyone had this issue before? I have the same issue at two different workstations. It doesn't matter what type of asset I try to add. :/ I have even tried two different Revit versions (2022 and 2023). I've tried Enscape 3.4.0 and 3.4.1.


    "cannot deserialze the current JSON object (e.g. {"name:"value"}) into type 'System.Collections.Generic.List`1[Enscape.CustomASsetEditor.Categories.Category]' because the type requires a JSON array."

    • Official Post

    HomeboY , thanks a lot for your report - I think in this case it would be best to receive a feedback report with your logs submitted from your machine as detailed here: https://enscape3d.com/communit…sing-the-feedback-button/


    Also, I reckon you've also tried to fully re-install Enscape 3.4.1 and still run into this problem?


    Thank you in advance, and gladly let me know once the report has been submitted so that I can have a look myself right away.

  • I have not reinstalled it completely, however the issue still remains on two different workstations but I could obviously try that.


    I have sent a ticket through the feedback button as well.


    Another question I have is about the materials to the Custom Asset Import, is there any way to add existing materials to imported assets? This would save a lot of time instead of creating new materials to all imports.

  • Did this ever get resolved? I'm using version 3.4 and getting the same error. I have a ticket open with Enscape and waiting for them to reply.

    No unfortunately not, I haven't tried it since. I have to copy and paste the assets from the local disk to Dropbox folder every time I leave work. :(