Video Editor - Changing FOV after Camera Position resets Camera Position

  • In the video editor, I am not able to adjust both camera position and fov without updating the keyframe between. If I change the camera position, and then change FOV, the camera position resets to the last saved position. If this is as designed, my feedback is that this is very unintuitive and frustrating.


    Note: If there was an Undo in the video editor this would be as bad, but as it is now one must recreate the precise viewpoint they were in the process of refining... fun stuff!

  • Thank you very much for the suggestion, but I am not looking for a workaround.


    Is the description above what you experience as well?


    To recreate:


    In Enscape viewport while using Video Editor

    1) move the camera... do not hit Update.

    2) Change the FOV


    For me the view changes back to the previous position saved in the keyframe.


    Does this happen for you as well?


    (fwiw... saving XML is not a reasonable workaround to this issue imo... I could more easily just remember to hit Update *every time I move the camera* instead of saving the xml *every time I move the camera*.)


    Thanks!

  • Yes, I can confirm this happens when I try it as well. The view pops back to the last keyframe position.


    I didn't necessarily mean using the xml as a suggestion to you, I was highlighting that the video editor is deficient and I have to rely on xml backups and editing for basic editor functionality. Functionality that we should already have, a year in and several versions later.