Rendering issue on large model (sketchup)

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • I am making a model (it is 12mb) in sketchup and when I want to start enscape to render, it loads a few moments and then sketchup and enscape crash, it happens with this project nothing else, then I try another smaller one and it renders without problems and in quality ultra

    • Official Post

    I am making a model (it is 12mb) in sketchup and when I want to start enscape to render, it loads a few moments and then sketchup and enscape crash, it happens with this project nothing else, then I try another smaller one and it renders without problems and in quality ultra

    Please kindly make sure that your system meets our requirements:…base/system-requirements/

    If they are met, please also kindly submit us a feedback report with your log files so that we can further look into this to analyze the cause of your crashing.

    Thanks a lot in advance.

  • Hello everyone,

    I am having a weird issue lately which I couldn't figure out how to fix it.

    Every time I am working on a heavy model (around 200 MB which is a regular model size in pro usage) and feeling heavy on SketchUp, when I try to get an ultra-quality render I get this error and escape crashes.

    I used to get this error and I think there was sth wrong with the version of the GPU and Windows updates which I think I resolved, but after a while, the error has come back, and exactly when it gets close to a deadline it keeps crashing. I had a very important presentation last night and unfortunately, I had to export all files in High-quality instead of ultra-quality. The weird situation is that I tried again today and everything was good I could export some good ultra qualities but after a couple of shots the error popped up again. I always try to export a test in HD size before going to a higher size but this error keeps popping even on HD image size.

    I use a good PC and I am sure my setup can handle these types of files and processes.

    Win11 / CPU 12400 i5/ RAM 32GB /

    GPU RTX 3060 ti tuf 8GB

    triple fan for CPU and GPU

    Sketchup 2022 (just updated to 2023 today and got the same error)

    Enscape 3.5

    note: The error always happens on ultra mode / the size of the image does not matter(at least on HD and above) / sometimes I do not get the right colors and reflections even when the render is going okay.

    any comments?


  • Enscape has crashed for me a couple of times, because of a single component that I downloaded from the warehouse...

    at the time I thought it was because the entire model was too heavy (and it was, because my models tend to be 300-500mb with a lot of lights and vegetation proxies too)

    but as soon as I deleted the last 10 or 20 components that I had imported AND PURGED THE MODEL, voilá........ Enscape was running great again

    so I tested the model with/without those components, and both of those times it turned out to be just a single component downloaded from the warehouse that, for some reason, caused Enscape to crash

  • Quote

    do I not lose all the benefits of ray tracing?

    See my later post

    Yes but rendering will then work on an 8Gb card.

    RT takes a heck of a lot of video memory, my next card (eventually) will have absolutely no less than 16Gb and ideally 20 or more, until then I run with RT off.

    I don't think the results are in any way bad:

    Try it, turn off RT do some tests on the model that crashes, if it doesn't crash then you'll know it's RT, if it does crash then you'll know it's something else and can turn RT back on.

  • And I never turn off RT

    I haven't looked at the RT settings in a while so whilst they 'didn't' work for me that's not to say they won't now. There's been a fair number of changes to Enscape since I turned RT off.

    I'm just setting up a test using your settings, I'm going to re-render my most recent set of panos, if it works then great!


    28 Panos queued up, 2 done, I'll compare them to the already rendered set when done. The shear fact the Ens hasn't crashed out already is a good sign

  • Right then...

    1st off I've edited my previous posts on this thread striking through my comments and referring to this one.

    I've now rendered 28 8k x 4k panos with RT on and with no crashes!, whats more its much faster!

    There IS a visual quality improvement but it take comparing the 2 RT and non-RT images to see it.

    It was never like this when I'd previously tried RT so, 1, hats off to the Enscape team for making such improvements and 2, the dunce hat for me for assuming it was STILL a memory hog and not trying it out sooner,

    I still stand by my recommendation to 'temporarily' turn off RT as a testing method for failing renders but as a permanent fix it's now unnecessary.

    Thanks xonpt for your comment that prompted me to test.

    • Official Post

    hypercube please send feedback with log files included and we'll be able to tell you more about what's going wrong.
    If things improved with turning off ray-traced sun shadows it's indeed hinting on that it might be memory related, especially if you have lot's of high poly geometry in your project. Another cause of high memory consumption with rt shadows is animated vegetation (as it requires unique geometry for each animated asset) - setting wind strength to 0 might also help in this case.

    Paul Russam glad to hear you're seeing improvements. There have indeed been a lot of quality improvements exclusive to hardware ray tracing in the last releases :) It does require more memory than the software ray tracing implementation, as it simply considers more geometry for GI and reflections.

  • ah,

    now I tried the same method on a large file again and got the error. RT sunshadow off. ultra quality ultra HD size

    still everything is good on high quality but the point is exactly what I need to show is being shown only on ultra (some white light reflected from polycarbonate wall).

    PS: turning off the whole RT worked on ultra-quality

    PS2: restarted Enscape on tried RT on again and started from a very low size like HD and moved to the top(ultra HD) and worked fine again. It is like we are talking about some other serious issue, not the RT only.

    PS3:and just find out I really need RT to be on, Does not give me the correct outcome without it.

  • I use GigaPixel Ai, if I have it open and try to run Enscape, Enscape will crash and visa versa if I have Enscape open, GPAi will crash.

    They both make use of the GPU and can’t run at the same time on my 2070

    Do you have any other ‘heavy’ app open when you’re using Enscape? I don’t mean the likes of a browser etc.