Batch rendering issues - (SLOW, crashes, wrong view)

Reminder: If you encounter any issues with Enscape (including installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed here. Thank you for your understanding.
  • Batch rendering has been problematic for me for multiple releases:


    1) Incredibly slow processing time vs rendering individual scenes. I'd estimate at least 50%-75% slower than if done individually. But this is all for nothing if (see #2)...


    2) Higher chance of crash to desktop - without a bugsplat - on "Ultra" after a few scenes.

    - Notes:

    - Tends to crash on "Ultra" but have no problems rendering individual scenes on "Ultra".

    - Batch on "High" seems stable.


    3) Occasionally does not update to the appropriate scene, leading to an incorrect view. Perhaps isn't giving itself enough time to update the camera view?

    - My models are large-ish (~200MB).


    I sometimes have 20 +/- scenes to render and batch could be a big timesaver...if it worked consistently and efficiently.


    4) Enscape has no option to simply name the file per SketchUp's scene name. Adds another step to take after rendering to go through each render and rename.

    - Enscape adds: "Enscape_2023-01-04-09-53-26_(SketchUp scene name)"

    - This is problematic for simply/quickly replacing/overwriting scenes if a quick update is needed.



    System info:

    GPU = RTX3080 (12GB)

    - "High" uses approx. 70% GPU memory while rendering

    - "Ultra" uses approx. 80% GPU memory while rendering


    System Memory = ~50% usage


    *Should not be a VRAM or system RAM issue.


    Enscape version: 3.5.0 preview 9

  • Do you have raytracing on?

    Try turning it off along with DLSS etc and see if the batch process will then work.

    I’ve an 8Gb 2070 and regularly batch render 30ish 4k x3k with no problems at what I regard as amazing speed …… unless …… I try raytracing, at which point it’s crash city.


    Personally I think we’ve all drank a bit too much of Nvidia’s RTX coolaid. It’s barely used by gamers (it’s intended audience) and is regularly the source of problems here and I assume with others render engines.

  • Do you have raytracing on?

    Try turning it off along with DLSS etc and see if the batch process will then work.

    I’ve an 8Gb 2070 and regularly batch render 30ish 4k x3k with no problems at what I regard as amazing speed …… unless …… I try raytracing, at which point it’s crash city.


    Personally I think we’ve all drank a bit too much of Nvidia’s RTX coolaid. It’s barely used by gamers (it’s intended audience) and is regularly the source of problems here and I assume with others render engines.

    Ray-tracing is on, but off for sun-shadows since it used to cause crashes for me a few builds ago when I first gave it a go with my newer RTX card upgrade. I also rely mainly on artificial light sources, so soft exterior sun shadows not a big deal for my use and those seemed the most problematic a while back. The upgraded reflections are a big benefit, so I would like to keep "basic" RT on if at all possible.


    DLSS and DeNoiser are on. Haven't tried toggling those yet. Honestly, because I don't want to spend the day troubleshooting when I need the batch to just work from time to time when I need it for these larger jobs. DeNoiser is something I want to keep on, since it does help results in my experience.


    To me, it seems to be the processing time with SketchUp transitioning from scene to scene in my larger models. Some scenes have more complex geometry and SketchUp lags, which I bet causes Enscape to run into a timeout issue or something like that. Still, that doesn't explain the simply longer render times using the batch render option. Yes, it's still "fast" considering it's rendering 20+ scenes vs something like VRay. It's just "slow" compared to what I'm used to doing single renders in Enscape already.