ENS not always fallows sKetchup's North direction

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • Here are two scenes from sKetchup. Both the same north direction (0deg) and shadow settings.. (12:00 ...)

    I don't understand why these two scenes behave differently but fixing is quite simple. I changed north angle to something else, then ENS starts to follow correctly and I change back and update scene.. I didn't try to reopen this project but as my memory goes it sometimes keep coming back.. Maybe it is something to do with geolocation since this is the other way to fix it.. If I go to Model Info > Geo-location > Set Manual.. I can change a little (like last digit)and after applying it is fixed will all scenes..

    Thats all I could notice..

    Edit..

    I was cleaning a bit the file to send You and I noticed that turning on shadows in scene and updating have fixed the problem too.. I very often save scenes with correct shadows set but not turned on.. it switches faster between scenes and is in general lighter on the PC.. As files go big it is a noticeable difference. But both of scenes had shadows turned off and one was fallowing and the other not.

    thats the file..

    shadow direc.zip