Bug in latest version of Enscape causes older SKP files to show error upon loading Sketchup

Reminder: If you encounter any issues with Enscape (including installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Feedback button as detailed here. Thank you for your understanding.
  • This happens when loading Sketchup 2022 with the model file (not when starting Enscape) when Enscape-3.4.3+93121.msi is installed.

    When I uninstall the latest Enscape - no error.

    When I reinstall another version Enscape-3.3.1+75071.msi no error.

    When I install the latest version (Enscape-3.4.3+93121) over 3.3.1 same error.


    We had to mass uninstall latest version (AGAIN) - ...............3.3.1+75071 seems to be the most overall stable version.


    error;


    Error Loading File C:/Users/zzz/AppData/Roaming/SketchUp/SketchUp 2022/SketchUp/Plugins/enscape/loader.rb

    Error: #<NoMethodError: undefined method `each' for nil:NilClass>

    C:/Program Files/SketchUp/SketchUp 2022/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:92:in `require'

    C:/Program Files/SketchUp/SketchUp 2022/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:92:in `require'

    C:/Users/zzzz/AppData/Roaming/SketchUp/SketchUp 2022/SketchUp/Plugins/enscape/loader.rb:14:in `<top (required)>'

    C:/Program Files/SketchUp/SketchUp 2022/Tools/extensions.rb:197:in `require'

    C:/Program Files/SketchUp/SketchUp 2022/Tools/extensions.rb:197:in `load'

    C:/Users/zzzz/AppData/Roaming/SketchUp/SketchUp 2022/SketchUp/Plugins/enscape.rb:9:in `register_extension'

    C:/Users/zzz/AppData/Roaming/SketchUp/SketchUp 2022/SketchUp/Plugins/enscape.rb:9:in `<top (required)>'


    • Official Post

    I'm sorry to hear about that of course.


    If you'd kindly also submit a feedback report from any of the machines where you experience this issue (after re-installing a working version) with logs we can investigate further.

    • Official Post

    This worked for me too!!! Thanks Tom. Everyone in our office is on Enscape 3.4.4 and had a user with this issue in Sketchup 2022. Reverting to 3.3.1 fixed the problem and they no longer are getting errors in Sketchup file.

    If you haven't, without having to re-install 3.4.4, please also simply send in a feedback report with logs (just takes a few clicks) so that we can investigate why you experience this exactly with just 3.4.4. Especially since it's ideal to find out why this problem occurs before Enscape 3.5 comes out and before you may not be able to use it properly. As mentioned, re-installing our latest release is not required as we'll still receive crashdumps/logs from previous versions.


    Thanks a lot in advance for your time.

  • It may be some other settings to mess with ENS on Your PC. I am on 3.4.4. And still on sK 22 since 23 wasn't working well for me.. I open some older files and it is all right.. never had this issue..

  • It may be some other settings to mess with ENS on Your PC. I am on 3.4.4. And still on sK 22 since 23 wasn't working well for me.. I open some older files and it is all right.. never had this issue..

    This error is very specific to certain older SKP files -- I have no idea what elements in the SKP files cause this.
    We work with over 35 Enscape users and only encountered this 3 times since I started this thread. Each time only fix we found was to downgrade to 3.3.1

  • FYI this is still happening on certain SKP models and the latest Enscape version.

    Only fix is to install version 3.3.1 or older of Enscape.


    Anyone at Enscape know the solution to this?

    This happens upon loading of the model (and not just Enscape) - and SKP freezes until Enscape is fully removed or 3.3.1 installed.


    Even with Sketchup 2023 latest version;



    This happens even when the Enscape plugin is installed for 'all users' in the programdata folder.


    Enscape needs to address this!

    • Official Post

    Tom G. , thanks once more for your further posts and please pardon the delay.


    It has been a while but as per my second post in this thread it would still be great to receive a dedicated feedback report with logs from one of these machines where this occurs:

    https://learn.enscape3d.com/bl…back-button-win-sketchup/


    You do not need to have Enscape running to send in a report, and just for your information whenever you experience any technical problems this is the ideal method of reaching out as basically all your logs and machine information get submitted to our technical support team directly for further troubleshooting.


    Further, if you do get the chance please also try a full re-install once more, again for "all users" on that machine but following this order:


    - Navigate to Add/Remove programs in Windows.

    - Uninstall Enscape by using the 'Uninstall' button

    - Following the completion of the uninstall, please delete the following directories:

    C:\Users\%USERNAME%\AppData\Roaming\Enscape

    C:\Users\%USERNAME%\AppData\Local\Enscape

    C:\Program Files\Enscape


    Afterward, reboot your machine, and re-install our latest release as found here once more, again for "all users".


    We had another user report a similar problem which hasn't gotten back after we recommended a full re-install. Due to that if that doesn't make a difference please definitely send in that report with a bit of context in the submission form and kindly let me know once you've done so ideally.


    Thank you once more in advance!

  • UPDATE.

    I confirmed this is happening on another computer - new installation of Windows 11, Sketchup 2022 (latest release) , Enscape latest release anything older than 3.3.1 .


    This happens on older SKP files .. I might be able to share this SKP model with Enscape only - directly not attaching here.

  • Was SketchUp installed correctly?


    It’s absolutely necessary to right click on the installer and select “install as administrator”.

    Being a user with administrator privileges is NOT the same.

    Without the above some plugins will not work.


    As you have 2022 already installed you can select ‘repair’ during the installation process and it will perform the necessary changes to your existing install.


  • This issue happens on brand new installs for multiple users and only on certain SKP models only - with certain elements imported a certain way.

    This is not an issue with Enscape 3.3.1 or before.


    We have a ticket open and I have sent them an example of an SKP file showing this issue.

  • We opened a ticket with Enscape and sent them all the details.

    We also sent them one of the Sketchup files in question and they were able to replicate the problem.

    Ticket id160383 .


    I explained to them the issues.

    They blamed Sketchup . Sketchup said that since the error goes away after uninstalling Enscape, it's not Trimble/Sketchup's problem.

    When I asked Enscape for updates - they have ghosted me.


    this is obviously an Enscape issue --- Enscape 3.3.1 or lower is not affected by this problem.


    Many of our Enscape users work with these older SKP files in question and Enscape is throwing these errors and crashes Enscape and Sketchup.


    So far no reply from Enscape for 1 week even after asking for updates.

  • That's an error with the plugin being loaded - that shouldn't be specific to a specific type of file AFAIK.


    The plugins are loaded before the file is loaded in


    What happens if you open SketchUp 2022 without a file? Enscape loads right?

    You should be able to open one of these files now


    have you got the latest Visual Studio Redist installed?

    https://aka.ms/vs/17/release/vc_redist.x64.exe

  • I can prove this happens on a specific type of .SKP file.

    DM me and I can send you an SKP file as an example.

  • Yes and that's the main/only issue.

    These Skechup files have no problems loading WITHOUT Enscape installed -- the problem is once you install the latest Enscape version.

    Yes, I’ve got enscape (latest) installed in 2022.0.354 it works fine.


    Not sure what is causing the problem for me in 2023.1 , I get those same errors

    • Official Post

    Tom G. , we were able to find the cause behind this specific behavior which should also be resolved with our one of our next upcoming service packs or full release.


    At this point thanks a lot for a bit more patience and I appreciate the feedback you've shared to this point.