Custom Asset Library Issues

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • This is a fairly recent problem since we last updated enscape in December. To start I noticed that our whole custom asset library was blank after updating even though it was pather to the same location as before. So I tried re-pathing and same issue, I checked the folder to maker sure the files still exist, and they were still in the folder. I then went to another team members computer to check and they were experiencing the same issue.

    After some hasty back-dates to previous folder versions I was on the verge of giving up because nothing has been added to this folder in almost a year and it all worked fine before the latest update. I even tried uninstalling an re-installing enscape and no avail they would show up. I then decided to repath the folder one folder structure back, as in if the previous folder was located in Desktop -> Enscape -> Enscape Assets -> Custom Assets I am instead pathing it to Desktop -> Enscape -> Enscape Assets. And boom this solved the issue of not being able to see or load my custom assets.

    Now onto the side affects of this change, I now have unbearable load times when I click my custom asset folder, these were not there last time the library was working. Now in your defense I have about 164 custom models and they mostly consist of 3D Render People and High Poly Trees. Though this load time was not present before, not sure if this is user error, a bug, or a product of my own creation.

  • Hi agawrys12

    I have, I think a similar issue, not sure if it is related, but sounds like it might be, hopefully helps sheds some light?

    I have a really strange problem, that I have been wrestling with for days. First details of my setup:

    • Revit 2023
    • Enscape 3.4.4+94564 (Latest)
    • Nvidia GTX 1660 16GB Driver Version 531.18 (Latest)

    I have been trying to create some custom assets, following the instructions in the helpful Enscape webinar

    Using the example Daft Punk Helmet shown in the video from TurboSquid everything seems to work fine. However if I use pretty much any other FBX or OBJ file I download from Turbosquid or CGtrader or any number of other sites, the custom asset creator process crashes out when importing the geometry. Now this happens with incredibly simple files as well as with complex files. The Daft Punk Helmets are pretty complex compared to things I have tried with (simple chairs, bed side tables etc).

    Looking at the logs I see these lines when it fails:

    3-01 13:05:14.437 86f4 [ERROR] OpenGL/Vulkan context lost: Vulkan Error: vk::Queue::submit: ErrorDeviceLost at queue submit.

    3-01 13:05:14.437 86f4 [INFO] Error kind: RESTART

    3-01 13:05:14.439 86f4 [ERROR] Caught close-exception in Async main loop: Close on RendererError!

    3-01 13:05:15.520 86f4 [INFO] Device is lost, not submitting any more commands.

    3-01 13:05:15.526 86f4 [INFO] Device is lost, not submitting any more commands.

    3-01 13:05:15.611 86f4 [INFO] Update statistics MaterialDataManager : Added 1 Removed 4

    3-01 13:05:15.612 86f4 [INFO] Largest instance counts:

    3-01 13:05:15.613 86f4 [INFO] [GPUMEM] ModelRenderManager (GEOMETRY) current usage: 39.79 MiB

    3-01 13:05:15.613 86f4 [INFO] Auralization ApplySwitchBuffer() complete!

    3-01 13:05:15.613 5e44 [INFO] Physic thread ended normally. (0x5e44)

    3-01 13:05:15.662 86f4 [INFO] Device is lost, not submitting any more commands.

    3-01 13:05:15.698 86f4 [INFO] GPUQueries (VulkanExecutorQuery:TransformFeedbackStreamEXT), maxPools: 5; maxQueriesPerPool: 0 (of 32); maxQueriesPerFrame: 0.

    3-01 13:05:15.698 86f4 [INFO] GPUQueries (VulkanExecutorQuery:Occlusion), maxPools: 5; maxQueriesPerPool: 0 (of 32); maxQueriesPerFrame: 0.

    3-01 13:05:15.698 86f4 [INFO] GPUQueries (VulkanExecutorQuery:Occlusion), maxPools: 5; maxQueriesPerPool: 0 (of 32); maxQueriesPerFrame: 0.

    3-01 13:05:15.699 86f4 [INFO] GPUQueries (VulkanExecutorTiming:Timestamp), maxPools: 5; maxQueriesPerPool: 7 (of 512); maxQueriesPerFrame: 7.

    3-01 13:05:15.709 86f4 [WARN] Swapchain::destroyResource() Timeout waiting for fence.

    I saw some other posts about updating Vulkan (which I have done to the latest version).

    I have tried older versions of graphics drivers and Vulkan as well and older versions of Enscape too

    I have tried to play around with the files in Blender before exporting them to see what is different with the daft punk helmet and other files, I can't see anything obvious. If I knew what caused the crash, I could just edit the files in blender first I guess (although this would be a pain), but at least I would know I guess.

    I have attached the daft punk pbx as well as an example chair which doesn't work. Hopefully you can recreate the issue, I have also uploaded logs when it works with the daft punk and fails with the chair.

    I have also turned off hardware ray tracing as I saw that was often suggested as a solution

    One last thing, that is the weirdest of all, if I import the daft punk helmet and then import another object that doesn't work by itself, it then works! It is like the daft punk primes it to accept the ones it crashes on before.

    Hope you guys can provide some advice.

    One last interesting bit of information, I tried the latest preview release of Enscape today and all objects crashed out (even the daft punk helmets).