Revit 2019 elements don't show in Enscape

  • We recently upgrade to Revit 2019 and after updating our Enscape to the latest version, and also making sure we had the latest driver for my graphic card, I tried viewing the project I am working on in Enscape. But several objects do not show in the Enscape view but are visible in the Revit view.

    This happens on another colleagues machine as well. See attached images that illustrate the problem.


    Had no issues in Revit 2018. Any thoughts?


  • Hey hoblo70 , thanks a lot for your submission and welcome to our forum. :)


    In order to get behind this issue, could you please send us Feedback using the [Feedback] button in the Enscape context menu? Please make sure that 'Include Logfiles into feedback' is checked in the Enscape Feedback window and add your forum name or some other reference, so we may connect the provided data to this thread.


    Feedback button in Revit:


    Also, alongside the feedback report, is there any chance you could send me the corresponding project file as well? That would be very helpful for our developers so they can provide a solution for this as quickly as possible. Thanks a lot in advance!

  • Demian Gutberlet

    I have been going through our model and from a process of elimination I think I found the problem. I believe it is one of our link Revit models that is the issue.


    I started by eliminating any design options and accepting the primary ones. No Change.

    Then I thought why not delete the view and recreate it. No change.

    Then I tried selecting one of the missing elements in the Enscape view, in Revit, and Isolate it by category. When I did this the missing elements appear in Enscape.


    So this made me believe that Enscape is reading the elements correctly but something else is causing a issue with showing them in the entire model view.


    That is when I decided to remove any linked files and all of a sudden all the missing elements appeared.


    Now I just have to go through all my linked Revit files and find the problem.


    Thanks for your teams help in the mean time. I can send you my linked Revit files if I hadn't done so before. Let me know if you need them.

  • Hey hoblo70 , I was able to download the file just fine and our developers were busy figuring out the cause behind this behavior. Thank you for your patience.


    The result is, we're getting exactly the geometry that you're seeing in Enscape from Revit (even though Revit's viewport shows more elements*) and it appears to be a conversion issue in Revit itself:


    Original Revit 2018 project:


    Revit 2019 project provided by you:



    2018 project loaded in Revit 2019:



    Our developers also got a couple of warnings and errors during the conversion AND in addition to all that, *Revit's own renderer fails to render the view completely which is a clear indication that parts of the geometry are broken.


    Thanks again for the report and I hope our findings are helpful. If you have any further questions regarding this subject, let me know. :)

  • Demian Gutberlet Thank you for the update. It is helpful to have your teams findings. Unfortunately I am not sure how to fix the problem as we have done some work in the model and probably cannot start over without losing work and time.


    I did try converting another project we have that is more complex than this one and it had no issues. So it is very strange that this occurred in only this model.


    If it is possible could you send us more specific information on what geometries they think are broken so I can try and fix it or rebuild the elements. We would love to continue using Enscape with this project and not have to go and use another rendering program.

  • hoblo70 , mostly the floors are affected by this problem, and when importing the project into Revit 2019, you should also receive some warnings in the conversion process, maybe they might be of help as well.


    Since the project is also only partially rendered in the dedicated Revit renderer itself, using another rendering program would probably also not help. We're generally very sorry about this behavior, but you could also contact Autodesk themselves to see if they might have some approach to that issue?