Grass thourgh toposurface

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
    • Official Post

    How can i solve this problem please ??

    I used an toposurface (Revit 2024) and i subdivised it to make 2 differents materials. But grass stay below the subdivised surface...

    I don't want grass through out my gravels...

    Welcome to our Forum.


    If you setup a different material for the sub-devised surface without any grass at all, please also ensure that the existing surface below is either removed or also does not still have a grass material applied.


    At least currently our grass cannot "know" whether or not there is another floor/object/plane blocking the grass, so in that regard it'll show through as seen in your example screenshot.


    Let me know in case I'm missing something or any further questions arise.

  • I am getting the same experience here. Any creative solutions? I haven't tried yet, but all I can think of is to change my default Revit 2024 toposolid material to gravel (not grass), and then make the grass regions as subdivisions (with minimal 1/128" offset) of the toposolid. Definitely counterintuitive, but hopefully it will work. I can't seem to come up with any other way of going about it, other than a non-Enscape grass texture-map that doesn't have any three-dimensionality in Enscape.

  • are there any further advancements for this issue? In revit 2024.1 and Enscape 3.5.3. i have a lot that is in rolling area so there is quite a bit of difference in the elevation from the front of the lot to the rear. i have my toposoild with just a grass material and all contours set correctly. then i have a subdivide for the driveway with a thickness of 1" and assigned conc material. when loaded in to Enscape the grass is showing through the driveway. how is the correct way to handle this?

  • are there any further advancements for this issue? In revit 2024.1 and Enscape 3.5.3. i have a lot that is in rolling area so there is quite a bit of difference in the elevation from the front of the lot to the rear. i have my toposoild with just a grass material and all contours set correctly. then i have a subdivide for the driveway with a thickness of 1" and assigned conc material. when loaded in to Enscape the grass is showing through the driveway. how is the correct way to handle this?

    While not a perfect solution, here's what my team member came up with: In the Enscape material settings, lower the grass height to it's minimum, reduce grass height variation so that there's no tall blades randomly sticking out, and for our project, we had to increase the thickness of the driveway to 2" (in terms of the Revit toposolid subdivision height/ offset above the baseline toposolid). Hope this helps!

  • Toposolid does not work like the "old" toposurface.

    A subdivision makes a copy of the main toposurface with a (slight) specified offset but the main toposolid still exist below.


    The only issue we found to this is : don't use a "grass" material for the main toposolid but only for the toposolid subdivision's you want with grass.


    Additional tips to know :

    If you use a transparent material (such as water for example) on a toposolid subdivision you will see the main toposolid material below.

  • for our workflow we typically want to show the entire site as grass, then we use a Subdivive (previous Subregion) to add in our mulch beds and driveways and maybe walk pavers if needed. it would not work for us to not have that main material as grass. if you have another solution then i would like to hear that. Ive tried the suggestion from "rdh3t" and that although not perfect does provide the best results that i have seen at this point.