Heavy Scene Forces Lower Quality Render?

Reminder: If you encounter any issues with Enscape or your subscription please reach out to our dedicated support team through the Help Center or by using the Feedback button as detailed here.
  • Okay so this is frustrating: the two images attached have the same visual settings (ultra) with the only difference being the furniture (which are external linked models) being toggled on and off.


    When playing with the visual settings slider, there is no lag between high and ultra like there normally is with the furniture tag off so I can only assume Enscape is forcing Medium to High settings in the viewport.. which would be fine if the visual quality was to then switch back to Ultra for the final render.. only it doesn't?


    Is this a technical glitch or intended to save on performance? And if intended, can we please please please have an option that can be toggled called "Beast Mode" with a GPU warning??


    Actually in general can we please just have this feature anyway hahaha

    • Official Post

    jamesjordn we're not automatically changing quality settings, except for VR (where quality is always shifted by one level due to performance).

    What makes you think the quality in the 2nd image is decreased except for the smoother quality settings transition?

    If it's the slightly blue tint of the lighting in the hallway, this is probably because the added furniture in the room increased the polygon count in your scene so that some walls of the hallway outside the view cannot be considered anymore for global illumination, as we currently have a fixed polygon limit for that. This doesn't mean that the quality level itself is reduced.


    The usual lag you experience when switching quality levels comes from shader compilation, as there are a lot of quality level specific settings in shader code.

    Now when you switch back and forth between quality levels the shaders for this level will already be compiled, because we cache them during runtime.

  • My apologies, that makes sense! And yes, the blue tint is what gave me that impression, but yes that makes sense..


    Do you have any recommendations on how to fix this issue without reducing the polygon count of the furniture?


    Thank you :)


    EDIT: Or is there a way that Enscape could push that GI consideration for Renders only and not in the window?

    • Official Post

    This blue tint is caused by indirect lighting by the sky, as probably some of the building's geometry is omitted that would otherwise block the visibility of the sky. Unfortunately without reducing the polygon count you only have limited options. But you can try to place a single, big plane (thus it only adds 2 triangles to the polygon count) right left outside the camera's view into the hallway. If you've surpassed the polygon limit our algorithm tries to select geometry that has a big surface area relative to it's polygon count first, so it's likely that it will consider this plane for the indirect light calculation and it'll block the sky's light.