[URGENT] Version 3.5 doesn't export PNGs with transparent backgrounds

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • I found a bug in v3.5 and I've tried everything to solve it, sadly with no success. Please someone from dev team have a look at this as this is urgent. I'm a Senior 3D Artist in the furniture industry and we use Enscape in the company. I used to be able to render furniture pieces on a transparent background before 3.5 but after the update the PNGs always come out with a white background whatever I do.


    I've tried everything:

    - Turning on/off White Background under Sky

    - Disabling/enabling my custom skybox

    - Disabling/enabling exporting additional map IDs

    - Disabling/enabling Apply Alpha Channel

    - Tried on a brand new file, same result

    - Tried playing with the RTX options, same result


    The machine is a Windows 11, SKP 2023, Enscape 3.5, NVIDIA RTX3090 24GB, 32GB RAM with an AMD Ryzen 9 processor.

    This was very important for our company because per furniture piece I render up to 80 different shots and they all have to be transparent. I'm currently stuck with no way of going forward and in the worst case have to manually edit the white background out of 300+ pictures.

    Demian Gutberlet, sorry for pinging you on a short notice, but if you could have a look, I'd be most grateful.


       

    • Official Post

    ViggoPaulman , I'm very sorry to hear about that of course - While we'll look into this right away I'd reccomend you simply make use of Enscape 3.4 in the meantime: https://enscape3d.com/version-history/


    Also please briefly submit a feedback report for me as detailed here, just so I can try reproducing this right away using your exact settings.


    Thank you Viggo and I appreciate your cooperation!

  • FOUND THE SOLUTION!

    Demian Gutberlet and all others who will ever come across this issue - after testing, experimenting and excluding every possibility, I have found the sollution!


    It's the Fog Setting! Turn ON the Fog!


    At home I have SketchUp 2023 + Enscape 3.5 and this problem/bug never exists if I try to render something. At work SketchUp is still at 2022 which led me to falsely believe that it's the SKP version that causes the problem. But it really is not. Then I experimented with the SketchUp Templates, because I have Enscape settings inside the empty Templates, to have a go-ready scene every time I start a new SKP file. My experiments showed me, that it's not because of the Templates either. It really seems to be the Fog Setting under 'Atmosphere'. Turn it ON!



    When Fog Intensity is 0, even if you have Alpha Channel (ie transparent background) checked in the Output menu, the rendering will come out with the background. Here, 2 examples.


    Turning Fog Intensity to anything other than 0 (in my case I put it on 1), everything falls into place and you get a transparent render. Same renders with Fog set to 1.

  • It seems the Forum does not allow pictures with transparent backgrounds. The last 2 pictures I uploaded came with a black background, but they are really transparent. Proof: you can see there is no white background or sky visible in the Window File Explorer. :)

  • Further tests show that this bug may still be connected to the different versions of SketchUp (2022 and 2023).

    I have a file made with SKP2023. Just tried rendering a scene with a transparent background in Enscape 3.5 installed on SKP2022 with Fog set to 0. The picture came out transparent:


    Same scene with the background:



    Still confused but fact remains - if you're experiencing the bug, turn Fog to something else other than 0.

    Also please notice something weird - in my previous post the transparent PNGs were uploaded with a black background. However this last PNG works just fine...

  • Can confirm this is the case. Had the Alpha Channel bug and came here via Google search. Setting fog to 1% fixes it.


    Edit: Demian Gutberlet Feedback also submitted via the program window button.

  • How about rendering for orthographic views? ... the fog setting is disabled when set to orthographic view. Actually perspective view renders fine as transparent png, but orthographic view always has a white background.