Ensape 3.5.1 - VR Black Screen

Reminder: If you encounter any issues with Enscape (including installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed here. Thank you for your understanding.
  • I fired up enscape and Revit 2021 on my machine today with the intent of jumping into VR on a project. I read somewhere that with 3.5 we do not need Steam VR any more so I was eager to try it out. My quest 2 headset is up to date, connected via a Link Cable, and the oculus app is open on my machine. when I press the VR Headset button in Enscape the quest display goes black but nothing else happens. I can see my boundary within the headset so I know that it is at least working but no model can be seen. It just remains black no matter how long I wait. I have attempted this with both Ray-tracing enabled and disabled with the same results. My laptop has an Nvidia Quadro RTX 5000 with 16GB of VRAM so I would not think the card is an issue here. I also tried the old workflow with Steam VR running but no luck there either.

    Anyone else been having issues with a black screen?

  • Hello there! Let's first try to eliminate some more possibilities for errors.

    - Do you have a black screen too when using Steam VR + Enscape 3.4.4? (I assume so from what you wrote but please confirm again)
    - Can you open another application through Steam successfully? Any free app/game will do.
    - Can you open another application through the Oculus application successfully? Any free app/game will do.

    - Can you also try disabling DLSS?

    Thank you!

  • I reinstalled Enscape 3.4.4 and am able to successfully launch VR in enscape using Steam VR.

    I am able to launch VR in 3.4.4 with DLSS and Raytracing both enabled and disabled.

    I am able to launch an application in Steam VR successfully.

    I am able to launch an application in Oculus successfully.

    I installed Enscape 3.5.1 just to reverify, followed the steps here and am unable to launch VR in Enscape either with or without Steam VR running.

    This time when trying to launch VR the headset would either not respond at all and continue to show the Oculus home environment or it would go to a black screen and not progress.

    I tried with DLSS and Raytracing both enabled and disabled and the result was the same.

  • I tried launching VR using Steam VR and again without Steam VR with OpenXR Runtime set to SteamVR but experience the same results.
    I also tried the same with the oculus as the default Open XR application but still am not able to launch VR.

    I have tested several different files just to make sure it was not a file issue and I have the same problem in all files.

  • Alright so it seems that the OpenXR implementation that is used is set to the SteamVR and not the Oculus implementation. Please follow the below steps to set the Oculus as the default one and tell me if it fixed your issue.

    1. Close Enscape and SteamVR if they’re running.
    2. Open the Oculus application.
    3. Go to Settings on the left side menu.
    4. Go to the General tab.
    5. Press Set Oculus as active.
    6. The button should become inactive.
    7. Try launching Enscape again.

  • I've done this already. My initial testing was done with Oculus set as the OpenXR Runtime. I switched it back to SteamVR for testing purposes. No change in behavior when trying with Oculus set as OpenXR. The Enscape VR still does not launch.

  • Hello again! After looking at the logs, we can see the following two lines:

    [OpenXR] XR_RUNTIME_JSON already set: C:\Program Files\Lenovo\Lenovo VDM\bin\lxropenxr_config.json

    [OpenXR] Current runtime does not support Vulkan.

    XR_RUNTIME_JSON is an environment variable which can be set manually/automatically to specify the OpenXR runtime to use if there are multiple installed. This is set as "C:\Program Files\Lenovo\Lenovo VDM\bin\lxropenxr_config.json" on your computer. Searching for Lenovo VDM, I can only see that it is Lenovo's Virtual Display Manager which is used for the ThinkReality A3 (20V7, 20V8) augmented reality (AR) glasses. Do (or did) you use those on your PC?

    So the solution is to clear that environment variable and ensure that it is not set again by the same application.

    1. First navigate to the environment variables of your machine, find this line and simply delete it. Be sure to check both in the "User" and "System" environment variables.
    2. If you are not using Lenovo Virtual Display or the AR glasses, you could uninstall the software too.

    Please tell me if that helped.

  • Sorry for the late response. I did have the Lenovo VDM installed and have since uninstalled it. I did not understand how to address item number one on the list so I just uninstalled it for testing purposes. I Checked to make sure oculus was set to the the active OpenXR Runtime and launched enscape again. still nothing happens when pressing the VR button in Enscape. My quest 2 stays at the oculus home environment. I submitted another logfile via enscape to further troubleshoot the issue.

  • Thanks for sending again your logs which indicate that there might be a problem and can't find a correct runtime. This means that Lenovo VDM is uninstalled but we don't have the correct path to the Oculus runtime. Let's clean up a bit the different runtimes.

    1. Uninstall SteamVR and Oculus.

    2. Go to the environment variables by following the steps outlined here:

    3. There are two lists of variables, one named "User variables" and one named "System variables". We will need to check in both lists that XR_RUNTIME_JSON is not present. If it is, click on it and then press the Delete button.

    4. Restart your computer.

    5. Install the Oculus software.

    6. Open Enscape.

    7. If the issue is not resolved, then install SteamVR too and set the default OpenXR runtime to SteamVR.

    8. If the issue is not resolved yet again, then I will ask you again to send a new round of feedback and logs to inspect.

    Thanks for staying with me and trying to resolve this.