Sketchup Scenes don't export correct saved view angles on batch rendering

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • I only use perspective. I figured there would be escape documentation on the subject? I tried following your thread but i was a little confused as to the exact process from start to finish on how to get the correct selected scenes to batch render correctly. Can you list steps 1-10? Thanks in advance

  • 1. About Video presets.

    - Don't use auto focus. If You really want to use depth of field make separate presets for each different distant.

    - Batch render doesn't use synchronized view, so be sure to have separate presets for each view with different FOV.

    2. Best would be if You set your views in ENScape preview window. Batch will render as You see it in Enscape not in sKetchup. You can get good results working from sKetchup but it is a bit more confusing.

    3. Of course when You create your views (scenes) link your presets, to every single view.

    If the view is not linked Batch will go for the preset which was selected in the moment of starting the batch render. If You have one basic preset which You use for most of views and just need a few other for couple of views You could not link views which use that basic preset, but than if You forget to choose this preset before starting batch render, You will have to start again.. Done it few times to the point of deciding to just link all.

    4. Use Your default sKetchup scene settings.. I mean each scene remembers tags visibility, hidden geometry, etc. Like with visual presets, batch will go for the tags visible before batch started if they are not saved in the scene.

    5.. difficult to go to 10 pointses.

    Try this.. If You still have problems (I had a lot, honestly I don't know why now it seems so simple), I may add a few points..

  • It's still buggy and it doesn't always render the full view. I'm only using a FOV of 55. If I want the full view rendered I have to render individually. I'm really surprised someone from the actual Enscape team hasn't commented or directed me to the proper set of steps to bach render the exact view chosen. It seems like something that should be easy to find for something so common in the Sketchup workflow.

  • What do You mean it "doesn't render the full view"? Size of the view is defined in the Visual Presets. If it is different in proportions than Your sKetchup model area then it will render differently..

    EDIT

    ...

    But still it would render the same with and without batch.. unless You render with Synchronize View which I wrote in point 1. not to.. Wasn't it explicit enough?

    Even if You use the same 55deg FOV everywhere You still need a preset with correct FOV for batch render.. I mean preset that would work on single render with Synchronized View turned off.

    ...

    ENScape is using horizontal FOV opposite to sKetchup using vertical FOV so usually for wild screen you will have top and bottom cut or added..

    Turn on Render Area to see only the part of view which will be rendered..

  • Look at the two images I attached. The one labeled "correct" is when I export a single image. The image labeled "wrong" is when I batch export. There must be some instructions somewhere. My Camera FOV is 55 and that is a very normal FOV.. I find it hard to believe nobody else has had this problem OR if they had someone would chime in and call me stupid. I really really find it surprising that nobody from the Enscape support team has written a response to me questioning if they even have Enscape support teams.

    @Tomasz Drgas have you seen any actual Enscape provided instructions on best practices for correct batch image creation?

    • Official Post

    ryanfernie , pardon me for not chiming in earlier - Just to make very sure regarding the behavior you detailed with your previous post: You have linked visual settings presets to each of your views and view synchronization is disabled entirely?


    Furthermore please be aware that if you have a visual settings preset linked to that corresponding view you've used as an example where the FOV is set to something else than 55 it will use those settings instead when batch rendering. Otherwise if there is no visual settings preset linked to that view in the first place, make sure to do so using the FOV value of your choice.


    If anything is still unclear or you have any feedback regarding that system, please let me know.

  • ryanfernie I missed that arrow at first too.. But except that.. There is something You are not talking about.
    Cos I thought You did all the 4 points I mentioned. At least Your post suggested You did "but it is still buggy"..

    and I don't know what does the discovery of this little arrow in UI changes.. I mean You have said that all of Your views are with 55 FOV and that manual render does it correctly, which would mean that Visual Settings FOV was correct so doesn't matter if You linked this settings to the view or not Batch would go to the correct VS anyways.. Cos You couldn't create different setting if You didn't know about this little arrow on the left of the UI.
    The only explanation I can think of is that You were working on file created by somebody else. That person created many settings but did not link them. only then there could be a difference between single render and Batch. But That would mean You haven't done the point 3

    Quote

    3. Of course when You create your views (scenes) link your presets, to every single view.

    Which You could do even if You didn't know how to go to the custom presets UI.

    If somebody gives You an instruction which You don't know how to do, ask for more precision, don't pretend You did it. It is my time but Your problem to be solved.
    Unless of course You have some better explanation.

  • I was trying to save settings and FOV's in either the SketchUp scenes or the newly created Escape scenes as we would when normally using Sketchup. Thats why I was having issues. It wasn't until Demian replied that I googled what he wrote "linked visual settings presets" and found the instructions I linked above. Thats when I noticed the arrow and that solved all of my problems once I found how easy it was. I wasn't actually saving settings presets. I was just trying to right-click and update my scene tabs. Thanks For your help Tomasz