Animation with burns and error in the shadows.

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • I recently encountered a major problem with enscape. I start a render and everything is ok but when I start an animation, it starts with the shadow parts completely burned and these shadows move abnormally in the scene. I send video to make you understand better. I also tried with a simple white box and it has the same problem....can anyone tell me something about this serious problem?

  • Go to Best Answer
    • Official Post

    Thanks a lot for your report and the examples attached.


    At least currently this is to be expected in certain scenes but we are already working on replacing our existing filtering/denoising method with an alternative solution that allows us to circumvent this (called NvDenoiser). This improved method will be more capable and advanced, thus also better at handling artifacts/noise and generally unwanted effects like those "abnormal/burning" shadows you've captured.


    While we're in the process of implementation you can expect this improvement to be added with our next releases.


    If any further inquiries come up regarding this or any other subject please let me know.

  • I didn't have this problem before, even with previous versions. I also turned off all raytracing and denoising parameters. Before I had a gtx1070ti and for two months I have mounted a rtx2080super. the problems started since i changed graphics card.

    • Official Post

    GiVi , this might've been less visible depending on the scene or even other factors such as Rendering Quality (which was potentially set to Draft?) when you still had the GTX 1070 Ti installed with a previous release and but it's not an avoidable behavior in current releases (which came out the past years) and it shouldn't be tied to the graphics card used either.


    Furthermore turning off raytracing and denoising is not recommended actually, as doing so will result in artifacts elsewhere without circumventing the main shadow behavior you showcased.


    Just FYI to clarify further there is also an ongoing issue with current releases in which you may experience this behavior during real-time walkthroughs (mainly when you disable our denoiser), this will already be fixed with our upcoming service pack 3.5.2 though.


    I wish I had more positive news and I can understand any frustration caused here but at this point we can only ask for a bit more patience when it comes to implementing the more advanced denoising solution.

  • Is this the same issue? Demian Gutberlet
    I have been using RTX 3050 updated new drivers. I included video for another sample of animation i rendered.
    When i turn off everything on hardware features the problem (shadow of the first frame). i checked on ly Denoiser on, the problem still happen, i checked DLSS on the problem still happen. Turn off all, problem is gone.

    • Official Post

    ElZoel , thanks for your post and further tests as well!


    Depending on the scene turning off DLSS in particular can help make this behavior of "creeping shadows" less visible, but I was still able to reproduce this behavior with DLSS on or off, it was just a bit more subtle when turned off.


    So further, yes, this does seem to be the issue we were discussing, so I'm glad you're more successful in lessening this effect in your scene for now.


    In any case, this will of course be resolved entirely (with DLSS on as well) once we have added the new mentioned denoiser.

    • Official Post

    rifkin , my apologies that no one got back to you via that thread of yours, but this really does seem to boil down to the same problem detailed here. I wish I could already say whether or not the new denoiser will make its way into 3.6, but once I know more I'll also share it.

  • rifkin , my apologies that no one got back to you via that thread of yours, but this really does seem to boil down to the same problem detailed here. I wish I could already say whether or not the new denoiser will make its way into 3.6, but once I know more I'll also share it.

    OK, I can see them being related, but not seeing how DLSS would be a factor in my example. If Enscape literally just rendered each animation frame as a separate still, it would be fine. If I did a screen recording navigating through in real-time, it would be fine. But it is doing something different when it renders the animation. Maybe some sort of "temporal" thing where it looks ahead/behind to find efficiencies, and that is failing?

    • Official Post

    OK, I can see them being related, but not seeing how DLSS would be a factor in my example. If Enscape literally just rendered each animation frame as a separate still, it would be fine. If I did a screen recording navigating through in real-time, it would be fine. But it is doing something different when it renders the animation. Maybe some sort of "temporal" thing where it looks ahead/behind to find efficiencies, and that is failing?

    Pardon for the confusion by bringing DLSS into the mix, allow me to clear up what I meant exactly: While reproducing this behavior myself I noticed that shadows may at times be slightly brighter with DLSS disabled thus this issue may simply be a bit less evident at times, but this did not allow me to circumvent this behavior entirely. Not in my example scenes at least unlike @ElZoel where this seemed to have helped more.


    Still, overall DLSS is not the main culprit here, but instead the current denoiser we are using (not to be confused with the "NVIDIA Denoiser" which you can disable/enable manually) which will be replaced with NRD: https://developer.nvidia.com/rtx/ray-tracing/rt-denoisers (Just in case you like to read into it)


    A more technical but simple explanation why we want to replace the current system: Depending on the scene conditions indirect lighting will remain/stick and not update until that part of the scene is occluded by objects/structures or once out of view - This can thus lead to these harsh borders/"creeping shadows" with regions that were dis-occluded.


    I hope this helps clear it up further. If I missed anything or you have any other questions let me know!

  • i try everything, turn on, turn off one by one, i also rendered still animation (a lot of image frame by frame) the shadow problem is still there. This is happened when rendering interior but on exterior no problem. Maybe the problem from Ray Traced Sun? I dont know.

    This problem is gone and everything is according to what I expected, a still image render and animation rendered in the same good quality even exceeded my expectations when render in 4K image and animation! Awesome. The solution for now is TURN OFF EVERYTHING. But when Denoiser is turn off, my screen full noise.. LoL

  • ElZoel you have tried everything as I have tried. I turned off the settings one by one, but nothing. I set the maximum render quality and always high resolution. Unfortunately this shadow in the initial phase of the animation remains. I solved it in another way, thanks to the rendering speed. I rotate the start part of the animation out of the part I want to fit into the animation. As the camera rotates 90° to the right or left, it leaves out that nasty shadow. I sacrifice the first few seconds of the animation which I then cut in post production. This is the system I have adopted. I forward a video that makes my trick better understood.

  • ElZoel you have tried everything as I have tried. I turned off the settings one by one, but nothing. I set the maximum render quality and always high resolution. Unfortunately this shadow in the initial phase of the animation remains. I solved it in another way, thanks to the rendering speed. I rotate the start part of the animation out of the part I want to fit into the animation. As the camera rotates 90° to the right or left, it leaves out that nasty shadow. I sacrifice the first few seconds of the animation which I then cut in post production. This is the system I have adopted. I forward a video that makes my trick better understood.

    I saw the video you sent, that's the problem we are facing together. But I find it strange why you can't get rid of the problem like me. I managed to get rid of the problem by just disabling everything. I hope a solution like yours can be a temporary solution for others. Thanks for sharing the experience.

  • ElZoel I've been using resolutions beyond 3840 ever since I started using enscape. I always put the quality of render ultra. Fortunately, the power of enscape and its speed allow for all of this. The problem in my opinion depends on the version of Enscape. We hope that future versions will be improved.

  • FWIW,


    I experienced a similar thing a couple of months ago... My interior movie [sweeping across a room] showed extremely strange "Shadows" on the ceiling... For half of the movie, it was fine, but when camera pointed in a certain direction, these "shadows" would appear...


    I tried many things...


    1. was to turn off the outside trees... this seemed to help (assuming was just choking on polygon count) but not totally eliminate the issue...


    2. I also tried making the ceiling slightly emmissive to knock down the shadows... Again about 75% success


    Good to know this is something being worked on...

  • I’m a sketchup user, and I have been experiencing issues with enscape 3.5 while exporting a video. I can’t explain it well but there are some shadow leaks/ light leaks, when hardware-accelerated ray tracing is on. Please fix

  • I tried to render a video like normal but the shadows inside are acting weird, the reason I added the renderer version is because it only happens while renderering as shown in the added video. I've tried alot of different things to fix it but the only fix I found is changing the render quality to the lowest (Draft) any higher isn't possible. I personally think it has something to do regarding the latest update, especially the "NVIDIA shadow denoiser", but even if I turn it off in the settings it still doesn't fix it. This is also the first time I had this problem. I hope someone can help me because the Draft quality is too low.

    Youtube video