Light Bleed Through Solid Object, any ideas?

Reminder: If you encounter any issues with Enscape (including installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Feedback button as detailed here. Thank you for your understanding.
  • I have some shelfs with LED lighing set up, I have a row of small disk lights which fall short of the uprights. However as you can see on the RH side there looks to be light coming through onto the wallpaper in the middle. The LH side looks fine and no bleed. Any idea or tricks people have used in the past. I have tried to angle the disk lights closest to the upright away, but this made no difference. It only seems to be the bottom shelf as well, which is odd!

  • Hi. I'm having the same problem. I've exaggerated the scene to show the issue. The only light source in this image is sphere lights close to the flames. So why aren't the sides of the firepit in shadow? I've had this issue with a lot of models but this is the model I currently have open.

    I know there are other aspects of the flames to work on, but this light bleed through is an immediate issue

    It's an big SketchUp file (252m), so the only way I can share it is with Dropbox.
    I'll start a new thread if no one responds, but no one responded to my last thread, so I deleted it.


  • Hard to know exactly what I going on there. Can you isolate the file down to just an area where this is happening and share it?

    I'll do a saveas and remove several square miles of mountains and trees. I might not get it done today.
    In the meantime, I've replaced the spheres with spots that are angled the right way to avoid the problem. But I would like to solve this issue for other and future models

  • Have you tried raising the light source up a little above the fire?

    Yes, it had no effect. This is the position of my sphere lights. I made sure none of the spheres were in contact with any faces or edges.
    Except that I need to remove some red in the flames, it really looks good. It's just that the firepit allows light to pass through in a very unnatural way.



    I just had a thought that maybe the pit is the problem. Going to try something..... Thank you for your response

  • I had the pit as an eggshell with no interior lining. (Yes, hot pink is my "back" color in SU. I always pick a color I don't like.)


    I made the pit a true solid with a surface for the embers.


    And the issue still exists.
    This pic is with the sphere lights I posted earlier:

    And this pic is with spots.

    As you can see, the sphere light makes the fire look better than the spots, so I hope there is a solution to this.

  • The values of the light sources are too low to create any meaninful contribution (2cdm) - the autoexposure is then lighting it all up to make it look lit.


    Turn of AE and try lighting the scene with a nominal value applied - this will look more like you would expect.


  • In case there is no solution to the problem, I'll show you my alternate solution with spots in case someone has a way to improve it.


    Here is my arrangement.

    I'm showing you here how I positioned the lower spots so the bottom edge is horizontal, so no light would aim into the pit materials.

    Then, since the spots aren't shining outward, I added these upper lights to shine on the faces of the 3 people I will add to the chairs, to make up for the lack of omni lights.


    Ideas for improving this alternate solution is also appreciated.

  • I had tried that earlier but I'll show you how it worked here.

    This is with AE turned off and the manual exposure slid to 100. I still have the problem.


    Are there other settings I can look at? Since you got it to work without adjusting anything in the model, it must be a settings issue. (I've only had Enscape for a few months and YouTube only teaches so much)

  • This is what it looks like with exposure turned to 60% like in the pic you sent.

    ^^

  • I had tried that earlier but I'll show you how it worked here.

    This is with AE turned off and the manual exposure slid to 100. I still have the problem.


    Are there other settings I can look at? Since you got it to work without adjusting anything in the model, it must be a settings issue. (I've only had Enscape for a few months and YouTube only teaches so much)


    it's not the settings so much (except AE) rather the lack of light energy because they lights that are placed are on such low values.

    Turn AE off - in my example I set it to 60


    Then increase the values of the lights - notice how the spheres are bigged in my screenshot - this means they are brighter

    47335-pasted-from-clipboard-png






    Another option to tackle this scene on the whole, which is more efficient is to use some self illumination for the "glowing" things.


    Turn off AE find the materials of the flames


    Change the flame from "generic" to Self Illumination


    change the colour and tint to a nice warm colour and adjust the brightness until the flames look nice.


    You could do the same for the lava

    That will get you something like this


    Now that isn't casting a light onto out seats etc , you could increase the exposure a little more, but there is a good chance this simply isn't pumping enough light and we may introduce noise- self emissive lighting isn't usually enough. So lets place a key light.

    Place a single sphere light , paint it a similar cooler and adjust the brightness until it looks as required



    Now we've achieved a similar effect with a fraction of the number of lights - lights are expensive to use in enscape, so we really want to use as few as possible wherever we can.

  • Then increase the values of the lights - notice how the spheres are bigger in my screenshot - this means they are brighter (Yep. I'm not THAT much of a noob! :D)


    Another option to tackle this scene on the whole, which is more efficient is to use some self illumination for the "glowing" things. That'll be when I get back to the model with all the acreage and trees in place.


    lights are expensive to use in Enscape, so we really want to use as few as possible wherever we can. I knew that from when I learned Thea 8 years ago, but I was out of ideas for solutions here and I was too busy being an architect until the workload eased up recently. (Enscape is much better.)

    I had tried making the png self-illuminating in a different model and it make the entire square illuminate, not just the flame (It was a candle flame in that case) so I didn't bother trying it here.
    I just tried it here with all the spheres and spots turned off and it worked. Also, your advice is the opposite of some video I watched on YT.


    I know the amount and color of light needs fixed next, but I was concentrating on the bleeding problem. I think once the rest of the model is brought back in and I make the adjustments, this should look pretty damn good.


    However, fill lighting bleeding through a solid seems to be a problem worth looking into?


    I thank you very much for your help.